Multiplexed Application Substrate over QUIC Encryption (MASQUE)

Created

  • 2022-06-23

Last Updated

  • 2026-08-28

Available Formats


MASQUE URI Suffixes

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Tommy Pauly, Magnus Westerlund

Reference

Available Formats

Path Segment Description Reference
udp UDP Proxying RFC 9298
ip IP Proxying RFC 9484

HTTP Capsule Types

Expert(s)

  • Lucas Pardue, David Schinazi

Reference

  • RFC 9297: HTTP Datagrams and the Capsule Protocol

Available Formats

Range Registration Procedures
provisional Expert Review
Date field update for provisional registrations First Come First Served
permanent, 0x00-0x3f Standards Action or IESG Approval
permanent, greater than 0x3f Specification Required
first unassigned codepoint Standards Action
values 0x29 * N + 0x17 (for integer values of N) Reserved
Value Capsule Type Status Reference Date Change Controller Contact Notes
0x00 DATAGRAM permanent RFC 9297 2022-06-23 IETF MASQUE Working Group
0x01 ADDRESS_ASSIGN permanent RFC 9484 2023-05-16 IETF MASQUE Working Group
0x02 ADDRESS_REQUEST permanent RFC 9484 2023-05-16 IETF MASQUE Working Group
0x03 ROUTE_ADVERTISEMENT permanent RFC 9484 2023-05-16 IETF MASQUE Working Group
0x08 DATA provisional draft-ietf-httpbis-connect-tcp-12, Section 3 2026-08-06 IETF HTTPBIS Working Group
0x09 FINAL_DATA provisional draft-ietf-httpbis-connect-tcp-12, Section 3 2026-08-06 IETF HTTPBIS Working Group
0x11 COMPRESSION_ASSIGN permanent RFC-ietf-masque-connect-udp-listen-16 2025-10-29 IETF MASQUE Working Group
0x12 COMPRESSION_ACK permanent RFC-ietf-masque-connect-udp-listen-16 2025-10-29 IETF MASQUE Working Group
0x13 COMPRESSION_CLOSE permanent RFC-ietf-masque-connect-udp-listen-16 2025-10-29 IETF MASQUE Working Group
0x243f FULL_NONCE_COUNTER permanent https://portal.3gpp.org/desktopmodules/Specifications/SpecificationDetails.aspx?specificationId=3390 2026-08-27 IETF 3GPP Specifications Manager

Contact Information

Name Contact URI Last Updated
3GPP Specifications Manager 3gppContact&etsi.org 2026-08-27
HTTPBIS Working Group ietf-http-wg&w3.org 2026-08-06
MASQUE Working Group masque&ietf.org 2023-03-06