Hypertext Transfer Protocol (HTTP) Digest Algorithm Values

Created

  • 2002-01-03

Last Updated

  • 2024-02-16

Available Formats


HTTP Digest Algorithm Values

Registration Procedure(s)

  • RFC Required or Specification Required

Expert(s)

  • James Manger

Reference

Note

This registry is deprecated since it lists the algorithms that can be used with the Digest and Want-Digest fields defined in RFC 3230, which has been obsoleted by RFC 9530. While registration is not closed, new registrations are encouraged to use the Hash Algorithms for HTTP Digest Fields registry instead.

Available Formats

Digest Algorithm Description Reference
ADLER32 The ADLER32 algorithm is a checksum specified in RFC 1950 "ZLIB Compressed Data Format". The 32-bit output is encoded in hexadecimal (using between 1 and 8 ASCII characters from 0-9, A-F, and a-f; leading 0's are allowed). For example, ADLER32=03da0195 and ADLER32=3DA0195 are both valid checksums for the 4-byte message "Wiki". RFC 1950; RFC 3309; Paul Millar
CRC32c The CRC32c algorithm is a 32-bit cyclic redundancy check. It achieves a better hamming distance (for better error-detection performance) than many other 32-bit CRC functions. Other places it is used include iSCSI and SCTP. The 32-bit output is encoded in hexadecimal (using between 1 and 8 ASCII characters from 0-9, A-F, and a-f; leading 0's are allowed). For example, CRC32c=0a72a4df and crc32c=A72A4DF are both valid checksums for the 3-byte message "dog". RFC 9260, Appendix A
MD5 The MD5 algorithm, as specified in RFC 1321. The output of this algorithm is encoded using the base64 encoding RFC 4648. RFC 1321; RFC 4648; RFC 5843
SHA The SHA-1 algorithm http://csrc.nist.gov/publications/PubsFIPS.html; National Institute of Standards and Technology. Secure Hash Standard (SHS). FEDERAL INFORMATION PROCESSING STANDARDS PUBLICATION 180-3, U.S. Department of Commerce, October 2008.. The output of this algorithm is encoded using the base64 encoding RFC 4648. http://csrc.nist.gov/publications/PubsFIPS.html; National Institute of Standards and Technology. Secure Hash Standard (SHS). FEDERAL INFORMATION PROCESSING STANDARDS PUBLICATION 180-3, U.S. Department of Commerce, October 2008.; RFC 4648; RFC 5843
SHA-256 The SHA-256 algorithm http://csrc.nist.gov/publications/PubsFIPS.html; National Institute of Standards and Technology. Secure Hash Standard (SHS). FEDERAL INFORMATION PROCESSING STANDARDS PUBLICATION 180-3, U.S. Department of Commerce, October 2008.. The output of this algorithm is encoded using the base64 encoding RFC 4648. http://csrc.nist.gov/publications/PubsFIPS.html; National Institute of Standards and Technology. Secure Hash Standard (SHS). FEDERAL INFORMATION PROCESSING STANDARDS PUBLICATION 180-3, U.S. Department of Commerce, October 2008.; RFC 4648; RFC 5843
SHA-512 The SHA-512 algorithm http://csrc.nist.gov/publications/PubsFIPS.html; National Institute of Standards and Technology. Secure Hash Standard (SHS). FEDERAL INFORMATION PROCESSING STANDARDS PUBLICATION 180-3, U.S. Department of Commerce, October 2008.. The output of this algorithm is encoded using the base64 encoding RFC 4648. http://csrc.nist.gov/publications/PubsFIPS.html; National Institute of Standards and Technology. Secure Hash Standard (SHS). FEDERAL INFORMATION PROCESSING STANDARDS PUBLICATION 180-3, U.S. Department of Commerce, October 2008.; RFC 4648; RFC 5843
UNIXsum The algorithm computed by the UNIX ``sum'' command, as defined by the Single UNIX Specification, Version 2 The Open Group. The Single UNIX Specification, Version 2 - 6 Vol Set for UNIX 98. Document number T912, The Open Group, February 1997.. The output of this algorithm is an ASCII decimal-digit string representing the 16-bit checksum, which is the first word of the output of the UNIX ``sum'' command. The Open Group. The Single UNIX Specification, Version 2 - 6 Vol Set for UNIX 98. Document number T912, The Open Group, February 1997.
UNIXcksum The algorithm computed by the UNIX ``cksum'' command, as defined by the Single UNIX Specification, Version 2 The Open Group. The Single UNIX Specification, Version 2 - 6 Vol Set for UNIX 98. Document number T912, The Open Group, February 1997.. The output of this algorithm is an ASCII digit string representing the 32-bit CRC, which is the first word of the output of the UNIX ``cksum'' command. The Open Group. The Single UNIX Specification, Version 2 - 6 Vol Set for UNIX 98. Document number T912, The Open Group, February 1997.

Hash Algorithms for HTTP Digest Authentication

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 7616: HTTP Digest Access Authentication

Available Formats

Hash Algorithm Digest Size Reference
MD5 128 RFC 7616
SHA-512-256 256 RFC 7616
SHA-256 256 RFC 7616

Contact Information

Name Contact URI Last Updated
Paul Millar paul.millar&desy.de 2012-11-06