IEEE 802 Numbers

Last Updated

  • 2024-11-03

Note

This page has assignments under the control of the IEEE Registration Authority that are of primarily historic interest that and have traditionally been on the IANA web pages. For allocations under the IANA OUI RFC 9542, see the "Ethernet Numbers" IANA web page. Contact information for the IEEE Registration Authority is as follows:

Available Formats


Ethertypes

Registration Procedure(s)

  • Not assigned by IANA. Per RFC 9542, updates to this registry are coordinated with the expert.

Expert(s)

  • Donald Eastlake (primary), Juan Carlos Zuniga (secondary)

Reference

Note

The following list of Ethertypes is contributed unverified information from various sources. See the IEEE Registration Authority web pages at http://standards.ieee.org/develop/regauth for a public list of Ethertypes.

Another list of Ethertypes is maintained by Michael A. Patton and is accessible at:

http://www.cavebear.com/archive/cavebear/Ethernet/index.html

Available Formats

Ethertype (decimal) Ethertype (hex) Exp. Ethernet (decimal) Exp. Ethernet (octal) Description Reference
0000-1500 0000-05DC - - IEEE802.3 Length Field IEEE Std 802.3
0257-0511 0101-01FF - - Old Xerox Experimental values. Invalid as an Ethertype since 1983. Neil Sembower
0512 0200 512 1000 Formerly XEROX PUP. Invalid as an Ethertype since 1983. Use 0x0A00. Boggs, D., J. Shoch, E. Taft, and R. Metcalfe, "PUP: An Internetwork Architecture", XEROX Palo Alto Research Center, CSL-79-10, July 1979; also in IEEE Transactions on Communication, Volume COM-28, Number 4, April 1980.; Neil Sembower
0513 0201 - - Formerly PUP Addr Trans. Invalid as an Ethertype since 1983. Use 0x0A01. Neil Sembower
1024 0400 - - Old Nixdorf private protocol. Invalid as an Ethertype since 1983. Neil Sembower
1536 0600 1536 3000 XEROX NS IDP "The Ethernet, A Local Area Network: Data Link Layer and Physical Layer Specification", AA-K759B-TK, Digital Equipment Corporation, Maynard, MA. Also as: "The Ethernet - A Local Area Network", Version 1.0, Digital Equipment Corporation, Intel Corporation, Xerox Corporation, September 1980. And: "The Ethernet, A Local Area Network: Data Link Layer and Physical Layer Specifications", Digital, Intel and Xerox, November 1982. And: XEROX, "The Ethernet, A Local Area Network: Data Link Layer and Physical Layer Specification", X3T51/80-50, Xerox Corporation, Stamford, CT., October 1980.; Neil Sembower
1632 0660 - - DLOG Neil Sembower
1633 0661 - - DLOG Neil Sembower
2048 0800 513 1001 Internet Protocol version 4 (IPv4) RFC 9542
2049 0801 - - X.75 Internet Neil Sembower
2050 0802 - - NBS Internet Neil Sembower
2051 0803 - - ECMA Internet Neil Sembower
2052 0804 - - Chaosnet Neil Sembower
2053 0805 - - X.25 Level 3 Neil Sembower
2054 0806 - - Address Resolution Protocol (ARP) RFC 9542
2055 0807 - - XNS Compatability Neil Sembower
2056 0808 - - Frame Relay ARP RFC 1701
2076 081C - - Symbolics Private David Plummer
2184-2186 0888-088A - - Xyplex Neil Sembower
2304 0900 - - Ungermann-Bass net debugr Neil Sembower
2560 0A00 - - Xerox IEEE802.3 PUP Neil Sembower
2561 0A01 - - PUP Addr Trans Neil Sembower
2989 0BAD - - Banyan VINES Neil Sembower
2990 0BAE - - VINES Loopback RFC 1701
2991 0BAF - - VINES Echo RFC 1701
4096 1000 - - Berkeley Trailer nego Neil Sembower
4097-4111 1001-100F - - Berkeley Trailer encap/IP Neil Sembower
5632 1600 - - Valid Systems Neil Sembower
8947 22F3 - - TRILL RFC 6325
8948 22F4 - - L2-IS-IS RFC 6325
16962 4242 - - PCS Basic Block Protocol Neil Sembower
21000 5208 - - BBN Simnet Neil Sembower
24576 6000 - - DEC Unassigned (Exp.) Neil Sembower
24577 6001 - - DEC MOP Dump/Load Neil Sembower
24578 6002 - - DEC MOP Remote Console Neil Sembower
24579 6003 - - DEC DECNET Phase IV Route Neil Sembower
24580 6004 - - DEC LAT Neil Sembower
24581 6005 - - DEC Diagnostic Protocol Neil Sembower
24582 6006 - - DEC Customer Protocol Neil Sembower
24583 6007 - - DEC LAVC, SCA Neil Sembower
24584-24585 6008-6009 - - DEC Unassigned Neil Sembower
24592-24596 6010-6014 - - 3Com Corporation Neil Sembower
25944 6558 - - Transparent Ethernet Bridging RFC 1701
25945 6559 - - Raw Frame Relay RFC 1701
28672 7000 - - Ungermann-Bass download Neil Sembower
28674 7002 - - Ungermann-Bass dia/loop Neil Sembower
28704-28713 7020-7029 - - LRT Neil Sembower
28720 7030 - - Proteon Neil Sembower
28724 7034 - - Cabletron Neil Sembower
32771 8003 - - Cronus VLN RFC 824; Daniel Tappan
32772 8004 - - Cronus Direct RFC 824; Daniel Tappan
32773 8005 - - HP Probe Neil Sembower
32774 8006 - - Nestar Neil Sembower
32776 8008 - - AT&T Neil Sembower
32784 8010 - - Excelan Neil Sembower
32787 8013 - - SGI diagnostics Andrew Cherenson
32788 8014 - - SGI network games Andrew Cherenson
32789 8015 - - SGI reserved Andrew Cherenson
32790 8016 - - SGI bounce server Andrew Cherenson
32793 8019 - - Apollo Domain Neil Sembower
32814 802E - - Tymshare Neil Sembower
32815 802F - - Tigan, Inc. Neil Sembower
32821 8035 - - Reverse Address Resolution Protocol (RARP) RFC 903; Joseph Murdock
32822 8036 - - Aeonic Systems Neil Sembower
32824 8038 - - DEC LANBridge Neil Sembower
32825-32828 8039-803C - - DEC Unassigned Neil Sembower
32829 803D - - DEC Ethernet Encryption Neil Sembower
32830 803E - - DEC Unassigned Neil Sembower
32831 803F - - DEC LAN Traffic Monitor Neil Sembower
32832-32834 8040-8042 - - DEC Unassigned Neil Sembower
32836 8044 - - Planning Research Corp. Neil Sembower
32838 8046 - - AT&T Neil Sembower
32839 8047 - - AT&T Neil Sembower
32841 8049 - - ExperData Neil Sembower
32859 805B - - Stanford V Kernel exp. Neil Sembower
32860 805C - - Stanford V Kernel prod. Neil Sembower
32861 805D - - Evans & Sutherland Neil Sembower
32864 8060 - - Little Machines Neil Sembower
32866 8062 - - Counterpoint Computers Neil Sembower
32869 8065 - - Univ. of Mass. @ Amherst Neil Sembower
32870 8066 - - Univ. of Mass. @ Amherst Neil Sembower
32871 8067 - - Veeco Integrated Auto. Neil Sembower
32872 8068 - - General Dynamics Neil Sembower
32873 8069 - - AT&T Neil Sembower
32874 806A - - Autophon Neil Sembower
32876 806C - - ComDesign Neil Sembower
32877 806D - - Computgraphic Corp. Neil Sembower
32878-32887 806E-8077 - - Landmark Graphics Corp. Neil Sembower
32890 807A - - Matra Neil Sembower
32891 807B - - Dansk Data Elektronik Neil Sembower
32892 807C - - Merit Internodal Hans-Werner Braun
32893-32895 807D-807F - - Vitalink Communications Neil Sembower
32896 8080 - - Vitalink TransLAN III Neil Sembower
32897-32899 8081-8083 - - Counterpoint Computers Neil Sembower
32923 809B - - Appletalk Neil Sembower
32924-32926 809C-809E - - Datability Neil Sembower
32927 809F - - Spider Systems Ltd. Neil Sembower
32931 80A3 - - Nixdorf Computers Neil Sembower
32932-32947 80A4-80B3 - - Siemens Gammasonics Inc. Neil Sembower
32960-32963 80C0-80C3 - - DCA Data Exchange Cluster Neil Sembower
32964 80C4 - - Banyan Systems Neil Sembower
32965 80C5 - - Banyan Systems Neil Sembower
32966 80C6 - - Pacer Software Neil Sembower
32967 80C7 - - Applitek Corporation Neil Sembower
32968-32972 80C8-80CC - - Intergraph Corporation Neil Sembower
32973-32974 80CD-80CE - - Harris Corporation Neil Sembower
32975-32978 80CF-80D2 - - Taylor Instrument Neil Sembower
32979-32980 80D3-80D4 - - Rosemount Corporation Neil Sembower
32981 80D5 - - IBM SNA Service on Ether Neil Sembower
32989 80DD - - Varian Associates Neil Sembower
32990-32991 80DE-80DF - - Integrated Solutions TRFS Neil Sembower
32992-32995 80E0-80E3 - - Allen-Bradley Neil Sembower
32996-33008 80E4-80F0 - - Datability Neil Sembower
33010 80F2 - - Retix Neil Sembower
33011 80F3 - - AppleTalk AARP (Kinetics) Neil Sembower
33012-33013 80F4-80F5 - - Kinetics Neil Sembower
33015 80F7 - - Apollo Computer Neil Sembower
33023 80FF - - Wellfleet Communications Neil Sembower
33024 8100 - - Customer VLAN Tag Type (C-Tag, formerly called the Q-Tag) (initially Wellfleet) RFC 9542
33025-33027 8101-8103 - - Wellfleet Communications Neil Sembower
33031-33033 8107-8109 - - Symbolics Private Neil Sembower
33072 8130 - - Hayes Microcomputers Neil Sembower
33073 8131 - - VG Laboratory Systems Neil Sembower
33074-33078 8132-8136 - - Bridge Communications Neil Sembower
33079-33080 8137-8138 - - Novell, Inc. Neil Sembower
33081-33085 8139-813D - - KTI Neil Sembower
33096 8148 - - Logicraft Neil Sembower
33097 8149 - - Network Computing Devices Neil Sembower
33098 814A - - Alpha Micro Neil Sembower
33100 814C - - SNMP Joyce K. Reynolds
33101 814D - - BIIN Neil Sembower
33102 814E - - BIIN Neil Sembower
33103 814F - - Technically Elite Concept Neil Sembower
33104 8150 - - Rational Corp Neil Sembower
33105-33107 8151-8153 - - Qualcomm Neil Sembower
33116-33118 815C-815E - - Computer Protocol Pty Ltd Neil Sembower
33124-33126 8164-8166 - - Charles River Data System Neil Sembower
33149 817D - - XTP Neil Sembower
33150 817E - - SGI/Time Warner prop. Neil Sembower
33152 8180 - - HIPPI-FP encapsulation Neil Sembower
33153 8181 - - STP, HIPPI-ST Neil Sembower
33154 8182 - - Reserved for HIPPI-6400 Neil Sembower
33155 8183 - - Reserved for HIPPI-6400 Neil Sembower
33156-33164 8184-818C - - Silicon Graphics prop. Neil Sembower
33165 818D - - Motorola Computer Neil Sembower
33178-33187 819A-81A3 - - Qualcomm Neil Sembower
33188 81A4 - - ARAI Bunkichi Neil Sembower
33189-33198 81A5-81AE - - RAD Network Devices Neil Sembower
33207-33209 81B7-81B9 - - Xyplex Neil Sembower
33228-33237 81CC-81D5 - - Apricot Computers Neil Sembower
33238-33245 81D6-81DD - - Artisoft Neil Sembower
33254-33263 81E6-81EF - - Polygon Neil Sembower
33264-33266 81F0-81F2 - - Comsat Labs Neil Sembower
33267-33269 81F3-81F5 - - SAIC Neil Sembower
33270-33272 81F6-81F8 - - VG Analytical Neil Sembower
33283-33285 8203-8205 - - Quantum Software Neil Sembower
33313-33314 8221-8222 - - Ascom Banking Systems Neil Sembower
33342-33344 823E-8240 - - Advanced Encryption Syste Neil Sembower
33407-33410 827F-8282 - - Athena Programming Neil Sembower
33379-33386 8263-826A - - Charles River Data System Neil Sembower
33434-33435 829A-829B - - Inst Ind Info Tech Neil Sembower
33436-33451 829C-82AB - - Taurus Controls Neil Sembower
33452-34451 82AC-8693 - - Walker Richer & Quinn Neil Sembower
34452-34461 8694-869D - - Idea Courier Neil Sembower
34462-34465 869E-86A1 - - Computer Network Tech Neil Sembower
34467-34476 86A3-86AC - - Gateway Communications Neil Sembower
34523 86DB - - SECTRA Neil Sembower
34526 86DE - - Delta Controls Neil Sembower
34525 86DD - - Internet Protocol version 6 (IPv6) RFC 9542
34527 86DF - - ATOMIC Joe Touch
34528-34543 86E0-86EF - - Landis & Gyr Powers Neil Sembower
34560-34576 8700-8710 - - Motorola Neil Sembower
34667 876B - - TCP/IP Compression RFC 1144; RFC 1701
34668 876C - - IP Autonomous Systems RFC 1701
34669 876D - - Secure Data RFC 1701
34824 8808 - - IEEE Std 802.3 - Ethernet Passive Optical Network (EPON) EPON; RFC 9542
34825 8809 - - Slow Protocols (Link Aggregation, OAM, etc.) The IEEE Registration Authority
34827 880B - - Point-to-Point Protocol (PPP) RFC 9542
34828 880C - - General Switch Management Protocol (GSMP) RFC 9542
34850 8822 - - Ethernet NIC hardware and software testing Wind River
34887 8847 - - MPLS RFC 5332
34888 8848 - - MPLS with upstream-assigned label RFC 5332
34913 8861 - - Multicast Channel Allocation Protocol (MCAP) RFC 9542
34915 8863 - - PPP over Ethernet (PPPoE) Discovery Stage RFC 2516
34916 8864 - - PPP over Ethernet (PPPoE) Session Stage RFC 2516; RFC 8822
34958 888E - - IEEE Std 802.1X - Port-based network access control The IEEE Registration Authority
34984 88A8 - - IEEE Std 802.1Q - Service VLAN tag identifier (S-Tag) The IEEE Registration Authority
35478-35479 8A96-8A97 - - Invisible Software Neil Sembower
34997 88B5 - - IEEE Std 802 - Local Experimental Ethertype The IEEE Registration Authority
34998 88B6 - - IEEE Std 802 - Local Experimental Ethertype The IEEE Registration Authority
34999 88B7 - - IEEE Std 802 - OUI Extended Ethertype The IEEE Registration Authority
35015 88C7 - - IEEE Std 802.11 - Pre-Authentication (802.11i) The IEEE Registration Authority
35020 88CC - - IEEE Std 802.1AB - Link Layer Discovery Protocol (LLDP) The IEEE Registration Authority
35045 88E5 - - IEEE Std 802.1AE - Media Access Control Security The IEEE Registration Authority
35047 88E7 - - Provider Backbone Bridging Instance tag IEEE Std 802.1Q-2014
35061 88F5 - - IEEE Std 802.1Q - Multiple VLAN Registration Protocol (MVRP) The IEEE Registration Authority
35062 88F6 - - IEEE Std 802.1Q - Multiple Multicast Registration Protocol (MMRP) The IEEE Registration Authority
35063 88F7 - - Precision Time Protocol NIST: IEEE Std 1588; Kang Lee
35085 890D - - IEEE Std 802.11 - Fast Roaming Remote Request (802.11r) The IEEE Registration Authority
35095 8917 - - IEEE Std 802.21 - Media Independent Handover Protocol The IEEE Registration Authority
35113 8929 - - IEEE Std 802.1Qbe - Multiple I-SID Registration Protocol The IEEE Registration Authority
35131 893B - - TRILL Fine Grained Labeling (FGL) RFC 7172
35136 8940 - - IEEE Std 802.1Qbg - ECP Protocol (also used in 802.1BR) The IEEE Registration Authority
35142 8946 - - TRILL RBridge Channel RFC 7178
35143 8947 - - GeoNetworking as defined in ETSI EN 302 636-4-1 The IEEE Registration Authority
35151 894F - - NSH (Network Service Header) RFC 8300
36864 9000 - - Loopback Neil Sembower
36865 9001 - - 3Com(Bridge) XNS Sys Mgmt Neil Sembower
36866 9002 - - 3Com(Bridge) TCP-IP Sys Neil Sembower
36867 9003 - - 3Com(Bridge) loop detect Neil Sembower
39458 9A22 - - Multi-Topology RFC 8377
41197 A0ED - - LoWPAN encapsulation RFC 7973
47082 B7EA - - The Ethertype will be used to identify a "Channel" in which control messages are encapsulated as payload of GRE packets. When a GRE packet tagged with the Ethertype is received, the payload will be handed to the network processor for processing. RFC 8157
65280 FF00 - - BBN VITAL-LanBridge cache private protocol. Neil Sembower
65280-65295 FF00-FF0F - - ISC Bunker Ramo private protocol. Neil Sembower
65535 FFFF - - Reserved RFC 1701

Organizationally Unique Identifiers

Registration Procedure(s)

  • Not assigned by IANA. Per RFC 9542, updates to this registry are coordinated with the expert.

Expert(s)

  • Donald Eastlake (primary), Juan Carlos Zuniga (secondary)

Reference

Note

Another list of Ethernet vendor address components is maintained by Michael A. Patton and is accessible at:

http://www.cavebear.com/archive/cavebear/Ethernet/Ethernet.txt

Available Formats

Hex Name Reference
00000C Cisco
00000E Fujitsu
00000F NeXT
000010 Sytek
00001D Cabletron
000020 DIAB (Data Intdustrier AB)
000022 Visual Technology
00002A TRW
000032 GPT Limited (reassigned from GEC Computers Ltd)
00005A S & Koch
00005E IANA
000065 NetScout Systems, Inc. Ashwani Singhal
00006B MIPS
000077 Interphase Corporation
00007A Ardent
000080 Cray Communications A/S
000089 Cayman Systems Gatorbox
000093 Proteon
00009F Ameristar Technology
0000A2 Wellfleet
0000A3 Network Application Technology
0000A6 NetScout Systems, Inc. (internal assignment, not for products) Ashwani Singhal
0000A7 NCD X-terminals
0000A9 Network Systems
0000AA Xerox Xerox machines
0000B3 CIMLinc
0000B7 Dove Fastnet
0000BC Allen-Bradley
0000C0 Western Digital
0000C5 Farallon phone net card
0000C6 HP Intelligent Networks Operation (formerly Eon Systems)
0000C8 Altos
0000C9 Emulex Terminal Servers
0000D0 Develcon
0000D7 Dartmouth College (NED Router)
0000D8 3Com? Novell? PS/2
0000DD Gould
0000DE Unigraph
0000E2 Acer Counterpoint
0000EF Alantec
0000FD High Level Hardvare (Orion, UK)
000102 BBN BBN internal usage (not registered)
0010D1 BlazeNet
001700 Kabel
0020AF 3COM ???
0020C9 Victron
002094 Cubix
00256D Broadband Forum (BBF)
00802B IMAC ???
00802D Xylogics, Inc. Annex terminal servers
008037 Ericsson Ericsson Group, Telefonaktiebolaget, LM Ericsson Corp. 126 25 STOCKHOLM, SWEDEN, SWEDEN
008064 Wyse Technology / Link Technologies
00808C NetScout Systems, Inc. Ashwani Singhal
0080C2 IEEE 802.1 Committee
0080D3 Shiva
00A03E ATM Forum
00AA00 Intel
00DD00 Ungermann-Bass
00DD01 Ungermann-Bass
020701 Racal InterLan
020406 BBN BBN internal usage (not registered)
026086 Satelcom MegaPac (UK)
02608C 3Com IBM PC; Imagen; Valid; Cisco
02CF1F CMC Masscomp; Silicon Graphics; Prime EXL
080002 3Com (Formerly Bridge)
080003 ACC (Advanced Computer Communications)
080005 Symbolics Symbolics LISP machines
080008 BBN
080009 Hewlett-Packard
08000A Nestar Systems
08000B Unisys
080011 Tektronix, Inc.
080014 Excelan BBN Butterfly, Masscomp, Silicon Graphics
080017 NSC
08001A Data General
08001B Data General
08001E Apollo
080020 Sun Sun machines
080022 NBI
080025 CDC
080026 Norsk Data (Nord)
080027 PCS Computer Systems GmbH
080028 TI Explorer
08002B DEC
08002E Metaphor
08002F Prime Computer Prime 50-Series LHC300
080036 Intergraph CAE stations
080037 Fuji-Xerox
080038 Bull
080039 Spider Systems
080041 DCA Digital Comm. Assoc.
080045 ???? (maybe Xylogics, but they claim not to know this number)
080046 Sony
080047 Sequent
080049 Univation
08004C Encore
08004E BICC
080056 Stanford University
080058 ??? DECsystem-20
08005A IBM
080067 Comdesign
080068 Ridge
080069 Silicon Graphics
08006E Concurrent Masscomp
080075 DDE (Danish Data Elektronik A/S)
08007C Vitalink TransLAN III
080080 XIOS
080086 Imagen/QMS
080087 Xyplex terminal servers
080089 Kinetics AppleTalk-Ethernet interface
08008B Pyramid
08008D XyVision XyVision machines
080090 Retix Inc Bridges
484453 HDS ???
800010 AT&T
AA0000 DEC obsolete
AA0001 DEC obsolete
AA0002 DEC obsolete
AA0003 DEC Global physical address for some DEC machines
AA0004 DEC Local logical address for systems running DECNET

Logical Link Control (LLC) Numbers

Registration Procedure(s)

  • Not assigned by IANA. Per RFC 9542, updates to this registry are coordinated with the expert.

Expert(s)

  • Donald Eastlake (primary), Juan Carlos Zuniga (secondary)

Reference

Note

There is also a public listing of LLC numbers on the IEEE Registration Authority web pages at http://standards.ieee.org/develop/regauth.

The IEEE likes to describe numbers in binary in bit transmission order, which is the opposite of the big-endian order used throughout the Internet protocol documentation.

Available Formats

Link Service Access Point (IEEE Binary) Link Service Access Point (Internet Binary ) Link Service Access Point (Decimal) Description Reference
00000000 00000000 0 Null LSAP The IEEE Registration Authority
01000000 00000010 2 Indiv LLC Sublayer Mgt The IEEE Registration Authority
11000000 00000011 3 Group LLC Sublayer Mgt The IEEE Registration Authority
00100000 00000100 4 SNA Path Control The IEEE Registration Authority
01100000 00000110 6 Reserved (DOD IP) RFC 768; Jon Postel
01110000 00001110 14 PROWAY-LAN The IEEE Registration Authority
01110010 01001110 78 EIA-RS 511 The IEEE Registration Authority
01111010 01011110 94 ISI IP Jon Postel
01110001 10001110 142 PROWAY-LAN The IEEE Registration Authority
01010101 10101010 170 SNAP The IEEE Registration Authority
01111111 11111110 254 ISO CLNS IS 8473 RFC 926; mystery contact
11111111 11111111 255 Global DSAP The IEEE Registration Authority

IANA Link Layer Discovery Protocol (LLDP) TLV Subtypes

Reference

  • RFC 8520: Manufacturer Usage Description Specification
  • RFC 9542: IANA Considerations and IETF Protocol and Documentation Usage for IEEE 802 Parameters

Note

Moved to IANA OUI Ethernet Numbers per RFC 9542.


Contact Information

Name Organization Contact URI Last Updated
Andrew Cherenson arc&sgi.com
Ashwani Singhal Ashwani.Singhal&netscout.com 2010-04-05
Daniel Tappan Tappan&bbn.com
David Plummer DCP&scrc-quabbin.arpa
Hans-Werner Braun HWB&mcr.umich.edu
The IEEE Registration Authority http://standards.ieee.org/develop/regauth/
Jon Postel postel&isi.edu
Joe Touch touch&strayalpha.com 2018-07-26
Joseph Murdock
Joyce K. Reynolds jkrey&isi.edu
mystery contact
Kang Lee kang.lee&nist.gov
Neil Sembower XEROX sembower&eso.mc.xerox.com
Wind River inquiries&windriver.com