Interior Gateway Protocol (IGP) Parameters
IGP Algorithm Types
When this registry is modified, the YANG module iana-igp-algo-types
must be updated as defined in RFC-ietf-lsr-ospf-flex-algo-yang-16.
| Value |
Name |
Description |
Reference |
| 0 |
SPF |
Shortest Path First (SPF) algorithm based on link metric. This
is the standard shortest path algorithm as computed by the IGP
protocol. Consistent with the deployed practice for link-state
protocols, Algorithm 0 permits any node to overwrite the SPF path
with a different path based on its local policy. |
RFC 8665 |
| 1 |
Strict SPF |
Strict Shortest Path First (SPF) algorithm based on link
metric. The algorithm is identical to Algorithm 0 but Algorithm 1
requires that all nodes along the path will honor the SPF routing
decision. Local policy at the node claiming support for Algorithm
1 MUST NOT alter the SPF paths computed by Algorithm 1. |
RFC 8665 |
| 2-127 |
|
Unassigned |
|
| 128-255 |
|
Flexible Algorithms |
RFC 9350, Section 4 |
IGP MSD-Types
- Uma Chunduri, Jeff Tantsura
- RFC 8491: Signaling Maximum SID Depth (MSD) Using IS-IS
- RFC 9702: YANG Data Model for Maximum Segment Identifier (SID) Depth (MSD) Types and MPLS MSD
When this registry is modified, the YANG module iana-msd-types
must be updated as defined in RFC 9702.
IGP Flexible Algorithm Definition Flags
Path Computation Element (PCE) Capability Flags
- RFC 9353: IGP Extension for Path Computation Element Communication Protocol (PCEP) Security Capability Support in PCE Discovery (PCED)
| Bit |
Capability Description |
Reference |
| 0 |
Path computation with GMPLS link constraints |
RFC 5088 |
| 1 |
Bidirectional path computation |
RFC 5088 |
| 2 |
Diverse path computation |
RFC 5088 |
| 3 |
Load-balanced path computation |
RFC 5088 |
| 4 |
Synchronized paths computation |
RFC 5088 |
| 5 |
Support for multiple objective functions |
RFC 5088 |
| 6 |
Support for additive path constraints (max hop count, etc.) |
RFC 5088 |
| 7 |
Support for request prioritization |
RFC 5088 |
| 8 |
Support for multiple requests per message |
RFC 5088 |
| 9 |
Global Concurrent Optimization (GCO) |
RFC 5557 |
| 10 |
P2MP path computation |
RFC 8306 |
| 11 |
Active stateful PCE capability |
RFC 8231 |
| 12 |
Passive stateful PCE capability |
RFC 8231 |
| 13 |
Active Stateful PCE with P2MP |
RFC 8623 |
| 14 |
Passive Stateful PCE with P2MP |
RFC 8623 |
| 15 |
Stateful PCE Initiation with P2MP |
RFC 8623 |
| 16 |
FlowSpec |
RFC 9168 |
| 17 |
TCP-AO Support |
RFC 9353 |
| 18 |
PCEP over TLS support |
RFC 9353 |
| 19-31 |
Unassigned |
|
PCE Discovery (PCED) Sub-TLV Type Indicators
- RFC 9353: IGP Extension for Path Computation Element Communication Protocol (PCEP) Security Capability Support in PCE Discovery (PCED)
IGP Algorithm Type For Computing Flooding Topology
- RFC 9667: Dynamic Flooding on Dense Graphs
IGP Flex-Algorithm Path Computation Rules
- Peter Psenak, Shraddha Hegde
- RFC 9917: IGP Flexible Algorithms Reverse Affinity Constraint
| Sequence Number |
Description |
Reference |
| 1 |
Check if any exclude Administrative Group rule is part of the
Flex-Algorithm Definition. If such exclude rule exists, check if any color
that is part of the exclude rule is also set on the link. If such a color
is set, the link MUST be pruned from the computation. |
RFC 9350, Section 13 |
| 2 |
Check if any exclude SRLG rule is part of the Flex-Algorithm
Definition. If such exclude rule exists, check if the link is part of
any SRLG that is also part of the SRLG exclude rule. If the link is part
of such SRLG, the link MUST be pruned from the computation. |
RFC 9350, Section 13 |
| 3 |
Check if any include-any Administrative Group rule is part of
the Flex-Algorithm Definition. If such include-any rule exists, check if
any color that is part of the include-any rule is also set on the link.
If no such color is set, the link MUST be pruned from the computation. |
RFC 9350, Section 13 |
| 4 |
Check if any include-all Administrative Group rule is part of the
Flex-Algorithm Definition. If such include-all rule exists, check if all
colors that are part of the include-all rule are also set on the link.
If all such colors are not set on the link, the link MUST be pruned from
the computation. |
RFC 9350, Section 13 |
| 5 |
If the Flex-Algorithm Definition uses something other than the
IGP metric (Section 5 of RFC 9350), and such metric
is not advertised for the particular link in a topology for which the
computation is done, such link MUST be pruned from the computation. A metric
of value 0 MUST NOT be assumed in such a case. |
RFC 9350, Section 13 |
| 6 |
Check if any exclude FAEMB rule is part of the Flex-Algorithm
definition. If such exclude rule exists and the link has Maximum Link
Bandwidth advertised, check if the link bandwidth satisfies the FAEMB
rule. If the link does not satisfy the FAEMB rule, the link MUST be pruned
from the Flex-Algorithm computation. |
RFC 9843, Section 6 |
| 7 |
Check if any exclude FAEMD rule is part of the Flex-Algorithm
definition. If such exclude rule exists and the link has Min Unidirectional
link delay advertised, check if the link delay satisfies the FAEMD rule. If
the link does not satisfy the FAEMD rule, the link MUST be pruned from the
Flex-Algorithm computation. |
RFC 9843, Section 6 |
| 8 |
Check if any exclude reverse Admin Group rule is part of the
Flex-Algorithm definition. If such exclude rule exists, check if any Admin
Group that is part of the exclude rule is also set on the link in the reverse
direction. If such Admin Group is set on the link in the reverse direction,
the link MUST be pruned from the computation. |
RFC 9917, Section 11 |
| 9 |
Check if any include-any reverse Admin Group rule is part of the
Flex-Algorithm definition. If such include-any rule exists, check if any Admin
Group that is part of the include-any rule is also set on the link in the
reverse direction. If no such Admin Group is set on the link in the reverse
direction, the link MUST be pruned from the computation. |
RFC 9917, Section 11 |
| 10 |
Check if any include-all reverse Admin Group rule is part of the
Flex-Algorithm definition. If such include-all rule exists, check if all
Admin Groups that are part of the include-all rule are also set on the link
in the reverse direction. If all such Admin Groups are not set on the link in
the reverse direction, the link MUST be pruned from the computation. |
RFC 9917, Section 11 |