Mobile Ad hoc NETwork (MANET) Parameters
Message Types
- Justin Dean, Christoper Dearlove (backup)
- RFC 5444: Generalized Mobile Ad Hoc Network (MANET) Packet/Message Format
- RFC 8245: Rules for Designing Protocols Using the Generalized Packet/Message Format from RFC 5444
| Type |
Description |
Reference |
| 0 |
HELLO : Local signaling |
RFC 6130 |
| 1 |
TC : Topology Control (MANET-wide signaling) |
RFC 7181 |
| 2-223 |
Unassigned |
|
| 224-255 |
Reserved for Experimental Use |
RFC 5444 |
TC Message-Type-specific Message TLV Types
- Justin Dean, Christoper Dearlove (backup)
- RFC 7181: The Optimized Link State Routing Protocol Version 2
| Range |
Registration Procedures |
Note |
| 0-127 |
Reserved |
Common to all Message Types, per RFC 5444 |
| 128-223 |
Expert Review |
|
| 224-255 |
Reserved |
Common to all Message Types, per RFC 5444 |
| Type |
Description |
Reference |
| 0-127 |
Reserved |
RFC 5444 |
| 128-223 |
Unassigned |
|
| 224-255 |
Reserved |
RFC 5444 |
TC Message-Type-specific Address Block TLV Types
- Justin Dean, Christoper Dearlove (backup)
- RFC 7181: The Optimized Link State Routing Protocol Version 2
| Range |
Registration Procedures |
Note |
| 0-127 |
Reserved |
Common to all Message Types, per RFC 5444 |
| 128-223 |
Expert Review |
|
| 224-255 |
Reserved |
Common to all Message Types, per RFC 5444 |
| Type |
Description |
Reference |
| 0-127 |
Reserved |
RFC 5444 |
| 128-223 |
Unassigned |
|
| 224-255 |
Reserved |
RFC 5444 |
Packet TLV Types
- Justin Dean, Christoper Dearlove (backup)
- RFC 5444: Generalized Mobile Ad Hoc Network (MANET) Packet/Message Format
- RFC 8245: Rules for Designing Protocols Using the Generalized Packet/Message Format from RFC 5444
| Type |
Description |
Reference |
| 0-4 |
Unassigned |
|
| 5 |
ICV |
RFC 7182 |
| 6 |
TIMESTAMP |
RFC 7182 |
| 7-223 |
Unassigned |
|
| 224-255 |
Reserved for Experimental Use |
RFC 5444 |
Message TLV Types
- Justin Dean, Christoper Dearlove (backup)
- RFC 5444: Generalized Mobile Ad Hoc Network (MANET) Packet/Message Format
- RFC 7631: TLV Naming in the Mobile Ad Hoc Network (MANET) Generalized Packet/Message Format
- RFC 8245: Rules for Designing Protocols Using the Generalized Packet/Message Format from RFC 5444
| Range |
Registration Procedures |
Note |
| 0-127 |
Expert Review |
|
| 128-223 |
Expert Review |
Reserved for Message Type Specific Message TLVs |
| 224-255 |
Reserved for Experimental Use |
|
| Type |
Description |
Reference |
| 0 |
Defined by Type Extension |
RFC 5497 |
| 1 |
Defined by Type Extension |
RFC 5497 |
| 2-4 |
Unassigned |
|
| 5 |
ICV |
RFC 7182 |
| 6 |
TIMESTAMP |
RFC 7182 |
| 7 |
Defined by Type Extension |
RFC 7181 |
| 8 |
Defined by Type Extension |
RFC 7181 |
| 9-223 |
Unassigned |
|
| 224-255 |
Reserved for Experimental Use |
RFC 5444 |
Type 0 Message TLV Type Extensions
- Justin Dean, Christoper Dearlove (backup)
- RFC 5497: Representing Multi-Value Time in Mobile Ad Hoc Networks (MANETs)
- RFC 7631: TLV Naming in the Mobile Ad Hoc Network (MANET) Generalized Packet/Message Format
| Type Extension |
Name |
Description |
Reference |
| 0 |
INTERVAL_TIME |
The maximum time before another message of the same
type as this message from the same originator should be received |
RFC 5497 |
| 1-223 |
|
Unassigned |
|
| 224-255 |
|
Reserved for Experimental Use |
RFC 5497 |
Type 1 Message TLV Type Extensions
- Justin Dean, Christoper Dearlove (backup)
- RFC 5497: Representing Multi-Value Time in Mobile Ad Hoc Networks (MANETs)
- RFC 7631: TLV Naming in the Mobile Ad Hoc Network (MANET) Generalized Packet/Message Format
| Type Extension |
Name |
Description |
Reference |
| 0 |
VALIDITY_TIME |
The time from receipt of the message during which the
information contained in the message is to be considered valid |
RFC 5497 |
| 1-223 |
|
Unassigned |
|
| 224-255 |
|
Reserved for Experimental Use |
RFC 5497 |
Type 7 Message TLV Type Extensions
- Justin Dean, Christoper Dearlove (backup)
- RFC 7181: The Optimized Link State Routing Protocol Version 2
- RFC 7631: TLV Naming in the Mobile Ad Hoc Network (MANET) Generalized Packet/Message Format
| Type Extension |
Name |
Description |
Reference |
| 0 |
MPR_WILLING |
First (most significant) half octet of Value field
specifies the originating router's willingness to act as a
flooding MPR; subsequent half octets specify the originating
router's willingness to act as a routing MPR, either for the link
metric types reported in an MPR_TYPES TLV (in the same order), or (if
no MPR_TYPES TLV is present) for the single administratively agreed
link metric type |
RFC 7181; RFC 7631; RFC 7722 |
| 1 |
MPR_TYPES |
The link metric types supported on this OLSRv2 interface of
this router (one octet each) |
RFC 7722 |
| 2 |
SOURCE_ROUTE |
Indicates that the originator of the message supports source
route forwarding. No value. |
RFC 8218 |
| 3-223 |
|
Unassigned |
|
| 224-255 |
|
Reserved for Experimental Use |
RFC 7181 |
Type 8 Message TLV Type Extensions
- Justin Dean, Christoper Dearlove (backup)
- RFC 7181: The Optimized Link State Routing Protocol Version 2
- RFC 7631: TLV Naming in the Mobile Ad Hoc Network (MANET) Generalized Packet/Message Format
| Type Extension |
Name |
Description |
Reference |
| 0 |
CONT_SEQ_NUM (COMPLETE) |
Specifies a content sequence number for this complete message. |
RFC 7181 |
| 1 |
CONT_SEQ_NUM (INCOMPLETE) |
Specifies a content sequence number for this incomplete message. |
RFC 7181 |
| 2-223 |
|
Unassigned |
|
| 224-255 |
|
Reserved for Experimental Use |
RFC 7181 |
HELLO Message-Type-specific Message TLV Types
- Justin Dean, Christoper Dearlove (backup)
- RFC 6130: Mobile Ad Hoc Network (MANET) Neighborhood Discovery Protocol (NHDP)
| Range |
Registration Procedures |
Note |
| 0-127 |
Reserved |
Common to all Message Types, RFC 5444 |
| 128-223 |
Expert Review |
|
| 224-255 |
Reserved |
Common to all Message Types, RFC 5444 |
Address Block TLV Types
- Justin Dean, Christoper Dearlove (backup)
- RFC 5444: Generalized Mobile Ad Hoc Network (MANET) Packet/Message Format
- RFC 7631: TLV Naming in the Mobile Ad Hoc Network (MANET) Generalized Packet/Message Format
- RFC 8245: Rules for Designing Protocols Using the Generalized Packet/Message Format from RFC 5444
| Range |
Registration Procedures |
Note |
| 0-127 |
Expert Review |
|
| 128-223 |
Expert Review |
Reserved for Message Type Specific Address Block TLVs |
| 224-255 |
Reserved for Experimental Use |
|
Type 0 Address Block TLV Type Extensions
- Justin Dean, Christoper Dearlove (backup)
- RFC 5497: Representing Multi-Value Time in Mobile Ad Hoc Networks (MANETs)
- RFC 7631: TLV Naming in the Mobile Ad Hoc Network (MANET) Generalized Packet/Message Format
| Type Extension |
Name |
Description |
Reference |
| 0 |
INTERVAL_TIME |
The maximum time before another message of the same
type as this message from the same originator and containing this address should be received |
RFC 5497 |
| 1-223 |
|
Unassigned |
|
| 224-255 |
|
Reserved for Experimental Use |
RFC 5497 |
Type 1 Address Block TLV Type Extensions
- Justin Dean, Christoper Dearlove (backup)
- RFC 5497: Representing Multi-Value Time in Mobile Ad Hoc Networks (MANETs)
- RFC 7631: TLV Naming in the Mobile Ad Hoc Network (MANET) Generalized Packet/Message Format
| Type Extension |
Name |
Description |
Reference |
| 0 |
VALIDITY_TIME |
The time from receipt of the address during which the
information regarding this address is to be considered valid |
RFC 5497 |
| 1-223 |
|
Unassigned |
|
| 224-255 |
|
Reserved for Experimental Use |
RFC 5497 |
Type 2 Address Block TLV Type Extensions
- Justin Dean, Christoper Dearlove (backup)
- RFC 6130: Mobile Ad Hoc Network (MANET) Neighborhood Discovery Protocol (NHDP)
- RFC 7631: TLV Naming in the Mobile Ad Hoc Network (MANET) Generalized Packet/Message Format
Type 3 Address Block TLV Type Extensions
- Justin Dean, Christoper Dearlove (backup)
- RFC 6130: Mobile Ad Hoc Network (MANET) Neighborhood Discovery Protocol (NHDP)
- RFC 7631: TLV Naming in the Mobile Ad Hoc Network (MANET) Generalized Packet/Message Format
Type 4 Address Block TLV Type Extensions
- Justin Dean, Christoper Dearlove (backup)
- RFC 6130: Mobile Ad Hoc Network (MANET) Neighborhood Discovery Protocol (NHDP)
- RFC 7631: TLV Naming in the Mobile Ad Hoc Network (MANET) Generalized Packet/Message Format
LINK_METRIC Address Block TLV Type Extensions
- Justin Dean, Christoper Dearlove (backup)
- RFC 7181: The Optimized Link State Routing Protocol Version 2
Also see the corresponding MIB at IANAolsrv2LinkMetricType-MIB.
| Type Extension |
Description |
Reference |
| 0-7 |
Link metric meaning assigned by administrative action. |
RFC 7181; RFC 7722 |
| 8-223 |
Unassigned |
|
| 224-255 |
Reserved for Experimental Use |
RFC 7181 |
Type 8 Address Block TLV Type Extensions
- Justin Dean, Christoper Dearlove (backup)
- RFC 7181: The Optimized Link State Routing Protocol Version 2
- RFC 7631: TLV Naming in the Mobile Ad Hoc Network (MANET) Generalized Packet/Message Format
Type 9 Address Block TLV Type Extensions
- Justin Dean, Christoper Dearlove (backup)
- RFC 7181: The Optimized Link State Routing Protocol Version 2
- RFC 7631: TLV Naming in the Mobile Ad Hoc Network (MANET) Generalized Packet/Message Format
Type 10 Address Block TLV Type Extensions
- Justin Dean, Christoper Dearlove (backup)
- RFC 7181: The Optimized Link State Routing Protocol Version 2
- RFC 7631: TLV Naming in the Mobile Ad Hoc Network (MANET) Generalized Packet/Message Format
| Type Extension |
Name |
Description |
Reference |
| 0 |
GATEWAY |
Specifies that a given network address is reached
via a gateway on the originating router. The number of hops is indicated
by the Value field, one octet per link metric type reported in an
MPR_TYPES Message TLV (in the same order) or (if no MPR_TYPES Message
TLV is present) using a single octet |
RFC 7181; RFC 7722 |
| 1-223 |
|
Unassigned |
|
| 224-255 |
|
Reserved for Experimental Use |
RFC 7631 |
HELLO Message-Type-specific Address Block TLV Types
- Justin Dean, Christoper Dearlove (backup)
- RFC 6130: Mobile Ad Hoc Network (MANET) Neighborhood Discovery Protocol (NHDP)
| Range |
Registration Procedures |
Note |
| 0-127 |
Reserved |
Common to all Message Types, per RFC 5444 |
| 128-223 |
Expert Review |
|
| 224-255 |
Reserved |
Common to all Message Types, per RFC 5444 |
| Type |
Description |
Reference |
| 0-127 |
Reserved |
RFC 5444 |
| 128 |
SMF_NBR_TYPE |
RFC 6621 |
| 129-223 |
Unassigned |
|
| 224-255 |
Reserved |
RFC 5444 |
ICV Packet TLV Type Extensions
- Justin Dean, Christoper Dearlove (backup)
- RFC 7182: Integrity Check Value and Timestamp TLV Definitions for Mobile Ad Hoc Networks (MANETs)
| Type Extension |
Description |
Reference |
| 0 |
ICV of a packet |
RFC 7182 |
| 1 |
ICV, using a cryptographic function and a hash function, as specified in Section 12 of RFC 7182 |
RFC 7182 |
| 2 |
ICV, using a cryptographic function and a hash function, and including the IP datagram source address, as specified in Section 12 of RFC 7182 |
RFC 7182 |
| 3-251 |
Unassigned |
|
| 252-255 |
Reserved for Experimental Use |
RFC 7182 |
TIMESTAMP Packet TLV Type Extensions
- Justin Dean, Christoper Dearlove (backup)
- RFC 7182: Integrity Check Value and Timestamp TLV Definitions for Mobile Ad Hoc Networks (MANETs)
| Type Extension |
Description |
Reference |
| 0 |
Unsigned timestamp of arbitrary length, given by the TLV Length field. The MANET routing protocol has to define how to interpret this timestamp |
RFC 7182 |
| 1 |
Unsigned 32-bit timestamp, as specified in IEEE 1003.1-2008 (POSIX) |
RFC 7182 |
| 2 |
NTP timestamp format, as defined in RFC 5905 |
RFC 7182 |
| 3 |
Signed timestamp of arbitrary length with no constraints such as monotonicity. In particular, it may represent any random value |
RFC 7182 |
| 4-251 |
Unassigned |
|
| 252-255 |
Reserved for Experimental Use |
RFC 7182 |
ICV Message TLV Type Extensions
- Justin Dean, Christoper Dearlove (backup)
- RFC 7182: Integrity Check Value and Timestamp TLV Definitions for Mobile Ad Hoc Networks (MANETs)
| Type Extension |
Description |
Reference |
| 0 |
ICV of a message |
RFC 7182 |
| 1 |
ICV, using a cryptographic function and a hash function, as specified in Section 12 of RFC 7182 |
RFC 7182 |
| 2 |
ICV, using a cryptographic function and a hash function, and including the IP datagram source address, as specified in Section 12 of RFC 7182 |
RFC 7182 |
| 3-251 |
Unassigned |
|
| 252-255 |
Reserved for Experimental Use |
RFC 7182 |
TIMESTAMP Message TLV Type Extensions
- Justin Dean, Christoper Dearlove (backup)
- RFC 7182: Integrity Check Value and Timestamp TLV Definitions for Mobile Ad Hoc Networks (MANETs)
| Type Extension |
Description |
Reference |
| 0 |
Unsigned timestamp of arbitrary length, given by the TLV Length field. The MANET routing protocol has to define how to interpret this timestamp |
RFC 7182 |
| 1 |
Unsigned 32-bit timestamp, as specified in IEEE 1003.1-2008 (POSIX) |
RFC 7182 |
| 2 |
NTP timestamp format, as defined in RFC 5905 |
RFC 7182 |
| 3 |
Signed timestamp of arbitrary length with no constraints such as monotonicity. In particular, it may represent any random value |
RFC 7182 |
| 4-251 |
Unassigned |
|
| 252-255 |
Reserved for Experimental Use |
RFC 7182 |
ICV Address Block TLV Type Extensions
- Justin Dean, Christoper Dearlove (backup)
- RFC 7182: Integrity Check Value and Timestamp TLV Definitions for Mobile Ad Hoc Networks (MANETs)
| Type Extension |
Description |
Reference |
| 0 |
ICV of an object (e.g. an address) |
RFC 7182 |
| 1 |
ICV, using a cryptographic function and a hash function, as specified in Section 12 of RFC 7182 |
RFC 7182 |
| 2 |
ICV, using a cryptographic function and a hash function, and including the IP datagram source address, as specified in Section 12 of RFC 7182 |
RFC 7182 |
| 3-251 |
Unassigned |
|
| 252-255 |
Reserved for Experimental Use |
RFC 7182 |
TIMESTAMP Address Block TLV Type Extensions
- Justin Dean, Christoper Dearlove (backup)
- RFC 7182: Integrity Check Value and Timestamp TLV Definitions for Mobile Ad Hoc Networks (MANETs)
| Type Extension |
Description |
Reference |
| 0 |
Unsigned timestamp of arbitrary length, given by the TLV Length field. The MANET routing protocol has to define how to interpret this timestamp |
RFC 7182 |
| 1 |
Unsigned 32-bit timestamp, as specified in IEEE 1003.1-2008 (POSIX) |
RFC 7182 |
| 2 |
NTP timestamp format, as defined in RFC 5905 |
RFC 7182 |
| 3 |
Signed timestamp of arbitrary length with no constraints such as monotonicity. In particular, it may represent any random value |
RFC 7182 |
| 4-251 |
Unassigned |
|
| 252-255 |
Reserved for Experimental Use |
RFC 7182 |
Hash Functions
- Justin Dean, Christoper Dearlove (backup)
- RFC 7182: Integrity Check Value and Timestamp TLV Definitions for Mobile Ad Hoc Networks (MANETs)
Cryptographic Functions
- Justin Dean, Christoper Dearlove (backup)
- RFC 7182: Integrity Check Value and Timestamp TLV Definitions for Mobile Ad Hoc Networks (MANETs)
SMF_TYPE Message TLV Type Extensions
- Justin Dean, Christoper Dearlove (backup)
- RFC 6621: Simplified Multicast Forwarding
Specifies relay algorithm supported by the SMF router,
originating the HELLO message, according to Section 11.4.4.
| Type Extension |
Description |
Reference |
| 0-127 |
Unassigned |
|
| 128-255 |
Reserved for Experimental Use |
RFC 6621 |
SMF_NBR_TYPE Address Block TLV Type Extensions
- Justin Dean, Christoper Dearlove (backup)
- RFC 6621: Simplified Multicast Forwarding
Specifies relay algorithm supported by the SMF router corresponding
to the advertised address, according to Section 11.4.4.
| Type Extension |
Description |
Reference |
| 0-127 |
Unassigned |
|
| 128-255 |
Reserved for Experimental Use |
RFC 6621 |
SMF Relay Algorithm IDs
- Justin Dean, Christoper Dearlove (backup)
- RFC 6621: Simplified Multicast Forwarding
A specification requesting an allocation from the 4-127 range from
the SMF Relay Algorithm ID Registry MUST specify the interpretation of
the <value> field (if any).
| Value |
Name |
Description |
Reference |
| 0 |
CF |
Section 4 |
RFC 6621 |
| 1 |
S-MPR |
Appendix B |
RFC 6621 |
| 2 |
E-CDS |
Appendix A |
RFC 6621 |
| 3 |
MPR-CDS |
Appendix C |
RFC 6621 |
| 4-127 |
|
Unassigned |
|
| 128-255 |
|
Reserved for Experimental Use |
RFC 6621 |
LOCAL_IF TLV Values
- Justin Dean, Christoper Dearlove (backup)
- RFC 7188: Optimized Link State Routing Protocol Version 2 (OLSRv2) and MANET Neighborhood Discovery Protocol (NHDP) Extension TLVs
| Value |
Name |
Description |
Reference |
| 0 |
THIS_IF |
The network address is associated with this local interface
of the sending router |
RFC 7188 |
| 1 |
OTHER_IF |
The network address is associated with another local interface
of the sending router |
RFC 7188 |
| 2-223 |
Unassigned |
|
|
| 224-254 |
Reserved for Experimental Use |
|
RFC 7188 |
| 255 |
UNSPECIFIED |
No information about this network address is provided |
RFC 7188 |
LINK_STATUS TLV Values
- Justin Dean, Christoper Dearlove (backup)
- RFC 7188: Optimized Link State Routing Protocol Version 2 (OLSRv2) and MANET Neighborhood Discovery Protocol (NHDP) Extension TLVs
| Value |
Name |
Description |
Reference |
| 0 |
LOST |
The link on this interface from the router with that network
address has been lost |
RFC 7188 |
| 1 |
SYMMETRIC |
The link on this interface from the router with that network
address has the status of symmetric |
RFC 7188 |
| 2 |
HEARD |
The link on this interface from the router with that network
address has the status of heard |
RFC 7188 |
| 3-223 |
Unassigned |
|
|
| 224-254 |
Reserved for Experimental Use |
|
RFC 7188 |
| 255 |
UNSPECIFIED |
No information about this network address is provided |
RFC 7188 |
OTHER_NEIGHB TLV Values
- Justin Dean, Christoper Dearlove (backup)
- RFC 7188: Optimized Link State Routing Protocol Version 2 (OLSRv2) and MANET Neighborhood Discovery Protocol (NHDP) Extension TLVs
| Value |
Name |
Description |
Reference |
| 0 |
LOST |
The neighbor relationship with the router with that network
address has been lost |
RFC 7188 |
| 1 |
SYMMETRIC |
The neighbor relationship with the router with that network
address is symmetric |
RFC 7188 |
| 2-223 |
Unassigned |
|
|
| 224-254 |
Reserved for Experimental Use |
|
RFC 7188 |
| 255 |
UNSPECIFIED |
No information about this network address is provided |
RFC 7188 |
MPR TLV BIT Values
- Justin Dean, Christoper Dearlove (backup)
- RFC 7188: Optimized Link State Routing Protocol Version 2 (OLSRv2) and MANET Neighborhood Discovery Protocol (NHDP) Extension TLVs
| Bit |
Value |
Name |
Description |
Reference |
| First octet bit 7 |
First octet 0x01 |
Flooding |
If set, then the neighbor with that network address has been
selected as flooding MPR |
RFC 7188; RFC 7722 |
| From first octet bit 6 |
From first octet 0x02 |
Routing |
If set, then the neighbor with that network address has been
selected as routing MPR, either for the link metric types reported in an
MPR_TYPES TLV (in the same order), or (if no MPR_TYPES TLV is present)
then (first octet bit 6, value 0x02) for the single administratively
agreed link metric type |
RFC 7188; RFC 7722 |
NBR_ADDR_TYPE Address Block TLV Bit Values
- Justin Dean, Christoper Dearlove (backup)
- RFC 7188: Optimized Link State Routing Protocol Version 2 (OLSRv2) and MANET Neighborhood Discovery Protocol (NHDP) Extension TLVs
| Bit |
Value |
Name |
Description |
Reference |
| 7 |
0x01 |
ORIGINATOR |
The network address is an originator address reachable via the
originating router |
RFC 7188 |
| 6 |
0x02 |
ROUTABLE |
The network address is a routable address reachable via the
originating router |
RFC 7188 |
| 0-5 |
|
Unassigned |
|
RFC 7188 |