Open Shortest Path First (OSPF) Authentication Codes

Last Updated

  • 2015-04-14

Available Formats


Authentication Codes

Registration Procedure(s)

  • IETF Review

Reference

Note

The Open Shortest Path First (OSPF) protocols has a provision for authentication, and the type of authentication can be indicated by a code number.

Available Formats

Code Authentication Method Reference
0 No Authentication RFC 1583
1 Simple Password Authentication RFC 1583
2 Cryptographic authentication RFC 2328; RFC 5709
3 Cryptographic Authentication with Extended Sequence Numbers RFC 7474
4-255 Unassigned
256-65535 Deprecated RFC 6549