Open Shortest Path First v2 (OSPFv2) Parameters
Created
- 2007-04-25
Last Updated
- 2026-05-22
Note
Please also see:
- Open Shortest Path First (OSPF) Authentication Codes
- Bandwidth Constraints Model Identifiers
- OSPF Database Description (DD) Packet Flags
- Open Shortest Path First (OSPF) Link Local Signalling (LLS) - Type/Length/Value Identifiers (TLV)
- Open Shortest Path First (OSPF) Opaque Link-State Advertisements (LSA) Option Types
- Open Shortest Path First (OSPF) Multi-Topology Routing
- Open Shortest Path First (OSPF) Signature Algorithms
- Open Shortest Path First (OSPF) Traffic Engineering TLVs
- Open Shortest Path First (OSPF) Parameters
Available Formats
OSPFv2 Options Registry (8 bits)
Registration Procedure(s)
- Standards Action
Reference
- RFC 4940: IANA Considerations for OSPF
Available Formats
OSPF Packet Type (both v2 and v3)
Reference
Available Formats
| Range | Registration Procedures |
|---|---|
| 1-127 | Standards Action |
| 128-255 | Reserved |
OSPFv2 Link State (LS) Type
Reference
Available Formats
| Range | Registration Procedures |
|---|---|
| 1-127 | Standards Action |
| 128-255 | Reserved |
| Value | Description | Reference |
|---|---|---|
| 0 | Reserved | RFC 4940 |
| 1 | Router-LSA | RFC 2328 |
| 2 | Network-LSA | RFC 2328 |
| 3 | Summary-LSA (IP network) | RFC 2328 |
| 4 | Summary-LSA (ASBR) | RFC 2328 |
| 5 | AS-external-LSA | RFC 2328 |
| 6 | Group-membership-LSA | RFC 1584; RFC 5110 |
| 7 | NSSA AS-external LSA | RFC 3101 |
| 8 | Reserved | |
| 9 | Link-scoped Opaque LSA | RFC 5250 |
| 10 | Area-scoped Opaque LSA | RFC 5250 |
| 11 | AS-scoped Opaque LSA | RFC 5250 |
| 12-127 | Unassigned | |
| 128-255 | Reserved |
OSPFv2 Router LSA Link Type (Value 1)
Reference
- RFC 4940: IANA Considerations for OSPF
Available Formats
| Range | Registration Procedures |
|---|---|
| 1-127 | Standards Action |
| 128-255 | Reserved |
OSPFv2 Router Properties Registry
Registration Procedure(s)
- Standards Action
Reference
- RFC 4940: IANA Considerations for OSPF
Available Formats
OSPFv2 Grace LSA Top Level TLV
Reference
- RFC 4940: IANA Considerations for OSPF
Available Formats
| Range | Registration Procedures | Note |
|---|---|---|
| 1-255 | Standards Action | |
| 256-65519 | Reserved | IANA does not assign |
| 65520-65527 | Experimentation | IANA does not assign |
| 65528-65535 | Vendor Private Use | IANA does not assign |
Path Computation Element (PCE) Capability Flags
Reference
- RFC 9353: IGP Extension for Path Computation Element Communication Protocol (PCEP) Security Capability Support in PCE Discovery (PCED)
Note
Moved to Interior Gateway Protocol (IGP) Parameters per RFC 9353.
OSPFv2 Instance IDs
Registration Procedure(s)
- Standards Action
Reference
- RFC 6549: OSPFv2 Multi-Instance Extensions
Available Formats
OSPFv2 Extended Prefix Opaque LSA TLVs
Registration Procedure(s)
- IETF Review or IESG Approval
Reference
- RFC 7684: OSPFv2 Prefix/Link Attribute Advertisement
Available Formats
OSPFv2 Extended Prefix TLV Sub-TLVs
Registration Procedure(s)
- IETF Review or IESG Approval
Reference
- RFC 7684: OSPFv2 Prefix/Link Attribute Advertisement
Available Formats
| Value | Description | Reference |
|---|---|---|
| 0 | Reserved | RFC 7684 |
| 1 | SID/Label Sub-TLV | RFC 8665 |
| 2 | Prefix-SID Sub-TLV | RFC 8665 |
| 3 | Flexible Algorithm Prefix Metric (FAPM) | RFC 9350, Section 9 |
| 4 | Prefix Source OSPF Router-ID | RFC 9084 |
| 5 | Prefix Source Router Address | RFC 9084 |
| 6 | OSPFv2 IP Algorithm Prefix Reachability | RFC 9502, Section 6.3 |
| 7 | OSPFv2 IP Forwarding Address | RFC 9502, Section 6.3.1 |
| 8 | Unassigned | |
| 9 | BIER Sub-TLV | RFC 8444 |
| 10 | BIER MPLS Encapsulation Sub-TLV | RFC 8444 |
| 11 | OSPFv2 Prefix Extended Flags | RFC 9792 |
| 12 | BIER PHP Request | RFC-ietf-bier-php-16 |
| 13 | Administrative Tag | RFC 9825 |
| 14-32767 | Unassigned | |
| 32768-33023 | Reserved for Experimental Use | RFC 7684 |
| 33024-65535 | Reserved | RFC 7684 |
OSPFv2 Extended Prefix TLV Flags
Registration Procedure(s)
- IETF Review or IESG Approval
Reference
- RFC 7684: OSPFv2 Prefix/Link Attribute Advertisement
Available Formats
OSPFv2 Extended Link Opaque LSA TLVs
Registration Procedure(s)
- IETF Review or IESG Approval
Reference
- RFC 7684: OSPFv2 Prefix/Link Attribute Advertisement
Available Formats
OSPFv2 Extended Link TLV Sub-TLVs
Registration Procedure(s)
- IETF Review or IESG Approval
Reference
- RFC 7684: OSPFv2 Prefix/Link Attribute Advertisement
- RFC 9356: Advertising Layer 2 Bundle Member Link Attributes in OSPF
Note
The "L2BM" column indicates applicability to the L2 Bundle Attributes Member sub-TLV. The options for the "L2BM" column are:
Y - This sub-TLV MAY appear in the L2 Bundle Member Attributes sub-TLV.
N - This sub-TLV MUST NOT appear in the L2 Bundle Member Attributes sub-TLV.
Available Formats
| Value | Designation | L2BM | Reference |
|---|---|---|---|
| 0 | Reserved | RFC 7684 | |
| 1 | SID/Label Sub-TLV | N | RFC 8665 |
| 2 | Adj-SID Sub-TLV | Y | RFC 8665 |
| 3 | LAN Adj-SID/Label Sub-TLV | Y | RFC 8665 |
| 4 | Network-to-Router Metric Sub-TLV | N | RFC 8042 |
| 5 | RTM Capability | N | RFC 8169 |
| 6 | OSPFv2 Link MSD | N | RFC 8476 |
| 7 | Graceful-Link-Shutdown Sub-TLV | N | RFC 8379 |
| 8 | Remote IPv4 Address Sub-TLV | N | RFC 8379 |
| 9 | Local/Remote Interface ID Sub-TLV | N | RFC 8379 |
| 10 | Application-Specific Link Attributes | Y | RFC 9492 |
| 11 | Shared Risk Link Group | Y | RFC 9492 |
| 12 | Unidirectional Link Delay | Y | RFC 9492 |
| 13 | Min/Max Unidirectional Link Delay | Y | RFC 9492 |
| 14 | Unidirectional Delay Variation | Y | RFC 9492 |
| 15 | Unidirectional Link Loss | Y | RFC 9492 |
| 16 | Unidirectional Residual Bandwidth | Y | RFC 9492 |
| 17 | Unidirectional Available Bandwidth | Y | RFC 9492 |
| 18 | Unidirectional Utilized Bandwidth | Y | RFC 9492 |
| 19 | Administrative Group | Y | RFC 9492 |
| 20 | Extended Administrative Group | Y | RFC 9492 |
| 21 | OSPFv2 Link Attributes Bits | Y | RFC 9667 |
| 22 | TE Metric | Y | RFC 9492 |
| 23 | Maximum link bandwidth | Y | RFC 9492 |
| 24 | L2 Bundle Member Attributes | N | RFC 9356 |
| 25 | Generic Metric | Y | RFC 9843, Section 2.2 |
| 26-32767 | Unassigned | ||
| 32768-33023 | Reserved for Experimental Use | RFC 7684 | |
| 33024-65535 | Reserved | RFC 7684 |
OSPFv2 Extended Inter-Area ASBR TLVs
Registration Procedure(s)
- IETF Review or IESG Approval
Reference
- RFC 9350: IGP Flexible Algorithm
Available Formats
OSPFv2 Extended Inter-Area ASBR Sub-TLVs
Registration Procedure(s)
- IETF Review or IESG Approval
Reference
- RFC 9350: IGP Flexible Algorithm
Available Formats
| Value | Description | Reference |
|---|---|---|
| 0 | Reserved | RFC 9350 |
| 1 | OSPF Flexible Algorithm ASBR Metric | RFC 9350 |
| 2 | OSPF IP Flexible Algorithm ASBR Metric | RFC 9502, Section 6.5 |
| 3-32767 | Unassigned | |
| 32768-33023 | Reserved for Experimental Use | RFC 9350 |
| 33024-65535 | Reserved | RFC 9350 |
IP Algorithm Prefix Reachability Sub-TLV Flags
Registration Procedure(s)
- IETF Review or IESG Approval
Reference
- RFC 9502: IGP Flexible Algorithm in IP Networks
Available Formats
| Bit | Name | Reference |
|---|---|---|
| 0 | bit E | RFC 9502, Section 6.3 |
| 1-7 | Unassigned |
OSPFv2 Prefix Extended Flags
Registration Procedure(s)
- IETF Review
Reference
- RFC 9792: Prefix Flag Extension for OSPFv2 and OSPFv3
Note
Per RFC 9792, IANA will add subsequent blocks of 32 bits upon exhaustion of the preceding 32-bit block.
Available Formats
| Bit | Description | Reference |
|---|---|---|
| 0 | U-Flag | RFC 9929, Section 4.2 |
| 1 | UP-Flag | RFC 9929, Section 4.2 |
| 2-31 | Unassigned |