RADIUS Types

Last Updated

  • 2026-10-09

Note

The RFC "Remote Authentication Dial In User Service (RADIUS)" RFC 2865 defines a Packet Type Code and an Attribute Type Code. The IANA registry of these codes and subordinate assigned values is listed here according to RFC 3575.

Available Formats


RADIUS Attribute Types

Reference

  • RFC 3575: IANA Considerations for RADIUS (Remote Authentication Dial In User Service)
  • RFC 6929: Remote Authentication Dial In User Service (RADIUS) Protocol Extensions
  • RFC 8044: Data Types in RADIUS

Note

Specifications which would allocate more than 20 percent of the remaining standard space attributes should have all allocations made from the extended space. Otherwise, specifications allocating fewer than 10 attributes should have allocations made in the standard space. Specifications which allocate a data type TLV should receive an allocation from the extended space. Specifications requesting allocation of an attribute which can transport 253 or more octets of data should have that attribute allocated from within the long extended space. See Section 10.3.4 of RFC 6929.

Available Formats

Range Registration Procedures
1-191 IETF Review
192-240 Reserved for Private Use
224-240 Implementation Specific
241-246 (extended space, Unassigned) IETF Review
241-246 (extended space, Reserved) Standards Action
247-255 Reserved
Value Description Data Type Reference
1 User-Name text RFC 2865
2 User-Password string RFC 2865
3 CHAP-Password string RFC 2865
4 NAS-IP-Address ipv4addr RFC 2865
5 NAS-Port integer RFC 2865
6 Service-Type enum RFC 2865
7 Framed-Protocol enum RFC 2865
8 Framed-IP-Address ipv4addr RFC 2865
9 Framed-IP-Netmask ipv4addr RFC 2865
10 Framed-Routing enum RFC 2865
11 Filter-Id text RFC 2865
12 Framed-MTU integer RFC 2865
13 Framed-Compression enum RFC 2865
14 Login-IP-Host ipv4addr RFC 2865
15 Login-Service enum RFC 2865
16 Login-TCP-Port integer RFC 2865
17 Unassigned
18 Reply-Message text RFC 2865
19 Callback-Number text RFC 2865
20 Callback-Id text RFC 2865
21 Unassigned
22 Framed-Route text RFC 2865
23 Framed-IPX-Network ipv4addr RFC 2865
24 State string RFC 2865
25 Class string RFC 2865
26 Vendor-Specific vsa RFC 2865
27 Session-Timeout integer RFC 2865
28 Idle-Timeout integer RFC 2865
29 Termination-Action enum RFC 2865
30 Called-Station-Id text RFC 2865
31 Calling-Station-Id text RFC 2865
32 NAS-Identifier text RFC 2865
33 Proxy-State string RFC 2865
34 Login-LAT-Service text RFC 2865
35 Login-LAT-Node text RFC 2865
36 Login-LAT-Group string RFC 2865
37 Framed-AppleTalk-Link integer RFC 2865
38 Framed-AppleTalk-Network integer RFC 2865
39 Framed-AppleTalk-Zone text RFC 2865
40 Acct-Status-Type enum RFC 2866
41 Acct-Delay-Time integer RFC 2866
42 Acct-Input-Octets integer RFC 2866
43 Acct-Output-Octets integer RFC 2866
44 Acct-Session-Id text RFC 2866
45 Acct-Authentic enum RFC 2866
46 Acct-Session-Time integer RFC 2866
47 Acct-Input-Packets integer RFC 2866
48 Acct-Output-Packets integer RFC 2866
49 Acct-Terminate-Cause enum RFC 2866
50 Acct-Multi-Session-Id text RFC 2866
51 Acct-Link-Count integer RFC 2866
52 Acct-Input-Gigawords integer RFC 2869
53 Acct-Output-Gigawords integer RFC 2869
54 Unassigned
55 Event-Timestamp time RFC 2869
56 Egress-VLANID integer RFC 4675
57 Ingress-Filters enum RFC 4675
58 Egress-VLAN-Name text RFC 4675
59 User-Priority-Table string RFC 4675
60 CHAP-Challenge string RFC 2865
61 NAS-Port-Type enum RFC 2865
62 Port-Limit integer RFC 2865
63 Login-LAT-Port text RFC 2865
64 Tunnel-Type enum RFC 2868
65 Tunnel-Medium-Type enum RFC 2868
66 Tunnel-Client-Endpoint text RFC 2868
67 Tunnel-Server-Endpoint text RFC 2868
68 Acct-Tunnel-Connection text RFC 2867
69 Tunnel-Password string RFC 2868
70 ARAP-Password string RFC 2869
71 ARAP-Features string RFC 2869
72 ARAP-Zone-Access enum RFC 2869
73 ARAP-Security integer RFC 2869
74 ARAP-Security-Data text RFC 2869
75 Password-Retry integer RFC 2869
76 Prompt enum RFC 2869
77 Connect-Info text RFC 2869
78 Configuration-Token text RFC 2869
79 EAP-Message concat RFC 2869
80 Message-Authenticator string RFC 2869
81 Tunnel-Private-Group-ID text RFC 2868
82 Tunnel-Assignment-ID text RFC 2868
83 Tunnel-Preference integer RFC 2868
84 ARAP-Challenge-Response string RFC 2869
85 Acct-Interim-Interval integer RFC 2869
86 Acct-Tunnel-Packets-Lost integer RFC 2867
87 NAS-Port-Id text RFC 2869
88 Framed-Pool text RFC 2869
89 CUI string RFC 4372
90 Tunnel-Client-Auth-ID text RFC 2868
91 Tunnel-Server-Auth-ID text RFC 2868
92 NAS-Filter-Rule text RFC 4849
93 Unassigned
94 Originating-Line-Info string RFC 7155
95 NAS-IPv6-Address ipv6addr RFC 3162
96 Framed-Interface-Id ifid RFC 3162
97 Framed-IPv6-Prefix ipv6prefix RFC 3162
98 Login-IPv6-Host ipv6addr RFC 3162
99 Framed-IPv6-Route text RFC 3162
100 Framed-IPv6-Pool text RFC 3162
101 Error-Cause Attribute enum RFC 3576
102 EAP-Key-Name string RFC 4072; RFC 7268
103 Digest-Response text RFC 5090
104 Digest-Realm text RFC 5090
105 Digest-Nonce text RFC 5090
106 Digest-Response-Auth text RFC 5090
107 Digest-Nextnonce text RFC 5090
108 Digest-Method text RFC 5090
109 Digest-URI text RFC 5090
110 Digest-Qop text RFC 5090
111 Digest-Algorithm text RFC 5090
112 Digest-Entity-Body-Hash text RFC 5090
113 Digest-CNonce text RFC 5090
114 Digest-Nonce-Count text RFC 5090
115 Digest-Username text RFC 5090
116 Digest-Opaque text RFC 5090
117 Digest-Auth-Param text RFC 5090
118 Digest-AKA-Auts text RFC 5090
119 Digest-Domain text RFC 5090
120 Digest-Stale text RFC 5090
121 Digest-HA1 text RFC 5090
122 SIP-AOR text RFC 5090
123 Delegated-IPv6-Prefix ipv6prefix RFC 4818
124 MIP6-Feature-Vector integer64 RFC 5447
125 MIP6-Home-Link-Prefix string RFC 5447
126 Operator-Name text RFC 5580
127 Location-Information string RFC 5580
128 Location-Data string RFC 5580
129 Basic-Location-Policy-Rules string RFC 5580
130 Extended-Location-Policy-Rules string RFC 5580
131 Location-Capable enum RFC 5580
132 Requested-Location-Info enum RFC 5580
133 Framed-Management-Protocol enum RFC 5607
134 Management-Transport-Protection enum RFC 5607
135 Management-Policy-Id text RFC 5607
136 Management-Privilege-Level integer RFC 5607
137 PKM-SS-Cert concat RFC 5904
138 PKM-CA-Cert concat RFC 5904
139 PKM-Config-Settings string RFC 5904
140 PKM-Cryptosuite-List string RFC 5904
141 PKM-SAID text RFC 5904
142 PKM-SA-Descriptor string RFC 5904
143 PKM-Auth-Key string RFC 5904
144 DS-Lite-Tunnel-Name string RFC 6519
145 Mobile-Node-Identifier string RFC 6572
146 Service-Selection text RFC 6572
147 PMIP6-Home-LMA-IPv6-Address ipv6addr RFC 6572
148 PMIP6-Visited-LMA-IPv6-Address ipv6addr RFC 6572
149 PMIP6-Home-LMA-IPv4-Address ipv4addr RFC 6572
150 PMIP6-Visited-LMA-IPv4-Address ipv4addr RFC 6572
151 PMIP6-Home-HN-Prefix ipv6prefix RFC 6572
152 PMIP6-Visited-HN-Prefix ipv6prefix RFC 6572
153 PMIP6-Home-Interface-ID ifid RFC 6572
154 PMIP6-Visited-Interface-ID ifid RFC 6572
155 PMIP6-Home-IPv4-HoA ipv4prefix RFC 6572
156 PMIP6-Visited-IPv4-HoA ipv4prefix RFC 6572
157 PMIP6-Home-DHCP4-Server-Address ipv4addr RFC 6572
158 PMIP6-Visited-DHCP4-Server-Address ipv4addr RFC 6572
159 PMIP6-Home-DHCP6-Server-Address ipv6addr RFC 6572
160 PMIP6-Visited-DHCP6-Server-Address ipv6addr RFC 6572
161 PMIP6-Home-IPv4-Gateway ipv4addr RFC 6572
162 PMIP6-Visited-IPv4-Gateway ipv4addr RFC 6572
163 EAP-Lower-Layer enum RFC 6677
164 GSS-Acceptor-Service-Name text RFC 7055
165 GSS-Acceptor-Host-Name text RFC 7055
166 GSS-Acceptor-Service-Specifics text RFC 7055
167 GSS-Acceptor-Realm-Name text RFC 7055
168 Framed-IPv6-Address ipv6addr RFC 6911
169 DNS-Server-IPv6-Address ipv6addr RFC 6911
170 Route-IPv6-Information ipv6prefix RFC 6911
171 Delegated-IPv6-Prefix-Pool text RFC 6911
172 Stateful-IPv6-Address-Pool text RFC 6911
173 IPv6-6rd-Configuration tlv RFC 6930
174 Allowed-Called-Station-Id text RFC 7268
175 EAP-Peer-Id string RFC 7268
176 EAP-Server-Id string RFC 7268
177 Mobility-Domain-Id integer RFC 7268
178 Preauth-Timeout integer RFC 7268
179 Network-Id-Name string RFC 7268
180 EAPoL-Announcement concat RFC 7268
181 WLAN-HESSID text RFC 7268
182 WLAN-Venue-Info integer RFC 7268
183 WLAN-Venue-Language string RFC 7268
184 WLAN-Venue-Name text RFC 7268
185 WLAN-Reason-Code integer RFC 7268
186 WLAN-Pairwise-Cipher integer RFC 7268
187 WLAN-Group-Cipher integer RFC 7268
188 WLAN-AKM-Suite integer RFC 7268
189 WLAN-Group-Mgmt-Cipher integer RFC 7268
190 WLAN-RF-Band integer RFC 7268
191 Unassigned
192-223 Experimental Use RFC 3575
224-240 Implementation Specific RFC 3575
241 Extended-Attribute-1 extended RFC 6929
241.1 Frag-Status integer RFC 7499
241.2 Proxy-State-Length integer RFC 7499
241.3 Response-Length integer RFC 7930
241.4 Original-Packet-Code integer RFC 7930
241.5 IP-Port-Limit-Info tlv RFC 8045, Section 3.1.1
241.6 IP-Port-Range tlv RFC 8045, Section 3.1.2
241.7 IP-Port-Forwarding-Map tlv RFC 8045, Section 3.1.3
241.8 Operator-NAS-Identifier string RFC 8559
241.9 Softwire46-Configuration tlv RFC 8658, Section 3.1
241.10 Softwire46-Priority tlv RFC 8658, Section 3.2
241.11 Softwire46-Multicast tlv RFC 8658, Section 3.3
241.12 User-Access-Group-ID string RFC 10065
241.{13-25} Unassigned
241.26 Extended-Vendor-Specific-1 evs RFC 6929
241.{27-240} Unassigned
241.{241-255} Reserved RFC 6929
242 Extended-Attribute-2 extended RFC 6929
242.{1-25} Unassigned
242.26 Extended-Vendor-Specific-2 evs RFC 6929
242.{27-240} Unassigned
242.{241-255} Reserved RFC 6929
243 Extended-Attribute-3 extended RFC 6929
243.{1-25} Unassigned
243.26 Extended-Vendor-Specific-3 evs RFC 6929
243.{27-240} Unassigned
243.{241-255} Reserved RFC 6929
244 Extended-Attribute-4 extended RFC 6929
244.{1-25} Unassigned
244.26 Extended-Vendor-Specific-4 evs RFC 6929
244.{27-240} Unassigned
244.{241-255} Reserved RFC 6929
245 Extended-Attribute-5 long-extended RFC 6929
245.1 SAML-Assertion text RFC 7833
245.2 SAML-Protocol text RFC 7833
245.3 DHCPv6-Options string RFC 9445
245.4 DHCPv4-Options string RFC 9445
245.{5-25} Unassigned
245.26 Extended-Vendor-Specific-5 evs RFC 6929
245.{27-240} Unassigned
245.{241-255} Reserved RFC 6929
246 Extended-Attribute-6 long-extended RFC 6929
246.{1-25} Unassigned
246.26 Extended-Vendor-Specific-6 evs RFC 6929
246.{27-240} Unassigned
246.{241-255} Reserved RFC 6929
247-255 Reserved RFC 3575

Values for RADIUS Attribute 6, Service-Type

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 2865: Remote Authentication Dial In User Service (RADIUS)
  • RFC 3575: IANA Considerations for RADIUS (Remote Authentication Dial In User Service)

Available Formats

Value Description Reference
1 Login
2 Framed
3 Callback Login
4 Callback Framed
5 Outbound
6 Administrative
7 NAS Prompt
8 Authenticate Only
9 Callback NAS Prompt
10 Call Check
11 Callback Administrative
12 Voice Murtaza Chiba
13 Fax Murtaza Chiba
14 Modem Relay Murtaza Chiba
15 IAPP-Register "IEEE Trial-Use Recommended Practice for Multi-Vendor Access Point Interoperability via an Inter-Access Point Protocol Across Distribution Systems Supporting IEEE 802.11 Operation", IEEE 802.11F, June 2003.; Stuart Kerry
16 IAPP-AP-Check "IEEE Trial-Use Recommended Practice for Multi-Vendor Access Point Interoperability via an Inter-Access Point Protocol Across Distribution Systems Supporting IEEE 802.11 Operation", IEEE 802.11F, June 2003.; Stuart Kerry
17 Authorize Only RFC 3576
18 Framed-Management RFC 5607
19 Additional-Authorization RFC 7499

Values for RADIUS Attribute 7, Framed-Protocol

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Alan DeKok, Margaret Cullen

Reference

  • RFC 2865: Remote Authentication Dial In User Service (RADIUS)
  • RFC 3575: IANA Considerations for RADIUS (Remote Authentication Dial In User Service)

Available Formats

Value Description Reference
1 PPP
2 SLIP
3 AppleTalk Remote Access Protocol (ARAP)
4 Gandalf proprietary SingleLink/MultiLink protocol
5 Xylogics proprietary IPX/SLIP
6 X.75 Synchronous
7 GPRS PDP Context Jeff Moore

Values for RADIUS Attribute 10, Framed-Routing

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Alan DeKok, Margaret Cullen

Reference

  • RFC 2865: Remote Authentication Dial In User Service (RADIUS)
  • RFC 3575: IANA Considerations for RADIUS (Remote Authentication Dial In User Service)

Available Formats

Value Description Reference
0 None
1 Send routing packets
2 Listen for routing packets
3 Send and Listen

Values for RADIUS Attribute 13, Framed-Compression

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Alan DeKok, Margaret Cullen

Reference

  • RFC 2865: Remote Authentication Dial In User Service (RADIUS)
  • RFC 3575: IANA Considerations for RADIUS (Remote Authentication Dial In User Service)

Available Formats

Value Description Reference
0 None
1 VJ TCP/IP header compression
2 IPX header compression
3 Stac-LZS compression

Values for RADIUS Attribute 15, Login-Service

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Alan DeKok, Margaret Cullen

Reference

  • RFC 2865: Remote Authentication Dial In User Service (RADIUS)
  • RFC 3575: IANA Considerations for RADIUS (Remote Authentication Dial In User Service)

Available Formats

Value Description Reference
0 Telnet
1 Rlogin
2 TCP Clear
3 PortMaster (proprietary)
4 LAT
5 X25-PAD
6 X25-T3POS
7 Unassigned
8 TCP Clear Quiet (suppresses any NAS-generated connect string)

Values for RADIUS Attribute 29, Termination-Action

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Alan DeKok, Margaret Cullen

Reference

  • RFC 2865: Remote Authentication Dial In User Service (RADIUS)
  • RFC 3575: IANA Considerations for RADIUS (Remote Authentication Dial In User Service)

Available Formats

Value Description Reference
0 Default
1 RADIUS-Request

Values for RADIUS Attribute 40, Acct-Status-Type

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Alan DeKok, Margaret Cullen

Reference

  • RFC 2866: RADIUS Accounting
  • RFC 3575: IANA Considerations for RADIUS (Remote Authentication Dial In User Service)

Available Formats

Value Description Reference
1 Start RFC 2866
2 Stop RFC 2866
3 Interim-Update RFC 2866
4 Reserved
5 Reserved
6 Reserved
7 Accounting-On RFC 2866
8 Accounting-Off RFC 2866
9 Tunnel-Start RFC 2867
10 Tunnel-Stop RFC 2867
11 Tunnel-Reject RFC 2867
12 Tunnel-Link-Start RFC 2867
13 Tunnel-Link-Stop RFC 2867
14 Tunnel-Link-Reject RFC 2867
15 Failed RFC 2866
16 Unassigned
17 Reserved
18 Subsystem-On https://freeradius.org/rfc/acct_status_type_subsystem.html; Alan DeKok
19 Subsystem-Off https://freeradius.org/rfc/acct_status_type_subsystem.html; Alan DeKok
20-216 Unassigned
217 Reserved
218 Reserved
219 Reserved

Values for RADIUS Attribute 45, Acct-Authentic

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Alan DeKok, Margaret Cullen

Reference

  • RFC 2866: RADIUS Accounting
  • RFC 3575: IANA Considerations for RADIUS (Remote Authentication Dial In User Service)

Available Formats

Value Description Reference
1 RADIUS RFC 2866
2 Local RFC 2866
3 Remote RFC 2866
4 Diameter Pat Calhoun

Values for RADIUS Attribute 49, Acct-Terminate-Cause

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Alan DeKok, Margaret Cullen

Reference

  • RFC 2866: RADIUS Accounting
  • RFC 3575: IANA Considerations for RADIUS (Remote Authentication Dial In User Service)

Available Formats

Value Description Reference
1 User Request RFC 2866
2 Lost Carrier RFC 2866
3 Lost Service RFC 2866
4 Idle Timeout RFC 2866
5 Session Timeout RFC 2866
6 Admin Reset RFC 2866
7 Admin Reboot RFC 2866
8 Port Error RFC 2866
9 NAS Error RFC 2866
10 NAS Request RFC 2866
11 NAS Reboot RFC 2866
12 Port Unneeded RFC 2866
13 Port Preempted RFC 2866
14 Port Suspended RFC 2866
15 Service Unavailable RFC 2866
16 Callback RFC 2866
17 User Error RFC 2866
18 Host Request RFC 2866
19 Supplicant Restart RFC 3580
20 Reauthentication Failure RFC 3580
21 Port Reinitialized RFC 3580
22 Port Administratively Disabled RFC 3580
23 Lost Power Ramprasad Golla

Values for RADIUS Attribute 61, NAS-Port-Type

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Alan DeKok, Margaret Cullen

Reference

  • RFC 2865: Remote Authentication Dial In User Service (RADIUS)
  • RFC 3575: IANA Considerations for RADIUS (Remote Authentication Dial In User Service)

Available Formats

Value Description Reference Registration Date
0 Async RFC 2865
1 Sync RFC 2865
2 ISDN Sync RFC 2865
3 ISDN Async V.120 RFC 2865
4 ISDN Async V.110 RFC 2865
5 Virtual RFC 2865
6 PIAFS RFC 2865
7 HDLC Clear Channel RFC 2865
8 X.25 RFC 2865
9 X.75 RFC 2865
10 G.3 Fax RFC 2865
11 SDSL - Symmetric DSL RFC 2865
12 ADSL-CAP - Asymmetric DSL, Carrierless Amplitude Phase Modulation RFC 2865
13 ADSL-DMT - Asymmetric DSL, Discrete Multi-Tone RFC 2865
14 IDSL - ISDN Digital Subscriber Line RFC 2865
15 Ethernet RFC 2865
16 xDSL - Digital Subscriber Line of unknown type RFC 2865
17 Cable RFC 2865
18 Wireless - Other RFC 2865
19 Wireless - IEEE 802.11 RFC 2865
20 Token-Ring RFC 3580
21 FDDI RFC 3580
22 Wireless - CDMA2000 Pete McCann
23 Wireless - UMTS Pete McCann
24 Wireless - 1X-EV Pete McCann
25 IAPP "IEEE Trial-Use Recommended Practice for Multi-Vendor Access Point Interoperability via an Inter-Access Point Protocol Across Distribution Systems Supporting IEEE 802.11 Operation", IEEE 802.11F, June 2003.; Stuart Kerry
26 FTTP - Fiber to the Premises Tim Nyce
27 Wireless - IEEE 802.16 "IEEE Standard for Local and metropolitan area networks, Part 16: Air Interface for Fixed and Mobile Broadband Wireless Access Systems, Amendment2: Physical and Medium Access Control Layers for Combined Fixed and Mobile Operation in Licensed Bands", IEEE 802.16, February 2006. 2006-12-12
28 Wireless - IEEE 802.20 Mobile Broadband Wireless Access (MBWA), IEEE Standard, IEEE 802.20, Work in Progress. 2006-12-12
29 Wireless - IEEE 802.22 Wireless Regional Area Networks (WRAN), IEEE Standard, IEEE 802.22, Work in Progress. 2006-12-12
30 PPPoA - PPP over ATM RFC 4603
31 PPPoEoA - PPP over Ethernet over ATM RFC 4603
32 PPPoEoE - PPP over Ethernet over Ethernet RFC 4603
33 PPPoEoVLAN - PPP over Ethernet over VLAN RFC 4603
34 PPPoEoQinQ - PPP over Ethernet over IEEE 802.1QinQ RFC 4603
35 xPON - Passive Optical Network Christian Hublet; Renxiang Yan 2007-06-19
36 Wireless - XGP Tomohiro Ichida 2008-08-12
37 WiMAX Pre-Release 8 IWK Function WMF-T37-008-R016v01_PreRelease8-3GPP-IWK; Avi Lior 2011-09-06
38 WIMAX-WIFI-IWK: WiMAX WIFI Interworking WMF-T37-010-R016v01_WiFi-WiMAX-IWK; Avi Lior 2011-09-06
39 WIMAX-SFF: Signaling Forwarding Function for LTE/3GPP2 WMF-T37-004-R015v02_3GPP2-Interworking; Avi Lior 2011-09-06
40 WIMAX-HA-LMA: WiMAX HA and or LMA function WMF-T33-001-R015 Network Stage 3; Avi Lior 2011-09-06
41 WIMAX-DHCP: WIMAX DCHP service WMF-T33-001-R015 Network Stage 3; Avi Lior 2011-09-06
42 WIMAX-LBS: WiMAX location based service WMF-T33-110-R015v01_LBS; Avi Lior 2011-09-06
43 WIMAX-WVS: WiMAX voice service WMF-T33-121-R020 WiMAX voice service; Avi Lior 2011-09-06

Values for RADIUS Attribute 64, Tunnel-Type

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Alan DeKok, Margaret Cullen

Reference

Available Formats

Value Description Reference
1 Point-to-Point Tunneling Protocol (PPTP) RFC 2868
2 Layer Two Forwarding (L2F) RFC 2868
3 Layer Two Tunneling Protocol (L2TP) RFC 2868
4 Ascend Tunnel Management Protocol (ATMP) RFC 2868
5 Virtual Tunneling Protocol (VTP) RFC 2868
6 IP Authentication Header in the Tunnel-mode (AH) RFC 2868
7 IP-in-IP Encapsulation (IP-IP) RFC 2868
8 Minimal IP-in-IP Encapsulation (MIN-IP-IP) RFC 2868
9 IP Encapsulating Security Payload in the Tunnel-mode (ESP) RFC 2868
10 Generic Route Encapsulation (GRE) RFC 2868
11 Bay Dial Virtual Services (DVS) RFC 2868
12 IP-in-IP Tunneling RFC 2868
13 Virtual LANs (VLAN) RFC 3580

Values for RADIUS Attribute 65, Tunnel-Medium-Type

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Alan DeKok, Margaret Cullen

Reference

Available Formats

Value Description Reference
1 IPv4 (IP version 4) RFC 2868
2 IPv6 (IP version 6) RFC 2868
3 NSAP RFC 2868
4 HDLC (8-bit multidrop) RFC 2868
5 BBN 1822 RFC 2868
6 802 (includes all 802 media plus Ethernet "canonical format") RFC 2868
7 E.163 (POTS) RFC 2868
8 E.164 (SMDS, Frame Relay, ATM) RFC 2868
9 F.69 (Telex) RFC 2868
10 X.121 (X.25, Frame Relay) RFC 2868
11 IPX RFC 2868
12 Appletalk RFC 2868
13 Decnet IV RFC 2868
14 Banyan Vines RFC 2868
15 E.164 with NSAP format subaddress RFC 2868

Values for RADIUS Attribute 72, ARAP-Zone-Access

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Alan DeKok, Margaret Cullen

Reference

  • RFC 2869: RADIUS Extensions
  • RFC 3575: IANA Considerations for RADIUS (Remote Authentication Dial In User Service)

Available Formats

Value Description Reference
1 Only allow access to default zone RFC 2869
2 Use zone filter inclusively RFC 2869
3 Not used RFC 2869
4 Use zone filter exclusively RFC 2869

Values for RADIUS Attribute 76, Prompt

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Alan DeKok, Margaret Cullen

Reference

  • RFC 2869: RADIUS Extensions
  • RFC 3575: IANA Considerations for RADIUS (Remote Authentication Dial In User Service)

Available Formats

Value Description Reference
0 No Echo RFC 2869
1 Echo RFC 2869

Values for RADIUS Attribute 101, Error-Cause Attribute

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Alan DeKok, Margaret Cullen

Reference

  • RFC 3575: IANA Considerations for RADIUS (Remote Authentication Dial In User Service)
  • RFC 5176: Dynamic Authorization Extensions to Remote Authentication Dial In User Service (RADIUS)
  • RFC 7930: Larger Packets for RADIUS over TCP

Available Formats

Value Description Reference
201 Residual Session Context Removed RFC 5176
202 Invalid EAP Packet (Ignored) RFC 5176
401 Unsupported Attribute RFC 5176
402 Missing Attribute RFC 5176
403 NAS Identification Mismatch RFC 5176
404 Invalid Request RFC 5176
405 Unsupported Service RFC 5176
406 Unsupported Extension RFC 5176
407 Invalid Attribute Value RFC 5176
501 Administratively Prohibited RFC 5176
502 Request Not Routable (Proxy) RFC 5176
503 Session Context Not Found RFC 5176
504 Session Context Not Removable RFC 5176
505 Other Proxy Processing Error RFC 5176
506 Resources Unavailable RFC 5176
507 Request Initiated RFC 5176
508 Multiple Session Selection Unsupported RFC 5176
509 Location-Info-Required RFC 5580
601 Response Too Big RFC 7930

Operator Namespace Identifier for Attribute 126

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Alan DeKok, Mohit Sethi

Reference

  • RFC 5580: Carrying Location Objects in RADIUS and Diameter

Available Formats

Identifier Token Contact Reference
0x00-0x29 Reserved RFC 5580
0x30 TADIG TD.13 Coordinator (td13 at gsm.org) RFC 5580
0x31 REALM IETF O&M Area Directors (ops-ads at ietf.org) RFC 5580
0x32 E212 ITU Director (tsbdir at itu.int) RFC 5580
0x33 ICC ITU Director (tsbdir at itu.int) RFC 5580
0x34 WBAID WBA Director (pmo@wballiance.com) Wireless Broadband Alliance; Bruno Tomas
0x35-0xFE Unassigned
0xFF Reserved RFC 5580

Location Profiles (Attribute 127, Location-Information)

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Alan DeKok, Mohit Sethi

Reference

  • RFC 5580: Carrying Location Objects in RADIUS and Diameter

Available Formats

Value Description Reference
0 Civic location profile RFC 5580
1 Geospatial location profile RFC 5580
2-255 Unassigned

Entity Types (Attribute 127, Location-Information)

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Alan DeKok, Mohit Sethi

Reference

  • RFC 5580: Carrying Location Objects in RADIUS and Diameter

Available Formats

Value Description Reference
0 Location of the User's Client Device RFC 5580
1 Location of the RADIUS Client RFC 5580
2-255 Unassigned

Privacy Flags (Attribute 129, Basic-Location-Policy-Rules)

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Alan DeKok, Mohit Sethi

Reference

  • RFC 5580: Carrying Location Objects in RADIUS and Diameter

Available Formats

Value Description Reference
0 Retransmission allowed RFC 5580
1-15 Unassigned

Location-Capable Attribute (Attribute 131)

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Alan DeKok, Mohit Sethi

Reference

  • RFC 5580: Carrying Location Objects in RADIUS and Diameter

Available Formats

Value Capability Token Reference
1 CIVIC_LOCATION RFC 5580
2 GEO_LOCATION RFC 5580
4 USERS_LOCATION RFC 5580
8 NAS_LOCATION RFC 5580

Requested-Location-Info Attribute (Attribute 132)

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Alan DeKok, Mohit Sethi

Reference

  • RFC 5580: Carrying Location Objects in RADIUS and Diameter

Available Formats

Value Capability Token Reference
1 CIVIC_LOCATION RFC 5580
2 GEO_LOCATION RFC 5580
4 USERS_LOCATION RFC 5580
8 NAS_LOCATION RFC 5580
16 FUTURE_REQUESTS RFC 5580
32 NONE RFC 5580

Values for RADIUS Attribute 133, Framed-Management-Protocol Attribute

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Alan DeKok, Margaret Cullen

Reference

  • RFC 5607: Remote Authentication Dial-In User Service (RADIUS) Authorization for Network Access Server (NAS) Management

Available Formats

Value Description Reference
1 SNMP RFC 5607
2 Web-based RFC 5607
3 NETCONF RFC 5607
4 FTP RFC 5607
5 TFTP RFC 5607
6 SFTP RFC 5607
7 RCP RFC 5607
8 SCP RFC 5607

Values for RADIUS Attribute 134, Management-Transport-Protection Attribute

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Alan DeKok, Margaret Cullen

Reference

  • RFC 5607: Remote Authentication Dial-In User Service (RADIUS) Authorization for Network Access Server (NAS) Management

Available Formats

Value Description Reference
1 No-Protection RFC 5607
2 Integrity-Protection RFC 5607
3 Integrity-Confidentiality-Protection RFC 5607

Code Values for RADIUS Attribute 241.1, Frag-Status

Registration Procedure(s)

  • RFC Required

Reference

  • RFC 7499: Support of Fragmentation of RADIUS Packets

Available Formats

Value Description Reference
0 Reserved RFC 7499
1 Fragmentation-Supported RFC 7499
2 More-Data-Pending RFC 7499
3 More-Data-Request RFC 7499
4-255 Unassigned

RADIUS Packet Type Codes

Registration Procedure(s)

  • IESG Approval

Reference

  • RFC 3575: IANA Considerations for RADIUS (Remote Authentication Dial In User Service)

Available Formats

Decimal Message Reference
1 Access-Request RFC 2865
2 Access-Accept RFC 2865
3 Access-Reject RFC 2865
4 Accounting-Request RFC 2865
5 Accounting-Response RFC 2865
6 Accounting-Status (now Interim Accounting) RFC 3575
7 Password-Request RFC 3575
8 Password-Ack RFC 3575
9 Password-Reject RFC 3575
10 Accounting-Message RFC 3575
11 Access-Challenge RFC 2865
12 Status-Server (experimental) RFC 2865
13 Status-Client (experimental) RFC 2865
21 Resource-Free-Request RFC 3575
22 Resource-Free-Response RFC 3575
23 Resource-Query-Request RFC 3575
24 Resource-Query-Response RFC 3575
25 Alternate-Resource-Reclaim-Request RFC 3575
26 NAS-Reboot-Request RFC 3575
27 NAS-Reboot-Response RFC 3575
28 Reserved
29 Next-Passcode RFC 3575
30 New-Pin RFC 3575
31 Terminate-Session RFC 3575
32 Password-Expired RFC 3575
33 Event-Request RFC 3575
34 Event-Response RFC 3575
35-39 Unassigned
40 Disconnect-Request RFC 3575; RFC 5176
41 Disconnect-ACK RFC 3575; RFC 5176
42 Disconnect-NAK RFC 3575; RFC 5176
43 CoA-Request RFC 3575; RFC 5176
44 CoA-ACK RFC 3575; RFC 5176
45 CoA-NAK RFC 3575; RFC 5176
46-49 Unassigned
50 IP-Address-Allocate RFC 3575
51 IP-Address-Release RFC 3575
52 Protocol-Error RFC 7930
53-249 Unassigned
250-253 Experimental Use RFC 3575
254 Reserved RFC 3575
255 Reserved RFC 3575

RADIUS IP Port Configuration and Reporting TLVs

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 8045: RADIUS Extensions for IP Port Configuration and Reporting

Available Formats

Value Description Data Type Reference
0 Reserved RFC 8045
1 IP-Port-Type integer RFC 8045, Section 3.2.1
2 IP-Port-Limit integer RFC 8045, Section 3.2.2
3 IP-Port-Ext-IPv4-Addr ipv4addr RFC 8045, Section 3.2.3
4 IP-Port-Int-IPv4-Addr ipv4addr RFC 8045, Section 3.2.4
5 IP-Port-Int-IPv6-Addr ipv6addr RFC 8045, Section 3.2.5
6 IP-Port-Int-Port integer RFC 8045, Section 3.2.6
7 IP-Port-Ext-Port integer RFC 8045, Section 3.2.7
8 IP-Port-Alloc integer RFC 8045, Section 3.2.8
9 IP-Port-Range-Start integer RFC 8045, Section 3.2.9
10 IP-Port-Range-End integer RFC 8045, Section 3.2.10
11 IP-Port-Local-Id string RFC 8045, Section 3.2.11
12-255 Unassigned

Data Type

Registration Procedure(s)

  • Standards Action

Reference

Available Formats

Value Description Reference
1 integer RFC 2865; RFC 8044
2 enum RFC 2865; RFC 8044
3 time RFC 2865; RFC 8044
4 text RFC 2865; RFC 8044
5 string RFC 2865; RFC 8044
6 concat RFC 8044
7 ifid RFC 3162; RFC 8044
8 ipv4addr RFC 2865; RFC 8044
9 ipv6addr RFC 3162; RFC 8044
10 ipv6prefix RFC 3162; RFC 8044
11 ipv4prefix RFC 6572; RFC 8044
12 integer64 RFC 6929; RFC 8044
13 tlv RFC 6929; RFC 8044
14 vsa RFC 2865; RFC 8044
15 extended RFC 6929; RFC 8044
16 long-extended RFC 6929; RFC 8044
17 evs RFC 6929; RFC 8044

RADIUS Softwire46 Configuration and Multicast Attributes

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 8658: RADIUS Attributes for Softwire Mechanisms Based on Address plus Port (A+P)

Available Formats

Value Description Data Type Reference
0 Reserved RFC 8658
1 Softwire46-MAP-E tlv RFC 8658, Section 3.1.1.1
2 Softwire46-MAP-T tlv RFC 8658, Section 3.1.1.2
3 Softwire46-Lightweight-4over6 tlv RFC 8658, Section 3.1.1.3
4 Softwire46-Rule (BMR) tlv RFC 8658, Section 3.1.3.1
5 Softwire46-Rule (FMR) tlv RFC 8658, Section 3.1.3.1
6 Softwire46-BR ipv6addr RFC 8658, Section 3.1.3.2
7 Softwire46-DMR ipv6prefix RFC 8658, Section 3.1.3.3
8 Softwire46-V4V6Bind tlv RFC 8658, Section 3.1.3.4
9 Softwire46-PORTPARAMS tlv RFC 8658, Section 3.1.3.5
10 Rule-IPv6-Prefix ipv6prefix RFC 8658, Section 3.1.4.1
11 Rule-IPv4-Prefix ipv4prefix RFC 8658, Section 3.1.4.2
12 EA-Length integer RFC 8658, Section 3.1.4.3
13 IPv4-Address ipv4addr RFC 8658, Section 3.1.5.1
14 Bind-IPv6-Prefix ipv6prefix RFC 8658, Section 3.1.5.2
15 PSID-Offset integer RFC 8658, Section 3.1.6.1
16 PSID-Len integer RFC 8658, Section 3.1.6.2
17 PSID integer RFC 8658, Section 3.1.6.3
18 Softwire46-Option-Code integer RFC 8658, Section 3.2.1
19 ASM-Prefix64 ipv6prefix RFC 8658, Section 3.3.1
20 SSM-Prefix64 ipv6prefix RFC 8658, Section 3.3.2
21 U-Prefix64 ipv6prefix RFC 8658, Section 3.3.3
22-255 Unassigned

Option Codes Permitted in the Softwire46-Priority Attribute

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 8658: RADIUS Attributes for Softwire Mechanisms Based on Address plus Port (A+P)

Available Formats

Option Code Softwire46 Mechanism Reference
1 MAP-E RFC 7597
2 MAP-T RFC 7599
3 Lightweight 4over6 RFC 7596
144 DS-Lite RFC 6519

Contact Information

Name Contact URI Last Updated
Alan DeKok aland&freeradius.org 2021-07-12
Avi Lior avi&bridgewatersystems.com 2011-09-06
Bruno Tomas pmo&wballiance.com 2019-06-20
Christian Hublet Christian.Hublet&alcatel-lucent.be 2007-06-21
Jeff Moore jeff.moore&cisco.com 2001-02
Murtaza Chiba mchiba&cisco.com 2001-06
Pat Calhoun pcalhoun&diameter.org 2001-05
Pete McCann mccap&lucent.com 2002-03
Ramprasad Golla rgolla&grid-net.com 2010-11-30
Renxiang Yan Renxiang.Yan&alcatel-sbell.com.cn 2007-06-19
Stuart Kerry stuart.kerry&philips.com 2003-01
Tim Nyce tnyce&idts.org 2004-03
Tomohiro Ichida t_ichida&willcom-inc.com 2008-08-12
Wireless Broadband Alliance https://www.wballiance.com/ 2019-06-20