OSPFv3 Options (24 bits)

Registration Procedure(s)

  • Standards Action

Reference

Available Formats

Value Description Reference
0x000001 V6-bit RFC 5340
0x000002 E-bit RFC 2328
0x000004 Deprecated RFC 5340
0x000008 N-bit RFC 3101
0x000010 R-Bit RFC 5340
0x000020 DC-bit RFC 1793
0x000040 Reserved for OSPFv2 migrated options RFC 5340
0x000080 Reserved for OSPFv2 migrated options RFC 5340
0x000100 AF-bit RFC 5838
0x000200 L-bit RFC 5613
0x000400 AT-bit RFC 7166

OSPFv3 LSA Function Codes

Reference

  • RFC 7770: Extensions to OSPF for Advertising Optional Router Capabilities

Available Formats

Range Registration Procedures Note
0-255 IETF Review
256-8175 Reserved IANA does not assign
8176-8183 Experimentation IANA does not assign
8184-8190 Vendor Private Use IANA does not assign
8191 Reserved IANA does not assign
Value LSA Function Code Name Reference
0 Reserved RFC 7770
1 Router-LSA RFC 5340
2 Network-LSA RFC 5340
3 Inter-Area-Prefix-LSA RFC 5340
4 Inter-Area-Router-LSA RFC 5340
5 AS-External-LSA RFC 5340
6 Deprecated RFC 5340
7 NSSA-LSA RFC 5340
8 Link-LSA RFC 5340
9 Intra-Area-Prefix-LSA RFC 5340
10 Intra-Area-TE-LSA RFC 5329
11 GRACE-LSA RFC 5187
12 OSPFv3 Router Information (RI) LSA RFC 7770
13 Inter-AS-TE-v3 LSA RFC 5392
14 OSPFv3 L1VPN LSA RFC 5523
15 OSPFv3 Autoconfiguration (AC) LSA RFC 7503
16 OSPFv3 Dynamic Flooding LSA RFC 9667
17-32 Unassigned
33 E-Router-LSA RFC 8362
34 E-Network-LSA RFC 8362
35 E-Inter-Area-Prefix-LSA RFC 8362
36 E-Inter-Area-Router-LSA RFC 8362
37 E-AS-External-LSA RFC 8362
38 Unused (Not to be allocated) RFC 8362
39 E-Type-7-LSA RFC 8362
40 E-Link-LSA RFC 8362
41 E-Intra-Area-Prefix-LSA RFC 8362
42 SRv6 Locator LSA RFC 9513, Section 7
43-255 Unassigned
256-8175 Reserved RFC 7770
8176-8183 Experimentation RFC 7770
8184-8190 Vendor Private Use RFC 7770
8191 Reserved RFC 7770

OSPFv3 Prefix Options (8 bits)

Registration Procedure(s)

  • Standards Action

Reference

Available Formats

Value Description Reference
0x01 NU-bit RFC 5340
0x02 LA-bit RFC 5340
0x04 Deprecated RFC 5340
0x08 P-bit RFC 5340
0x10 DN-bit RFC 5340
0x20 N-bit RFC 8362
0x40 E-Flag (ELC Flag) RFC 9089
0x80 AC-bit RFC 9513, Section 6

OSPFv3 Router LSA Link Types

Reference

Available Formats

Range Registration Procedures
0-127 Standards Action
128-255 Reserved
Value Description Reference
0 Reserved RFC 4940
1 Point-to-Point connection to another router RFC 5340
2 Transit Network RFC 5340
3 Reserved RFC 5340
4 Virtual Link RFC 5340
5-127 Unassigned
128-255 Reserved

OSPFv3 Router Properties Registry

Registration Procedure(s)

  • Standards Action

Reference

Available Formats

Value Description Reference
0x01 B-bit RFC 5340
0x02 E-bit RFC 5340
0x04 V-bit RFC 5340
0x08 Deprecated RFC 5340
0x10 Nt-bit RFC 5340

LD Options

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 5820: Extensions to OSPF to Support Mobile Ad Hoc Networking

Available Formats

Value Description Reference
0x01 U-bit RFC 5820

OSPFv3 Instance ID Address Family Values

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 5838: Support of Address Families in OSPFv3
  • RFC 6969: OSPFv3 Instance ID Registry Update

Note

These values for instance ID are applicable when RFC 5838 is used to support multiple address families. The instance ID field may be used for applications other than the support of multiple address families.

Available Formats

Value Description Reference
0 Base IPv6 Unicast AF RFC 5838
1-31 Base IPv6 Unicast AF dependent on local policy RFC 5838
32 Base IPv6 Multicast RFC 5838
33-63 IPv6 Multicast AFs dependent on local policy RFC 5838
64 Base IPv4 Unicast AF RFC 5838
65-95 IPv4 Unicast AFs dependent on local policy RFC 5838
96 Base IPv4 Multicast RFC 5838
97-127 IPv4 Multicast AFs dependent on local policy RFC 5838
128-191 Unassigned
192-255 Reserved for Private Use RFC 6969

OSPFv3 Autoconfiguration (AC) LSA TLVs

Registration Procedure(s)

  • IETF Review or IESG Approval

Reference

Available Formats

Value Description Reference
0 Reserved RFC 7503
1 Router-Hardware-Fingerprint TLV RFC 7503
2-65534 Unassigned
65535 Autoconfiguration-Experiment-TLV RFC 7503

OSPFv3 Extended-LSA TLVs

Reference

  • RFC 8362: OSPFv3 Link State Advertisement (LSA) Extensibility

Available Formats

Range Registration Procedures
9-32767 IETF Review or IESG Approval
33024-45055 First Come First Served
Value Description Reference
0 Reserved RFC 8362
1 Router-Link TLV RFC 8362
2 Attached-Routers TLV RFC 8362
3 Inter-Area-Prefix TLV RFC 8362
4 Inter-Area-Router TLV RFC 8362
5 External-Prefix TLV RFC 8362
6 Intra-Area-Prefix TLV RFC 8362
7 IPv6 Link-Local Address TLV RFC 8362
8 IPv4 Link-Local Address TLV RFC 8362
9 OSPFv3 Extended Prefix Range TLV RFC 8666
10-32767 Unassigned
32768-33023 Reserved for Experimental Use RFC 8362
33024-45055 Unassigned
45056-65535 Reserved RFC 8362

OSPFv3 Extended-LSA Sub-TLVs

Reference

  • RFC 8362: OSPFv3 Link State Advertisement (LSA) Extensibility
  • RFC 9356: Advertising Layer 2 Bundle Member Link Attributes in OSPF

Note

The "L2BM" column indicates applicability to the L2 Bundle Attributes Member sub-TLV. The options for the "L2BM" column are:

Y - This sub-TLV MAY appear in the L2 Bundle Member Attributes sub-TLV.

N - This sub-TLV MUST NOT appear in the L2 Bundle Member Attributes sub-TLV.

X - This is not a sub-TLV of the Router-Link TLV; it MUST NOT appear in the L2 Bundle Member Attributes sub-TLV.

Note

Allocations made in this registry for sub-TLVs that are associated with OSPFv3 Extended TLVs related to prefix advertisements MUST be evaluated for their applicability as OSPFv3 SRv6 Locator sub-TLVs, which are required to be allocated in the "OSPFv3 SRv6 Locator LSA Sub-TLVs" registry at Open Shortest Path First v3 (OSPFv3) Parameters.

Available Formats

Range Registration Procedures
4-32767 IETF Review or IESG Approval
33024-45055 First Come First Served
Value Description L2BM Reference
0 Reserved RFC 8362
1 IPv6-Forwarding-Address sub-TLV X RFC 8362
2 IPv4-Forwarding-Address sub-TLV X RFC 8362
3 Route-Tag sub-TLV X RFC 8362
4 Prefix SID sub-TLV X RFC 8666
5 Adj-SID sub-TLV Y RFC 8666
6 LAN Adj-SID sub-TLV Y RFC 8666
7 SID/Label sub-TLV N RFC 8666
8 Graceful-Link-Shutdown sub-TLV N RFC 8379
9 OSPFv3 Link MSD N RFC 8476
10 OSPFv3 Link Attributes Bits Y RFC 9667
11 Application-Specific Link Attributes Y RFC 9492
12 Shared Risk Link Group Y RFC 9492
13 Unidirectional Link Delay Y RFC 9492
14 Min/Max Unidirectional Link Delay Y RFC 9492
15 Unidirectional Delay Variation Y RFC 9492
16 Unidirectional Link Loss Y RFC 9492
17 Unidirectional Residual Bandwidth Y RFC 9492
18 Unidirectional Available Bandwidth Y RFC 9492
19 Unidirectional Utilized Bandwidth Y RFC 9492
20 Administrative Group Y RFC 9492
21 Extended Administrative Group Y RFC 9492
22 TE Metric Y RFC 9492
23 Maximum link bandwidth Y RFC 9492
24 Local Interface IPv6 Address N RFC 9492
25 Remote Interface IPv6 Address N RFC 9492
26 Flexible Algorithm Prefix Metric (FAPM) X RFC 9350, Section 9
27 Prefix Source OSPF Router-ID X RFC 9084
28 Prefix Source Router Address X RFC 9084
29 L2 Bundle Member Attributes N RFC 9356
30 SRv6 SID Structure Y RFC 9513, Section 10
31 SRv6 End.X SID Y RFC 9513, Section 9.1
32 SRv6 LAN End.X SID Y RFC 9513, Section 9.2
33 OSPF Flexible Algorithm ASBR Metric X RFC 9350, Section 10.2
34 Generic Metric Y RFC 9843, Section 2.2
35 OSPFv3 IP Algorithm Prefix Reachability X RFC 9502, Section 6.4
36 OSPFv3 IP Flexible Algorithm ASBR Metric X RFC 9502, Section 6.5
37 OSPFv3 Prefix Extended Flags X RFC 9792
38 BIER PHP Request X RFC-ietf-bier-php-16
39 Administrative Tag X RFC 9825
40-32767 Unassigned
32768-33023 Reserved for Experimental Use RFC 8362
33024-45055 Unassigned
45056-65535 Reserved RFC 8362

OSPFv3 SRv6 Capabilities TLV Flags

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 9513: OSPFv3 Extensions for Segment Routing over IPv6 (SRv6)

Available Formats

Bit Description Reference
0 Unassigned
1 O-flag RFC 9513, Section 2
2-15 Unassigned

OSPFv3 SRv6 End SID Sub-TLV Flags

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 9513: OSPFv3 Extensions for Segment Routing over IPv6 (SRv6)

Available Formats

Bit Description Reference
0-7 Unassigned

OSPFv3 SRv6 Adjacency SID Sub-TLV Flags

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 9513: OSPFv3 Extensions for Segment Routing over IPv6 (SRv6)

Available Formats

Bit Description Reference
0 B-flag RFC 9513, Section 9.1, 9.2
1 S-flag RFC 9513, Section 9.1, 9.2
2 P-flag RFC 9513, Section 9.1, 9.2
3-7 Unassigned

OSPFv3 SRv6 Locator LSA TLVs

Reference

  • RFC 9513: OSPFv3 Extensions for Segment Routing over IPv6 (SRv6)

Available Formats

Range Registration Procedures
0-32767 IETF Review or IESG Approval
33024-45055 First Come First Served
Value Description Reference
0 Reserved RFC 9513
1 SRv6 Locator RFC 9513, Section 7.1
2-32767 Unassigned
32768-33023 Reserved for Experimental Use RFC 9513
33024-45055 Unassigned
45056-65535 Reserved RFC 9513

OSPFv3 SRv6 Locator LSA Sub-TLVs

Reference

  • RFC 9513: OSPFv3 Extensions for Segment Routing over IPv6 (SRv6)

Note

Allocations made in this registry for sub-TLVs that are associated with OSPFv3 SRv6 Locator TLVs MUST be evaluated for their applicability as OSPFv3 Extended-LSA sub-TLVs, which are required to be allocated in the “OSPFv3 Extended-LSA Sub-TLVs" registry at Open Shortest Path First v3 (OSPFv3) Parameters.

Available Formats

Range Registration Procedures
0-32767 IETF Review or IESG Approval
33024-45055 First Come First Served
Value Description Reference
0 Reserved RFC 9513
1 SRv6 End SID RFC 9513, Section 8
2 IPv6-Forwarding-Address RFC 8362; RFC 9513, Section 7.2
3 Route-Tag RFC 8362; RFC 9513, Section 7.2
4 Prefix Source OSPF Router-ID RFC 9084; RFC 9513, Section 7.2
5 Prefix Source Router Address RFC 9084; RFC 9513, Section 7.2
6 Administrative Tag RFC 9825
7-9 Unassigned
10 SRv6 SID Structure RFC 9513, Section 10
11-32767 Unassigned
32768-33023 Reserved for Experimental Use RFC 9513
33024-45055 Unassigned
45056-65535 Reserved RFC 9513

OSPFv3 Prefix Extended Flags

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 9792: Prefix Flag Extension for OSPFv2 and OSPFv3

Note

Per RFC 9792, IANA will add subsequent blocks of 32 bits upon exhaustion of the preceding 32-bit block.

Available Formats

Bit Description Reference
0 U-Flag RFC 9929, Section 4.2
1 UP-Flag RFC 9929, Section 4.2
2-31 Unassigned