Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 0 | tcp | Reserved | 2024-12-20 | RFC 6335 | |||||||
| 0 | udp | Reserved | 2024-12-20 | RFC 6335 | |||||||
| tcpmux | 1 | tcp | TCP Port Service Multiplexer | Mark Lottor | Mark Lottor | ||||||
| tcpmux | 1 | udp | TCP Port Service Multiplexer | Mark Lottor | Mark Lottor | ||||||
| 2 | tcp | Reserved | 2025-02-13 | De-assigned on 2025-02-13, previously compressnet by Bernie Volz | |||||||
| 2 | udp | Reserved | 2025-02-13 | De-assigned on 2025-02-13, previously compressnet by Bernie Volz | |||||||
| 3 | tcp | Reserved | 2025-02-13 | De-assigned on 2025-02-13, previously compressnet by Bernie Volz | |||||||
| 3 | udp | Reserved | 2025-02-13 | De-assigned on 2025-02-13, previously compressnet by Bernie Volz | |||||||
| 4 | tcp | Unassigned | |||||||||
| 4 | udp | Unassigned | |||||||||
| rje | 5 | tcp | Remote Job Entry | Jon Postel | Jon Postel | ||||||
| rje | 5 | udp | Remote Job Entry | Jon Postel | Jon Postel | ||||||
| 6 | tcp | Unassigned | |||||||||
| 6 | udp | Unassigned | |||||||||
| echo | 7 | tcp | Echo | Jon Postel | Jon Postel | ||||||
| echo | 7 | udp | Echo | Jon Postel | Jon Postel | ||||||
| 8 | tcp | Unassigned | |||||||||
| 8 | udp | Unassigned | |||||||||
| discard | 9 | tcp | Discard | Jon Postel | Jon Postel | ||||||
| discard | 9 | udp | Discard | Jon Postel | Jon Postel | ||||||
| discard | 9 | sctp | Discard | Randall Stewart | Randall Stewart | 2022-02-07 | RFC 9260 | ||||
| discard | 9 | dccp | Discard | Eddie Kohler | Eddie Kohler | RFC 4340 | 1145656131 | ||||
| 10 | tcp | Unassigned | |||||||||
| 10 | udp | Unassigned | |||||||||
| systat | 11 | tcp | Active Users | Jon Postel | Jon Postel | ||||||
| systat | 11 | udp | Active Users | Jon Postel | Jon Postel | ||||||
| 12 | tcp | Unassigned | |||||||||
| 12 | udp | Unassigned | |||||||||
| daytime | 13 | tcp | Daytime | Jon Postel | Jon Postel | RFC 867 | |||||
| daytime | 13 | udp | Daytime | Jon Postel | Jon Postel | RFC 867 | |||||
| 14 | tcp | Unassigned | |||||||||
| 14 | udp | Unassigned | |||||||||
| 15 | tcp | Unassigned [was netstat] | |||||||||
| 15 | udp | Unassigned | |||||||||
| 16 | tcp | Unassigned | |||||||||
| 16 | udp | Unassigned | |||||||||
| qotd | 17 | tcp | Quote of the Day | Jon Postel | Jon Postel | ||||||
| qotd | 17 | udp | Quote of the Day | Jon Postel | Jon Postel | ||||||
| msp | 18 | tcp | Message Send Protocol (historic) | Rina Nethaniel | Rina Nethaniel | ||||||
| msp | 18 | udp | Message Send Protocol (historic) | Rina Nethaniel | Rina Nethaniel | ||||||
| chargen | 19 | tcp | Character Generator | ||||||||
| chargen | 19 | udp | Character Generator | ||||||||
| ftp-data | 20 | tcp | File Transfer [Default Data] | Jon Postel | Jon Postel | ||||||
| ftp-data | 20 | udp | File Transfer [Default Data] | Jon Postel | Jon Postel | ||||||
| ftp-data | 20 | sctp | FTP | Randall Stewart | Randall Stewart | 2022-02-07 | RFC 9260 | ||||
| ftp | 21 | tcp | File Transfer Protocol [Control] | Jon Postel | Jon Postel | RFC 959 | Defined TXT keys: u=<username> p=<password> path=<path> | ||||
| ftp | 21 | udp | File Transfer Protocol [Control] | Jon Postel | Jon Postel | RFC 959 | Defined TXT keys: u=<username> p=<password> path=<path> | ||||
| ftp | 21 | sctp | FTP | Randall Stewart | Randall Stewart | 2022-02-07 | RFC 9260 | Defined TXT keys: u=<username> p=<password> path=<path> | |||
| ssh | 22 | tcp | The Secure Shell (SSH) Protocol | RFC 4251 | Defined TXT keys: u=<username> p=<password> | ||||||
| ssh | 22 | udp | The Secure Shell (SSH) Protocol | RFC 4251 | Defined TXT keys: u=<username> p=<password> | ||||||
| ssh | 22 | sctp | SSH | Randall Stewart | Randall Stewart | 2022-02-07 | RFC 9260 | Defined TXT keys: u=<username> p=<password> | |||
| telnet | 23 | tcp | Telnet | Jon Postel | Jon Postel | RFC 854 | Defined TXT keys: u=<username> p=<password> | ||||
| telnet | 23 | udp | Telnet | Jon Postel | Jon Postel | RFC 854 | Defined TXT keys: u=<username> p=<password> | ||||
| 24 | tcp | any private mail system | Rick Adams | Rick Adams | |||||||
| 24 | udp | any private mail system | Rick Adams | Rick Adams | |||||||
| smtp | 25 | tcp | Simple Mail Transfer | IESG | IETF Chair | 2017-06-05 | RFC-ietf-emailcore-rfc5321bis-43 | ||||
| smtp | 25 | udp | Simple Mail Transfer | IESG | IETF Chair | 2017-06-05 | RFC-ietf-emailcore-rfc5321bis-43 | ||||
| 26 | tcp | Unassigned | |||||||||
| 26 | udp | Unassigned | |||||||||
| nsw-fe | 27 | tcp | NSW User System FE | Robert Thomas | Robert Thomas | ||||||
| nsw-fe | 27 | udp | NSW User System FE | Robert Thomas | Robert Thomas | ||||||
| 28 | tcp | Unassigned | |||||||||
| 28 | udp | Unassigned | |||||||||
| msg-icp | 29 | tcp | MSG ICP | Robert Thomas | Robert Thomas | ||||||
| msg-icp | 29 | udp | MSG ICP | Robert Thomas | Robert Thomas | ||||||
| 30 | tcp | Unassigned | |||||||||
| 30 | udp | Unassigned | |||||||||
| msg-auth | 31 | tcp | MSG Authentication | Robert Thomas | Robert Thomas | ||||||
| msg-auth | 31 | udp | MSG Authentication | Robert Thomas | Robert Thomas | ||||||
| 32 | tcp | Unassigned | |||||||||
| 32 | udp | Unassigned | |||||||||
| dsp | 33 | tcp | Display Support Protocol | Ed Cain | Ed Cain | ||||||
| dsp | 33 | udp | Display Support Protocol | Ed Cain | Ed Cain | ||||||
| 34 | tcp | Unassigned | |||||||||
| 34 | udp | Unassigned | |||||||||
| 35 | tcp | any private printer server | Jon Postel | Jon Postel | |||||||
| 35 | udp | any private printer server | Jon Postel | Jon Postel | |||||||
| 36 | tcp | Unassigned | |||||||||
| 36 | udp | Unassigned | |||||||||
| time | 37 | tcp | Time | Jon Postel | Jon Postel | ||||||
| time | 37 | udp | Time | Jon Postel | Jon Postel | ||||||
| rap | 38 | tcp | Route Access Protocol | Robert Ullmann | Robert Ullmann | ||||||
| rap | 38 | udp | Route Access Protocol | Robert Ullmann | Robert Ullmann | ||||||
| rlp | 39 | tcp | Resource Location Protocol | Mike Accetta | Mike Accetta | ||||||
| rlp | 39 | udp | Resource Location Protocol | Mike Accetta | Mike Accetta | ||||||
| 40 | tcp | Unassigned | |||||||||
| 40 | udp | Unassigned | |||||||||
| graphics | 41 | tcp | Graphics | ||||||||
| graphics | 41 | udp | Graphics | ||||||||
| name | 42 | tcp | Host Name Server | ||||||||
| name | 42 | udp | Host Name Server | ||||||||
| nameserver | 42 | tcp | Host Name Server | ||||||||
| nameserver | 42 | udp | Host Name Server | ||||||||
| nicname | 43 | tcp | Who Is | ||||||||
| nicname | 43 | udp | Who Is | ||||||||
| mpm-flags | 44 | tcp | MPM FLAGS Protocol | ||||||||
| mpm-flags | 44 | udp | MPM FLAGS Protocol | ||||||||
| mpm | 45 | tcp | Message Processing Module [recv] | ||||||||
| mpm | 45 | udp | Message Processing Module [recv] | ||||||||
| mpm-snd | 46 | tcp | MPM [default send] | Jon Postel | Jon Postel |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Bernie Volz | volz&cisco.com | ||
| Ed Cain | cain&edn-unix.dca.mil | ||
| Eddie Kohler | IETF dccp WG | kohler&cs.ucla.edu | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Jon Postel | postel&isi.edu | ||
| Mark Lottor | MKL&nisc.sri.com | ||
| Mike Accetta | MIKE.ACCETTA&cmu-cs-a.edu | ||
| Randall Stewart | IETF TSVWG | rrs&lakerest.net | |
| Rick Adams | rick&uunet.uu.net | ||
| Rina Nethaniel | |||
| Robert Thomas | BThomas&f.bbn.com | ||
| Robert Ullmann | ariel&world.std.com |