Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-13

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
kme-trap-port 2081 udp KME PRINTER TRAP PORT Masakatsu Matsuo Masakatsu Matsuo
infowave 2082 tcp Infowave Mobility Server Kaz Kylheku Kaz Kylheku
infowave 2082 udp Infowave Mobility Server Kaz Kylheku Kaz Kylheku
radsec 2083 tcp Secure Radius Service IESG IETF Chair 2005-05 RFC 6614 The TCP port 2083 was already previously assigned by IANA for "RadSec", an early implementation of RADIUS/TLS, prior to issuance of this RFC. This early implementation can be configured to be compatible to RADIUS/TLS as specified by the IETF. See RFC 6614, Appendix A for details.
radsec 2083 udp Secure Radius Service IESG IETF Chair 2005-05 2014-07-14 RFC 7360 The UDP port 2083 was already previously assigned by IANA for "RadSec", an early implementation of RADIUS/TLS, prior to issuance of this RFC.
sunclustergeo 2084 tcp SunCluster Geographic Oracle Corporation Steve McKinty 2005-11 2013-08-14
sunclustergeo 2084 udp SunCluster Geographic Oracle Corporation Steve McKinty 2005-11 2013-08-14
ada-cip 2085 tcp ADA Control Eugene Frenkel Eugene Frenkel 2005-11
ada-cip 2085 udp ADA Control Eugene Frenkel Eugene Frenkel 2005-11
gnunet 2086 tcp GNUnet Christian Grothoff Christian Grothoff 2002-10
gnunet 2086 udp GNUnet Christian Grothoff Christian Grothoff 2002-10
eli 2087 tcp ELI - Event Logging Integration Maya Zimerman Maya Zimerman
eli 2087 udp ELI - Event Logging Integration Maya Zimerman Maya Zimerman
ip-blf 2088 tcp IP Busy Lamp Field Jeffrey Szczepanski Jeffrey Szczepanski 2005-02
ip-blf 2088 udp IP Busy Lamp Field Jeffrey Szczepanski Jeffrey Szczepanski 2005-02
sep 2089 tcp Security Encapsulation Protocol - SEP Maya Zimerman Maya Zimerman
sep 2089 udp Security Encapsulation Protocol - SEP Maya Zimerman Maya Zimerman
lrp 2090 tcp Load Report Protocol Amir Peless Amir Peless
lrp 2090 udp Load Report Protocol Amir Peless Amir Peless
prp 2091 tcp PRP Amir Peless Amir Peless
prp 2091 udp PRP Amir Peless Amir Peless
descent3 2092 tcp Descent 3 Kevin Bentley Kevin Bentley
descent3 2092 udp Descent 3 Kevin Bentley Kevin Bentley
nbx-cc 2093 tcp NBX CC
nbx-cc 2093 udp NBX CC
nbx-au 2094 tcp NBX AU
nbx-au 2094 udp NBX AU
nbx-ser 2095 tcp NBX SER
nbx-ser 2095 udp NBX SER
nbx-dir 2096 tcp NBX DIR Henry Houh Henry Houh
nbx-dir 2096 udp NBX DIR Henry Houh Henry Houh
jetformpreview 2097 tcp Jet Form Preview Zygmunt Wiercioch Zygmunt Wiercioch
jetformpreview 2097 udp Jet Form Preview Zygmunt Wiercioch Zygmunt Wiercioch
dialog-port 2098 tcp Dialog Port Joseph Mathew Joseph Mathew
dialog-port 2098 udp Dialog Port Joseph Mathew Joseph Mathew
h2250-annex-g 2099 tcp H.225.0 Annex G Signalling ITU-T ITU-T TSB 2013-01-31
h2250-annex-g 2099 udp H.225.0 Annex G Signalling ITU-T ITU-T TSB 2013-01-31
amiganetfs 2100 tcp Amiga Network Filesystem Rudi Chiarito Rudi Chiarito
amiganetfs 2100 udp Amiga Network Filesystem Rudi Chiarito Rudi Chiarito
rtcm-sc104 2101 tcp rtcm-sc104 Wolfgang Rupprecht Wolfgang Rupprecht
rtcm-sc104 2101 udp rtcm-sc104 Wolfgang Rupprecht Wolfgang Rupprecht
zephyr-srv 2102 tcp Zephyr server
zephyr-srv 2102 udp Zephyr server
zephyr-clt 2103 tcp Zephyr serv-hm connection
zephyr-clt 2103 udp Zephyr serv-hm connection
zephyr-hm 2104 tcp Zephyr hostmanager Greg Hudson Greg Hudson
zephyr-hm 2104 udp Zephyr hostmanager Greg Hudson Greg Hudson
minipay 2105 tcp MiniPay Amir Herzberg Amir Herzberg
minipay 2105 udp MiniPay Amir Herzberg Amir Herzberg
mzap 2106 tcp MZAP Dave Thaler Dave Thaler
mzap 2106 udp MZAP Dave Thaler Dave Thaler
bintec-admin 2107 tcp BinTec Admin Thomas Schmidt Thomas Schmidt
bintec-admin 2107 udp BinTec Admin Thomas Schmidt Thomas Schmidt
comcam 2108 tcp Comcam Don Gilbreath Don Gilbreath
comcam 2108 udp Comcam Don Gilbreath Don Gilbreath
ergolight 2109 tcp Ergolight Jindra Ryvola Jindra Ryvola
ergolight 2109 udp Ergolight Jindra Ryvola Jindra Ryvola
umsp 2110 tcp UMSP Alexander Bogdanov Alexander Bogdanov
umsp 2110 udp UMSP Alexander Bogdanov Alexander Bogdanov
dsatp 2111 tcp OPNET Dynamic Sampling Agent Transaction Protocol OPNET Technologies Inc Edward Macomber 2011-09-21
dsatp 2111 udp OPNET Dynamic Sampling Agent Transaction Protocol OPNET Technologies Inc Edward Macomber 2011-09-21
idonix-metanet 2112 tcp Idonix MetaNet Paul Harrison Paul Harrison
idonix-metanet 2112 udp Idonix MetaNet Paul Harrison Paul Harrison
hsl-storm 2113 tcp HSL StoRM Jost Faganel Jost Faganel
hsl-storm 2113 udp HSL StoRM Jost Faganel Jost Faganel
ariascribe 2114 tcp Classical Music Meta-Data Access and Enhancement Aria Scribe Software Ltd Michael Levy 2018-02-05
ariascribe 2114 udp Classical Music Meta-Data Access and Enhancement Aria Scribe Software Ltd Michael Levy 2018-02-05
kdm 2115 tcp Key Distribution Manager Mike Little Mike Little
kdm 2115 udp Key Distribution Manager Mike Little Mike Little
ccowcmr 2116 tcp CCOWCMR Mark Morwood Mark Morwood
ccowcmr 2116 udp CCOWCMR Mark Morwood Mark Morwood
mentaclient 2117 tcp MENTACLIENT
mentaclient 2117 udp MENTACLIENT
mentaserver 2118 tcp MENTASERVER Ilan Shlosberg Ilan Shlosberg
mentaserver 2118 udp MENTASERVER Ilan Shlosberg Ilan Shlosberg
gsigatekeeper 2119 tcp GSIGATEKEEPER Steve Tuecke Steve Tuecke
gsigatekeeper 2119 udp GSIGATEKEEPER Steve Tuecke Steve Tuecke
qencp 2120 tcp Quick Eagle Networks CP Santa Dasu Santa Dasu
qencp 2120 udp Quick Eagle Networks CP Santa Dasu Santa Dasu
scientia-ssdb 2121 tcp SCIENTIA-SSDB SYSTEMS MANAGER SYSTEMS MANAGER
scientia-ssdb 2121 udp SCIENTIA-SSDB SYSTEMS MANAGER SYSTEMS MANAGER
caupc-remote 2122 tcp CauPC Remote Control Environics Oy Environics Oy
caupc-remote 2122 udp CauPC Remote Control Environics Oy Environics Oy
gtp-control 2123 tcp GTP-Control Plane (3GPP) Alessio Casati Alessio Casati
gtp-control 2123 udp GTP-Control Plane (3GPP) Alessio Casati Alessio Casati
elatelink 2124 tcp ELATELINK Tim Lawrence Tim Lawrence
elatelink 2124 udp ELATELINK Tim Lawrence Tim Lawrence
lockstep 2125 tcp LOCKSTEP Karl Forster Karl Forster
lockstep 2125 udp LOCKSTEP Karl Forster Karl Forster
pktcable-cops 2126 tcp PktCable-COPS Glenn Russell Glenn Russell
pktcable-cops 2126 udp PktCable-COPS Glenn Russell Glenn Russell
index-pc-wb 2127 tcp INDEX-PC-WB James David Fisher James David Fisher
index-pc-wb 2127 udp INDEX-PC-WB James David Fisher James David Fisher
net-steward 2128 tcp Net Steward Control Martin Norman Martin Norman
net-steward 2128 udp Net Steward Control Martin Norman Martin Norman
cs-live 2129 tcp cs-live.com Matt Lachance Matt Lachance
cs-live 2129 udp cs-live.com Matt Lachance Matt Lachance
xds 2130 tcp XDS Peter Zurich Peter Zurich
xds 2130 udp XDS Peter Zurich Peter Zurich
avantageb2b 2131 tcp Avantageb2b Avi Software Avi Software
avantageb2b 2131 udp Avantageb2b Avi Software Avi Software

Contact Information

Name Organization Contact URI Last Updated
Alessio Casati a.casati&computer.org
Alexander Bogdanov alexander_bgd&softhome.net
Amir Herzberg amirh&vnet.ibm.com
Amir Peless amirp&radware.co.il
Aria Scribe Software Ltd scribe&ariascribe.com 2018-02-05
Avi Software srobert&logava.com
Christian Grothoff grothoff&gnunet.org 2017-11-16
Dave Thaler dthaler&microsoft.com
Don Gilbreath don&comcam.net 2002-09
Edward Macomber OPNET Technologies Inc tmacomber&opnet.com 2011-09-21
Environics Oy pasi.nuutinmaki&environics.fi
Eugene Frenkel eugene&ada-usa.com 2005-11
Glenn Russell grussell&cablelabs.com
Greg Hudson zephyr-bugs&mit.edu
Henry Houh hhouh&nbxcorp.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
ITU-T tsbsg16&itu.int 2013-01-31
ITU-T TSB ITU-T tsbsg16&itu.int 2013-01-31
Ilan Shlosberg ilan&mentasoftware.com
James David Fisher jfisher1&avaya.com
Jeffrey Szczepanski jrs&inscitek.com 2005-02
Jindra Ryvola jryvola&ledalite.com
Joseph Mathew mjoseph&dosa.cisco.com
Jost Faganel jost.faganel&hermes.si
Karl Forster kforster&lockstep.com
Kaz Kylheku kkylheku&infowave.com
Kevin Bentley Kevin&outrage.com
Mark Morwood markm&sentillion.com
Martin Norman martin&ndl.co.uk
Masakatsu Matsuo masa&sdsft.kme.mei.co.jp
Matt Lachance matt&cs-live.com
Maya Zimerman mayaz&radware.co.il
Michael Levy scribe&ariascribe.com 2018-01-24
Mike Little mike.little&gdc4s.com
OPNET Technologies Inc tmacomber&opnet.com 2011-09-21
Oracle Corporation steve.mckinty&oracle.com 2013-08-14
Paul Harrison paulh&idonix.co.uk
Peter Zurich pbz&lowpft.com
Rudi Chiarito nutello&sweetness.com
SYSTEMS MANAGER systems-manager&scientia.com
Santa Dasu Santa_Dasu&quickeagle.com
Steve McKinty Oracle Corporation steve.mckinty&oracle.com 2013-08-14
Steve Tuecke tuecke&mcs.anl.gov
Thomas Schmidt ts&bintec.de
Tim Lawrence lawrence&tao-group.com
Wolfgang Rupprecht wolfgang&wsrcc.com
Zygmunt Wiercioch zyg&jetform.com