Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| hostname | 101 | tcp | NIC Host Name Server | Jon Postel | Jon Postel | ||||||
| hostname | 101 | udp | NIC Host Name Server | Jon Postel | Jon Postel | ||||||
| surf | 1010 | tcp | surf | Joseph Geer | Joseph Geer | ||||||
| surf | 1010 | udp | surf | Joseph Geer | Joseph Geer | ||||||
| 1011-1020 | Reserved | ||||||||||
| pt2-discover | 1101 | tcp | PT2-DISCOVER | Ralph Kammerlander | Ralph Kammerlander | ||||||
| pt2-discover | 1101 | udp | PT2-DISCOVER | Ralph Kammerlander | Ralph Kammerlander | ||||||
| re101 | 1343 | tcp | re101 | Doriano Blengino | Doriano Blengino | ||||||
| re101 | 1343 | udp | re101 | Doriano Blengino | Doriano Blengino | ||||||
| rtcm-sc104 | 2101 | tcp | rtcm-sc104 | Wolfgang Rupprecht | Wolfgang Rupprecht | ||||||
| rtcm-sc104 | 2101 | udp | rtcm-sc104 | Wolfgang Rupprecht | Wolfgang Rupprecht | ||||||
| hp-pxpib | 3101 | tcp | HP PolicyXpert PIB Server | Brian O'Keefe | Brian O'Keefe | ||||||
| hp-pxpib | 3101 | udp | HP PolicyXpert PIB Server | Brian O'Keefe | Brian O'Keefe | ||||||
| brlp-0 | 4101 | tcp | Braille protocol | ||||||||
| brlp-0 | 4101 | udp | Braille protocol | ||||||||
| talarian-tcp | 5101 | tcp | Talarian_TCP | Leo Martins | Leo Martins | ||||||
| talarian-udp | 5101 | udp | Talarian_UDP | Leo Martins | Leo Martins | ||||||
| synchronet-rtc | 6101 | tcp | SynchroNet-rtc | Arne Haugland | Arne Haugland | ||||||
| synchronet-rtc | 6101 | udp | SynchroNet-rtc | Arne Haugland | Arne Haugland | ||||||
| elcn | 7101 | tcp | Embedded Light Control Network | Michael Scarito | Michael Scarito | 2007-02 | |||||
| elcn | 7101 | udp | Embedded Light Control Network | Michael Scarito | Michael Scarito | 2007-02 | |||||
| ldoms-migr | 8101 | tcp | Logical Domains Migration | Liam Merwick | Liam Merwick | 2009-01-16 | |||||
| 8101 | udp | Reserved | |||||||||
| bacula-dir | 9101 | tcp | Bacula Director | Kern Sibbald | Kern Sibbald | 2002-01 | |||||
| bacula-dir | 9101 | udp | Bacula Director | Kern Sibbald | Kern Sibbald | 2002-01 | |||||
| itap-ddtp | 10100 | tcp | VERITAS ITAP DDTP | Saugata Guha | Saugata Guha | 2004-05 | |||||
| itap-ddtp | 10100 | udp | VERITAS ITAP DDTP | Saugata Guha | Saugata Guha | 2004-05 | |||||
| ezmeeting-2 | 10101 | tcp | eZmeeting | Albert C. Yang | Albert C. Yang | 2002-03 | |||||
| ezmeeting-2 | 10101 | udp | eZmeeting | Albert C. Yang | Albert C. Yang | 2002-03 | |||||
| ezproxy-2 | 10102 | tcp | eZproxy | Albert C. Yang | Albert C. Yang | 2002-03 | |||||
| ezproxy-2 | 10102 | udp | eZproxy | Albert C. Yang | Albert C. Yang | 2002-03 | |||||
| ezrelay | 10103 | tcp | eZrelay | Albert C. Yang | Albert C. Yang | 2002-03 | |||||
| ezrelay | 10103 | udp | eZrelay | Albert C. Yang | Albert C. Yang | 2002-03 | |||||
| swdtp | 10104 | tcp | Systemwalker Desktop Patrol | Akira Ide | Akira Ide | 2006-09 | |||||
| swdtp | 10104 | udp | Systemwalker Desktop Patrol | Akira Ide | Akira Ide | 2006-09 | |||||
| 10105-10106 | Unassigned | ||||||||||
| bctp-server | 10107 | tcp | VERITAS BCTP, server | Saugata Guha | Saugata Guha | 2004-05 | |||||
| bctp-server | 10107 | udp | VERITAS BCTP, server | Saugata Guha | Saugata Guha | 2004-05 | |||||
| 10108-10109 | Unassigned | ||||||||||
| nmea-0183 | 10110 | tcp | NMEA-0183 Navigational Data | Meindert Sprang | Meindert Sprang | 2009-02-18 | |||||
| nmea-0183 | 10110 | udp | NMEA-0183 Navigational Data | Meindert Sprang | Meindert Sprang | 2009-02-18 | |||||
| 10111 | tcp | Reserved | |||||||||
| nmea-onenet | 10111 | udp | NMEA OneNet multicast messaging | National Marine Electronics Association | Mark Oslund | 2011-09-15 | 2023-12-27 | ||||
| 10112 | Unassigned | ||||||||||
| netiq-endpoint | 10113 | tcp | NetIQ Endpoint | John Wood | John Wood | ||||||
| netiq-endpoint | 10113 | udp | NetIQ Endpoint | John Wood | John Wood | ||||||
| netiq-qcheck | 10114 | tcp | NetIQ Qcheck | Michael Sharpe | Michael Sharpe | 2010-09-14 | |||||
| netiq-qcheck | 10114 | udp | NetIQ Qcheck | Michael Sharpe | Michael Sharpe | 2010-09-14 | |||||
| netiq-endpt | 10115 | tcp | NetIQ Endpoint | Gary Weichinger | Gary Weichinger | ||||||
| netiq-endpt | 10115 | udp | NetIQ Endpoint | Gary Weichinger | Gary Weichinger | ||||||
| netiq-voipa | 10116 | tcp | NetIQ VoIP Assessor | Gary Weichinger | Gary Weichinger | ||||||
| netiq-voipa | 10116 | udp | NetIQ VoIP Assessor | Gary Weichinger | Gary Weichinger | ||||||
| iqrm | 10117 | tcp | NetIQ IQCResource Managament Svc | Michael Sharpe | Michael Sharpe | 2010-09-14 | |||||
| iqrm | 10117 | udp | NetIQ IQCResource Managament Svc | Michael Sharpe | Michael Sharpe | 2010-09-14 | |||||
| 10118-10124 | Unassigned | ||||||||||
| cimple | 10125 | tcp | HotLink CIMple REST API | HotLink Corporation | Richard Offer | 2014-12-18 | |||||
| 10125 | udp | Reserved | |||||||||
| 10126-10127 | Unassigned | ||||||||||
| bmc-perf-sd | 10128 | tcp | BMC-PERFORM-SERVICE DAEMON | Portnoy Boxman | Portnoy Boxman | ||||||
| bmc-perf-sd | 10128 | udp | BMC-PERFORM-SERVICE DAEMON | Portnoy Boxman | Portnoy Boxman | ||||||
| bmc-gms | 10129 | tcp | BMC General Manager Server | Dima Seliverstov | Dima Seliverstov | 2009-07-28 | |||||
| 10129 | udp | Reserved | |||||||||
| 10130-10159 | Unassigned | ||||||||||
| qb-db-server | 10160 | tcp | QB Database Server | Wei Wang | Wei Wang | 2005-11 | |||||
| qb-db-server | 10160 | udp | QB Database Server | Wei Wang | Wei Wang | 2005-11 | |||||
| snmptls | 10161 | tcp | SNMP-TLS | RFC 6353 | |||||||
| snmpdtls | 10161 | udp | SNMP-DTLS | RFC 6353 | |||||||
| snmptls-trap | 10162 | tcp | SNMP-Trap-TLS | RFC 6353 | |||||||
| snmpdtls-trap | 10162 | udp | SNMP-Trap-DTLS | RFC 6353 | |||||||
| 10163-10199 | Unassigned | ||||||||||
| notezilla-lan | 21010 | tcp | Notezilla.Lan Server | Conceptworld Corporation | Gautam Jain | 2013-08-20 | |||||
| 21010 | udp | Reserved | |||||||||
| 21011-21211 | Unassigned | ||||||||||
| 25101-25470 | Unassigned | ||||||||||
| 30101-30259 | Unassigned | ||||||||||
| 31000-31015 | Unassigned | ||||||||||
| ka-sddp | 31016 | tcp | Kollective Agent Secure Distributed Delivery Protocol | Kollective Technology Inc. | John Wainwright | 2016-12-11 | |||||
| ka-kdp | 31016 | udp | Kollective Agent Kollective Delivery Protocol | Kollective Technology Inc. | John Wainwright | 2016-12-11 | |||||
| 31017-31019 | Unassigned | ||||||||||
| 35101-35353 | Unassigned | ||||||||||
| 47101-47556 | Unassigned |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Akira Ide | ide.akira&jp.fujitsu.com | 2006-09 | |
| Albert C. Yang | albert.yang&ezmeeting.com | 2002-03 | |
| Arne Haugland | Arne.Haugland¶soldev.com | ||
| Brian O'Keefe | bokeefe&cnd.hp.com | ||
| Conceptworld Corporation | admin&conceptworld.com | 2013-08-20 | |
| Dima Seliverstov | Dima_Seliverstov&bmc.com | 2009-07-28 | |
| Doriano Blengino | tecnico_remove_&_remove_xonelectronics.it | ||
| Gary Weichinger | gary.weichinger&netiq.com | ||
| Gautam Jain | Conceptworld Corporation | admin&conceptworld.com | 2013-08-20 |
| HotLink Corporation | roffer&hotlink.com | 2014-12-18 | |
| John Wainwright | jwainwright&kollective.com | 2016-12-11 | |
| John Wood | John.Wood&netiq.com | ||
| Jon Postel | postel&isi.edu | ||
| Joseph Geer | jgeer&peapod.com | ||
| Kern Sibbald | kern&sibbald.com | 2002-01 | |
| Kollective Technology Inc. | info&kollective.com | 2016-12-11 | |
| Leo Martins | leo&talarian.com | ||
| Liam Merwick | ldoms-iana-ports&sun.com | 2009-01-16 | |
| Mark Oslund | National Marine Electronics Association | info&nmea.org | 2023-12-27 |
| Meindert Sprang | ms&customware.nl | 2009-02-18 | |
| Michael Scarito | ms&mit.edu | 2007-02 | |
| Michael Sharpe | iana-ports&netiq.com | 2010-09-14 | |
| National Marine Electronics Association | standards&nmea.org | 2023-12-27 | |
| Portnoy Boxman | portnoy_boxman&bmc.com | 2005-01 | |
| Ralph Kammerlander | ralph.kammerlander&khe.siemens.de | ||
| Richard Offer | HotLink Corporation | roffer&hotlink.com | 2014-12-18 |
| Saugata Guha | sguha&veritas.com | 2004-05 | |
| Wei Wang | Wei_Wang&intuit.com | 2005-11 | |
| Wolfgang Rupprecht | wolfgang&wsrcc.com |