Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
discard 9 dccp Discard Eddie Kohler Eddie Kohler RFC 4340 1145656131
systat 11 tcp Active Users Jon Postel Jon Postel
systat 11 udp Active Users Jon Postel Jon Postel
http 80 tcp World Wide Web HTTP IESG IETF Chair 2021-10-01 RFC 9110 Defined TXT keys: u=<username> p=<password> path=<path to document>
http 80 udp World Wide Web HTTP IESG IETF Chair 2021-10-01 RFC 9110 Defined TXT keys: u=<username> p=<password> path=<path to document>
www 80 tcp World Wide Web HTTP IESG IETF Chair 2021-10-01 RFC 9110 This is a duplicate of the "http" service and should not be used for discovery purposes.
www 80 udp World Wide Web HTTP IESG IETF Chair 2021-10-01 RFC 9110 This is a duplicate of the "http" service and should not be used for discovery purposes.
pop3 110 tcp Post Office Protocol - Version 3 Marshall Rose Marshall Rose
pop3 110 udp Post Office Protocol - Version 3 Marshall Rose Marshall Rose
sunrpc 111 tcp SUN Remote Procedure Call Chuck McManis Chuck McManis
sunrpc 111 udp SUN Remote Procedure Call Chuck McManis Chuck McManis
mcidas 112 tcp McIDAS Data Transmission Protocol Glenn Davis Glenn Davis
mcidas 112 udp McIDAS Data Transmission Protocol Glenn Davis Glenn Davis
ident 113 tcp
auth 113 tcp Authentication Service Mike St. Johns Mike St. Johns
auth 113 udp Authentication Service Mike St. Johns Mike St. Johns
114 unassigned Deprecated June 2004
sftp 115 tcp Simple File Transfer Protocol Mark Lottor Mark Lottor
sftp 115 udp Simple File Transfer Protocol Mark Lottor Mark Lottor
ansanotify 116 tcp ANSA REX Notify Nicola J. Howarth Nicola J. Howarth
ansanotify 116 udp ANSA REX Notify Nicola J. Howarth Nicola J. Howarth
uucp-path 117 tcp UUCP Path Service
uucp-path 117 udp UUCP Path Service
sqlserv 118 tcp SQL Services Larry Barnes Larry Barnes
sqlserv 118 udp SQL Services Larry Barnes Larry Barnes
nntp 119 tcp Network News Transfer Protocol IESG IETF Chair 2018-07-06 RFC 3977
nntp 119 udp Network News Transfer Protocol IESG IETF Chair 2018-07-06 RFC 3977
914c-g 211 tcp Texas Instruments 914C/G Terminal

IANA assigned this well-formed service name as a replacement for "914c/g".
Bill Harrell Bill Harrell
914c/g 211 tcp Texas Instruments 914C/G Terminal Bill Harrell Bill Harrell This entry is an alias to "914c-g". This entry is now historic, not usable for use with many common service discovery mechanisms.
914c-g 211 udp Texas Instruments 914C/G Terminal

IANA assigned this well-formed service name as a replacement for "914c/g".
Bill Harrell Bill Harrell
914c/g 211 udp Texas Instruments 914C/G Terminal Bill Harrell Bill Harrell This entry is an alias to "914c-g". This entry is now historic, not usable for use with many common service discovery mechanisms.
asip-webadmin 311 tcp AppleShare IP WebAdmin Ann Huang Ann Huang
asip-webadmin 311 udp AppleShare IP WebAdmin Ann Huang Ann Huang
bh611 354 tcp bh611 John Kelly John Kelly
bh611 354 udp bh611 John Kelly John Kelly
359 tcp Reserved 2023-11-16 De-Assigned on 2023-11-16.
359 udp Reserved 2023-11-16 De-Assigned on 2023-11-16.
rmt 411 tcp Remote MT Protocol Peter Eriksson Peter Eriksson
rmt 411 udp Remote MT Protocol Peter Eriksson Peter Eriksson
https 443 tcp http protocol over TLS/SSL IESG IETF Chair 2021-10-01 RFC 9110
https 443 udp http protocol over TLS/SSL IESG IETF Chair 2021-10-01 RFC 9110
passgo 511 tcp PassGo John Rainford John Rainford
passgo 511 udp PassGo John Rainford John Rainford
npmp-gui 611 tcp npmp-gui John Barnes John Barnes
npmp-gui 611 udp npmp-gui John Barnes John Barnes
ipp 631 tcp IPP (Internet Printing Protocol) IESG IETF Chair 2018-07-06 RFC 8011 Defined TXT keys: See BonjourPrinting.pdf.
ipp 631 udp IPP (Internet Printing Protocol) IESG IETF Chair 2018-07-06 RFC 8011 Defined TXT keys: See BonjourPrinting.pdf.
ipps 631 tcp Internet Printing Protocol over HTTPS IESG IETF Chair 2018-07-06 RFC 8011
cisco-tdp 711 tcp Cisco TDP Bruce Davie Bruce Davie
cisco-tdp 711 udp Cisco TDP Bruce Davie Bruce Davie
811-827 Unassigned
xact-backup 911 tcp xact-backup Bill Carroll Bill Carroll
xact-backup 911 udp xact-backup Bill Carroll Bill Carroll
1011-1020 Reserved
mctp 1100 tcp MCTP Vitaly Revsin Vitaly Revsin
mctp 1100 udp MCTP Vitaly Revsin Vitaly Revsin
pt2-discover 1101 tcp PT2-DISCOVER Ralph Kammerlander Ralph Kammerlander
pt2-discover 1101 udp PT2-DISCOVER Ralph Kammerlander Ralph Kammerlander
adobeserver-1 1102 tcp ADOBE SERVER 1
adobeserver-1 1102 udp ADOBE SERVER 1
adobeserver-2 1103 tcp ADOBE SERVER 2 Frank Soetebeer Frank Soetebeer
adobeserver-2 1103 udp ADOBE SERVER 2 Frank Soetebeer Frank Soetebeer
xrl 1104 tcp XRL Patrick Robinson Patrick Robinson
xrl 1104 udp XRL Patrick Robinson Patrick Robinson
ftranhc 1105 tcp FTRANHC Eriko Shimada Eriko Shimada
ftranhc 1105 udp FTRANHC Eriko Shimada Eriko Shimada
isoipsigport-1 1106 tcp ISOIPSIGPORT-1
isoipsigport-1 1106 udp ISOIPSIGPORT-1
isoipsigport-2 1107 tcp ISOIPSIGPORT-2 Peter Egli Peter Egli
isoipsigport-2 1107 udp ISOIPSIGPORT-2 Peter Egli Peter Egli
ratio-adp 1108 tcp ratio-adp Oliver Thulke Oliver Thulke
ratio-adp 1108 udp ratio-adp Oliver Thulke Oliver Thulke
1109 Reserved - IANA
webadmstart 1110 tcp Start web admin server
nfsd-keepalive 1110 udp Client status info Beth Crespo Beth Crespo
lmsocialserver 1111 tcp LM Social Server Ron Lussier Ron Lussier
lmsocialserver 1111 udp LM Social Server Ron Lussier Ron Lussier
icp 1112 tcp Intelligent Communication Protocol Mark H. David Mark H. David
icp 1112 udp Intelligent Communication Protocol Mark H. David Mark H. David
ltp-deepspace 1113 tcp Licklider Transmission Protocol RFC 5326
ltp-deepspace 1113 udp Licklider Transmission Protocol 2014-02-21 RFC 5326; RFC 7122
ltp-deepspace 1113 dccp Licklider Transmission Protocol 2013-11-12 2014-02-21 RFC 7122 7107696
mini-sql 1114 tcp Mini SQL David Hughes David Hughes
mini-sql 1114 udp Mini SQL David Hughes David Hughes
ardus-trns 1115 tcp ARDUS Transfer
ardus-trns 1115 udp ARDUS Transfer
ardus-cntl 1116 tcp ARDUS Control
ardus-cntl 1116 udp ARDUS Control
ardus-mtrns 1117 tcp ARDUS Multicast Transfer Shinya Abe Shinya Abe
ardus-mtrns 1117 udp ARDUS Multicast Transfer Shinya Abe Shinya Abe
sacred 1118 tcp SACRED RFC 3767
sacred 1118 udp SACRED RFC 3767
bnetgame 1119 tcp Battle.net Chat/Game Protocol
bnetgame 1119 udp Battle.net Chat/Game Protocol
bnetfile 1120 tcp Battle.net File Transfer Protocol Domain Tech Domain Tech 2005-04
bnetfile 1120 udp Battle.net File Transfer Protocol Domain Tech Domain Tech 2005-04
rmpp 1121 tcp Datalode RMPP Dave Ruedger Dave Ruedger 2003-11
rmpp 1121 udp Datalode RMPP Dave Ruedger Dave Ruedger 2003-11
availant-mgr 1122 tcp availant-mgr Steven Pelletier Steven Pelletier
availant-mgr 1122 udp availant-mgr Steven Pelletier Steven Pelletier

Contact Information

Name Organization Contact URI Last Updated
Ann Huang annhuang&apple.com
Beth Crespo beth.crespo&hp.com
Bill Carroll billc&xactlabs.com
Bill Harrell
Bruce Davie bsd&cisco.com
Chuck McManis cmcmanis&freegate.net
Dave Ruedger daver&datalode.com 2003-11
David Hughes bambi&hughes.com.au
Domain Tech Domainnametech&blizzard.com 2005-04
Eddie Kohler IETF dccp WG kohler&cs.ucla.edu
Eriko Shimada eriko&kel.fujitsu.co.jp
Frank Soetebeer frsoeteb&adobe.com 2003-01
Glenn Davis support&unidata.ucar.edu
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
John Barnes jbarnes&crl.com
John Kelly johnk&bellhow.com
John Rainford jrainford&passgo.com
Jon Postel postel&isi.edu
Larry Barnes barnes&broke.enet.dec.com
Mark H. David mhd&gensym.com
Mark Lottor MKL&nisc.sri.com
Marshall Rose mrose17&gmail.com 2024-07-29
Mike St. Johns stjohns&arpa.mil
Nicola J. Howarth njh&ansa.co.uk
Oliver Thulke oth&ratio.de
Patrick Robinson probinson&plosive.com
Peter Egli peter.egli&inalp.com
Peter Eriksson pen&lysator.liu.se
Ralph Kammerlander ralph.kammerlander&khe.siemens.de
Ron Lussier coyote&likeminds.com
Shinya Abe abeabe&pfu.co.jp
Steven Pelletier stevep&availant.com
Vitaly Revsin vitaly&webmanage.com