Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
sunrpc 111 tcp SUN Remote Procedure Call Chuck McManis Chuck McManis
sunrpc 111 udp SUN Remote Procedure Call Chuck McManis Chuck McManis
webadmstart 1110 tcp Start web admin server
nfsd-keepalive 1110 udp Client status info Beth Crespo Beth Crespo
lmsocialserver 1111 tcp LM Social Server Ron Lussier Ron Lussier
lmsocialserver 1111 udp LM Social Server Ron Lussier Ron Lussier
icp 1112 tcp Intelligent Communication Protocol Mark H. David Mark H. David
icp 1112 udp Intelligent Communication Protocol Mark H. David Mark H. David
ltp-deepspace 1113 tcp Licklider Transmission Protocol RFC 5326
ltp-deepspace 1113 udp Licklider Transmission Protocol 2014-02-21 RFC 5326; RFC 7122
ltp-deepspace 1113 dccp Licklider Transmission Protocol 2013-11-12 2014-02-21 RFC 7122 7107696
mini-sql 1114 tcp Mini SQL David Hughes David Hughes
mini-sql 1114 udp Mini SQL David Hughes David Hughes
ardus-trns 1115 tcp ARDUS Transfer
ardus-trns 1115 udp ARDUS Transfer
ardus-cntl 1116 tcp ARDUS Control
ardus-cntl 1116 udp ARDUS Control
ardus-mtrns 1117 tcp ARDUS Multicast Transfer Shinya Abe Shinya Abe
ardus-mtrns 1117 udp ARDUS Multicast Transfer Shinya Abe Shinya Abe
sacred 1118 tcp SACRED RFC 3767
sacred 1118 udp SACRED RFC 3767
bnetgame 1119 tcp Battle.net Chat/Game Protocol
bnetgame 1119 udp Battle.net Chat/Game Protocol
dsatp 2111 tcp OPNET Dynamic Sampling Agent Transaction Protocol OPNET Technologies Inc Edward Macomber 2011-09-21
dsatp 2111 udp OPNET Dynamic Sampling Agent Transaction Protocol OPNET Technologies Inc Edward Macomber 2011-09-21
wsynch 3111 tcp Web Synchronous Services Valery Fremaux Valery Fremaux
wsynch 3111 udp Web Synchronous Services Valery Fremaux Valery Fremaux
xgrid 4111 tcp Xgrid David Kramer David Kramer 2004-11
xgrid 4111 udp Xgrid David Kramer David Kramer 2004-11
taep-as-svc 5111 tcp TAEP AS service Liu Changchun Liu Changchun 2008-11-05
taep-as-svc 5111 udp TAEP AS service Liu Changchun Liu Changchun 2008-11-05
spc 6111 tcp HP SoftBench Sub-Process Control Scott A. Kramer Scott A. Kramer
spc 6111 udp HP SoftBench Sub-Process Control Scott A. Kramer Scott A. Kramer
8111 tcp Reserved
skynetflow 8111 udp Skynetflow network services skynetflow.com Dmitrii Ogarkov 2019-05-28
hexxorecore 9111 tcp Multiple Purpose, Distributed Message Bus Hexxore Patrick Roozeboom 2018-07-31
hexxorecore 9111 udp Multiple Purpose, Distributed Message Bus Hexxore Patrick Roozeboom 2018-07-31
10111 tcp Reserved
nmea-onenet 10111 udp NMEA OneNet multicast messaging National Marine Electronics Association Mark Oslund 2011-09-15 2023-12-27
11096-11102 Unassigned
origo-sync 11103 tcp OrigoDB Server Sync Interface Devrex Labs Robert Friberg 2013-03-29
11103 udp Reserved
netapp-icmgmt 11104 tcp NetApp Intercluster Management Craig Everhart Craig Everhart 2010-07-06
11104 udp Reserved
netapp-icdata 11105 tcp NetApp Intercluster Data Craig Everhart Craig Everhart 2010-07-06
11105 udp Reserved
sgi-lk 11106 tcp SGI LK Licensing service Michel Bourget Michel Bourget 2009-01-06
sgi-lk 11106 udp SGI LK Licensing service Michel Bourget Michel Bourget 2009-01-06
11107 Unassigned
myq-termlink 11108 udp Hardware Terminals Discovery and Low-Level Communication Protocol JANUS, spol. s r.o. Jakub Ahmadyar 2013-04-23
11108 tcp Reserved
sgi-dmfmgr 11109 tcp Data migration facility Manager (DMF) is a browser based interface to DMF SGI John Sygulla 2013-01-07
11109 udp Reserved
sgi-soap 11110 tcp Data migration facility (DMF) SOAP is a web server protocol to support remote access to DMF SGI John Sygulla 2013-01-07
11110 udp Reserved
vce 11111 tcp Viral Computing Environment (VCE) Fred Cohen Fred Cohen
vce 11111 udp Viral Computing Environment (VCE) Fred Cohen Fred Cohen
dicom 11112 tcp DICOM David Clunie David Clunie 2005-08
dicom 11112 udp DICOM David Clunie David Clunie 2005-08
11113-11160 Unassigned
suncacao-snmp 11161 tcp sun cacao snmp access point Nick Stephen Nick Stephen 2005-08
suncacao-snmp 11161 udp sun cacao snmp access point Nick Stephen Nick Stephen 2005-08
suncacao-jmxmp 11162 tcp sun cacao JMX-remoting access point Nick Stephen Nick Stephen 2005-08
suncacao-jmxmp 11162 udp sun cacao JMX-remoting access point Nick Stephen Nick Stephen 2005-08
suncacao-rmi 11163 tcp sun cacao rmi registry access point Nick Stephen Nick Stephen 2005-08
suncacao-rmi 11163 udp sun cacao rmi registry access point Nick Stephen Nick Stephen 2005-08
suncacao-csa 11164 tcp sun cacao command-streaming access point Nick Stephen Nick Stephen 2005-08
suncacao-csa 11164 udp sun cacao command-streaming access point Nick Stephen Nick Stephen 2005-08
suncacao-websvc 11165 tcp sun cacao web service access point Nick Stephen Nick Stephen 2005-08
suncacao-websvc 11165 udp sun cacao web service access point Nick Stephen Nick Stephen 2005-08
11166-11170 Unassigned
11171 tcp Reserved
snss 11171 udp Surgical Notes Security Service Discovery (SNSS) David Lethe David Lethe 2010-12-24
oemcacao-jmxmp 11172 tcp OEM cacao JMX-remoting access point David Sechrest David Sechrest 2010-09-22
11172 udp Reserved
t5-straton 11173 tcp Straton Runtime Programing COPALP Jerome FOLLUT 2012-03-01
11173 udp Reserved
oemcacao-rmi 11174 tcp OEM cacao rmi registry access point David Sechrest David Sechrest 2010-09-22
11174 udp Reserved
oemcacao-websvc 11175 tcp OEM cacao web service access point David Sechrest David Sechrest 2010-09-22
11175 udp Reserved
11176-11200 Unassigned
40854-41110 Unassigned
fs-qos 41111 tcp Foursticks QoS Protocol Chee Kent Lam Chee Kent Lam 2002-04
fs-qos 41111 udp Foursticks QoS Protocol Chee Kent Lam Chee Kent Lam 2002-04
41112-41120 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Beth Crespo beth.crespo&hp.com
Chee Kent Lam cklam&foursticks.com 2002-04
Chuck McManis cmcmanis&freegate.net
COPALP jf&copalp.com 2012-03-01
Craig Everhart Craig.Everhart&netapp.com 2010-07-06
David Clunie dclunie&dclunie.com 2005-08
David Hughes bambi&hughes.com.au
David Kramer dkramer&apple.com 2004-11
David Lethe david&santools.com 2010-12-24
David Sechrest david.sechrest&oracle.com 2010-09-22
Devrex Labs robert.friberg&devrex.se 2013-03-29
Dmitrii Ogarkov df&skynetflow.com 2019-05-28
Edward Macomber OPNET Technologies Inc tmacomber&opnet.com 2011-09-21
Fred Cohen fc&all.net
Hexxore info&hexxore.nl 2018-07-31
Jakub Ahmadyar JANUS, spol. s r.o. ahmadyar&myq.cz 2013-04-23
JANUS, spol. s r.o. ahmadyar&myq.cz 2013-04-23
Jerome FOLLUT COPALP jf&copalp.com 2012-03-01
John Sygulla SGI jsygulla&sgi.com 2013-01-07
Liu Changchun blzhang&infospark.cn 2008-11-05
Mark H. David mhd&gensym.com
Mark Oslund National Marine Electronics Association info&nmea.org 2023-12-27
Michel Bourget michel&sgi.com 2009-01-06
National Marine Electronics Association standards&nmea.org 2023-12-27
Nick Stephen nick.stephen&sun.com 2005-08
OPNET Technologies Inc tmacomber&opnet.com 2011-09-21
Patrick Roozeboom info&hexxore.nl 2018-07-31
Robert Friberg Devrex Labs robert.friberg&devrex.se 2013-03-29
Ron Lussier coyote&likeminds.com
SGI jsygulla&sgi.com 2013-01-07
Scott A. Kramer sk&tleilaxu.sde.hp.com
Shinya Abe abeabe&pfu.co.jp
skynetflow.com info&skynetflow.com 2019-05-28
Valery Fremaux vf&eisti.fr