Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-22
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| imap | 143 | tcp | Internet Message Access Protocol | IESG | IETF Chair | 2021-02-22 | RFC 3501; RFC 9051 | ||||
| 143 | udp | Reserved | 2021-02-22 | RFC 9051 | |||||||
| iscsi | 860 | tcp | iSCSI | IESG | IETF Chair | 2013-08-27 | RFC 7143 | ||||
| iscsi | 860 | udp | iSCSI | IESG | IETF Chair | 2013-08-27 | RFC 7143 | ||||
| imyx | 1143 | tcp | Infomatryx Exchange | David Walling | David Walling | 2006-03 | |||||
| imyx | 1143 | udp | Infomatryx Exchange | David Walling | David Walling | 2006-03 | |||||
| tpdu | 1430 | tcp | Hypercom TPDU | Noor Chowdhury | Noor Chowdhury | ||||||
| tpdu | 1430 | udp | Hypercom TPDU | Noor Chowdhury | Noor Chowdhury | ||||||
| rgtp | 1431 | tcp | Reverse Gossip Transport | Ian Jackson | Ian Jackson | ||||||
| rgtp | 1431 | udp | Reverse Gossip Transport | Ian Jackson | Ian Jackson | ||||||
| blueberry-lm | 1432 | tcp | Blueberry Software License Manager | Steve Beigel | Steve Beigel | ||||||
| blueberry-lm | 1432 | udp | Blueberry Software License Manager | Steve Beigel | Steve Beigel | ||||||
| ms-sql-s | 1433 | tcp | Microsoft-SQL-Server | ||||||||
| ms-sql-s | 1433 | udp | Microsoft-SQL-Server | ||||||||
| ms-sql-m | 1434 | tcp | Microsoft-SQL-Monitor | Peter Hussey | Peter Hussey | ||||||
| ms-sql-m | 1434 | udp | Microsoft-SQL-Monitor | Peter Hussey | Peter Hussey | ||||||
| ibm-cics | 1435 | tcp | IBM CICS | Geoff Meacock | Geoff Meacock | ||||||
| ibm-cics | 1435 | udp | IBM CICS | Geoff Meacock | Geoff Meacock | ||||||
| saism | 1436 | tcp | Satellite-data Acquisition System 2 | Bill Taylor | Bill Taylor | ||||||
| saism | 1436 | udp | Satellite-data Acquisition System 2 | Bill Taylor | Bill Taylor | ||||||
| tabula | 1437 | tcp | Tabula | Marcelo Einhorn | Marcelo Einhorn | ||||||
| tabula | 1437 | udp | Tabula | Marcelo Einhorn | Marcelo Einhorn | ||||||
| eicon-server | 1438 | tcp | Eicon Security Agent/Server | ||||||||
| eicon-server | 1438 | udp | Eicon Security Agent/Server | ||||||||
| eicon-x25 | 1439 | tcp | Eicon X25/SNA Gateway | ||||||||
| eicon-x25 | 1439 | udp | Eicon X25/SNA Gateway | ||||||||
| lv-jc | 2143 | tcp | Live Vault Job Control | ||||||||
| lv-jc | 2143 | udp | Live Vault Job Control | ||||||||
| seaview | 3143 | tcp | Sea View | Jim Flaherty | Jim Flaherty | ||||||
| seaview | 3143 | udp | Sea View | Jim Flaherty | Jim Flaherty | ||||||
| iscsi-target | 3260 | tcp | iSCSI port | IESG | IETF Chair | 2013-08-27 | RFC 7143 | ||||
| iscsi-target | 3260 | udp | iSCSI port | IESG | IETF Chair | 2013-08-27 | RFC 7143 | ||||
| oidsr | 4143 | tcp | Document Replication | Norman Brie | Norman Brie | ||||||
| oidsr | 4143 | udp | Document Replication | Norman Brie | Norman Brie | ||||||
| rfb | 5900 | tcp | Remote Framebuffer | Tristan Richardson | Tristan Richardson | 2006-03 | RFC 6143 | ||||
| rfb | 5900 | udp | Remote Framebuffer | Tristan Richardson | Tristan Richardson | 2006-03 | RFC 6143 | ||||
| watershed-lm | 6143 | tcp | Watershed License Manager | David Ferrero | David Ferrero | ||||||
| watershed-lm | 6143 | udp | Watershed License Manager | David Ferrero | David Ferrero | ||||||
| lsdp | 11430 | udp | Lenbrook Service Discovery Protocol | Lenbrook Industries Limited | Kevin Groeneveld | 2014-03-27 | |||||
| 11430 | tcp | Reserved | |||||||||
| 11431-11433 | Unassigned | ||||||||||
| ollama | 11434 | tcp | Ollama | Jesse Gross | Jesse Gross | 2025-09-26 | |||||
| 11434 | udp | Reserved | |||||||||
| 11435-11488 | Unassigned | Known UNAUTHORIZED USE: port 11488 | |||||||||
| icpps | 14143 | tcp | IceWall Cert Protocol over TLS | Kenta Kambara | Kenta Kambara | 2016-05-24 | |||||
| 14143 | udp | Reserved |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Bill Taylor | sais&ssec.wisc.edu | ||
| David Ferrero | david&zion.com | ||
| David Walling | sylvanhollow&yahoo.com | 2006-03 | |
| Geoff Meacock | gbibmswl&ibmmail.com | ||
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Ian Jackson | iwj&cam-orl.co.uk | ||
| Jesse Gross | jesse&ollama.com | 2026-02-02 | |
| Jim Flaherty | jim_e_flaherty¬es.seagate.com | ||
| Kenta Kambara | kenta.kambara&hpe.com | 2016-05-24 | |
| Kevin Groeneveld | Lenbrook Industries Limited | kgroeneveld&lenbrook.com | 2014-03-27 |
| Lenbrook Industries Limited | tsonderskov&lenbrook.com | 2014-03-27 | |
| Marcelo Einhorn | KGUNE%25HUJIVM1.bitnet@taunivm.tau.ac.il | ||
| Noor Chowdhury | noor&hypercom.com | ||
| Norman Brie | norm_brie&sns.ca | ||
| Peter Hussey | peterhusµsoft.com | ||
| Steve Beigel | ublueb!steve&uunet.uu.net | ||
| Tristan Richardson | iana&realvnc.com | 2006-03 |