Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| vmnet | 175 | tcp | VMNET | Christopher Tengi | Christopher Tengi | ||||||
| vmnet | 175 | udp | VMNET | Christopher Tengi | Christopher Tengi | ||||||
| dlep | 854 | tcp | Dynamic Link Exchange Protocol (DLEP) | IESG | IETF Chair | 2017-04-03 | RFC 8175 | ||||
| dlep | 854 | udp | Dynamic Link Exchange Protocol (DLEP) | IESG | IETF Chair | 2017-04-03 | RFC 8175 | ||||
| dossier | 1175 | tcp | Dossier Server | Rob Minerick | Rob Minerick | 2004-11 | |||||
| dossier | 1175 | udp | Dossier Server | Rob Minerick | Rob Minerick | 2004-11 | |||||
| sslp | 1750 | tcp | Simple Socket Library's PortMaster | Dr. Charles E. Campbell Jr. | Dr. Charles E. Campbell Jr. | ||||||
| sslp | 1750 | udp | Simple Socket Library's PortMaster | Dr. Charles E. Campbell Jr. | Dr. Charles E. Campbell Jr. | ||||||
| swiftnet | 1751 | tcp | SwiftNet | Terry Lim | Terry Lim | ||||||
| swiftnet | 1751 | udp | SwiftNet | Terry Lim | Terry Lim | ||||||
| lofr-lm | 1752 | tcp | Leap of Faith Research License Manager | ||||||||
| lofr-lm | 1752 | udp | Leap of Faith Research License Manager | ||||||||
| predatar-comms | 1753 | tcp | Predatar Comms Service | Silverstring Ltd. | Ronnie De Giorgio | 2011-09-15 | |||||
| 1753 | udp | Reserved | |||||||||
| oracle-em2 | 1754 | tcp | oracle-em2 | Bob Purvy | Bob Purvy | ||||||
| oracle-em2 | 1754 | udp | oracle-em2 | Bob Purvy | Bob Purvy | ||||||
| ms-streaming | 1755 | tcp | ms-streaming | Bret O'Rourke | Bret O'Rourke | ||||||
| ms-streaming | 1755 | udp | ms-streaming | Bret O'Rourke | Bret O'Rourke | ||||||
| capfast-lmd | 1756 | tcp | capfast-lmd | Chuck Neal | Chuck Neal | ||||||
| capfast-lmd | 1756 | udp | capfast-lmd | Chuck Neal | Chuck Neal | ||||||
| cnhrp | 1757 | tcp | cnhrp | William Stoye | William Stoye | ||||||
| cnhrp | 1757 | udp | cnhrp | William Stoye | William Stoye | ||||||
| tftp-mcast | 1758 | tcp | tftp-mcast | Tom Emberson | Tom Emberson | ||||||
| tftp-mcast | 1758 | udp | tftp-mcast | Tom Emberson | Tom Emberson | ||||||
| spss-lm | 1759 | tcp | SPSS License Manager | Tex Hull | Tex Hull | ||||||
| spss-lm | 1759 | udp | SPSS License Manager | Tex Hull | Tex Hull | ||||||
| airsync | 2175 | tcp | Microsoft Desktop AirSync Protocol | ||||||||
| airsync | 2175 | udp | Microsoft Desktop AirSync Protocol | ||||||||
| t1-e1-over-ip | 3175 | tcp | T1_E1_Over_IP | Mark Doyle | Mark Doyle | ||||||
| t1-e1-over-ip | 3175 | udp | T1_E1_Over_IP | Mark Doyle | Mark Doyle | ||||||
| bccp | 4175 | tcp | Brocade Cluster Communication Protocol | Norival Figueira | Norival Figueira | 2010-04-07 | |||||
| 4175 | udp | Reserved | |||||||||
| 7175-7180 | Unassigned | ||||||||||
| oemcacao-websvc | 11175 | tcp | OEM cacao web service access point | David Sechrest | David Sechrest | 2010-09-22 | |||||
| 11175 | udp | Reserved | |||||||||
| 11724-11750 | Unassigned | ||||||||||
| intrepid-ssl | 11751 | tcp | Intrepid SSL | Robert Eden | Robert Eden | 2003-03 | |||||
| intrepid-ssl | 11751 | udp | Intrepid SSL | Robert Eden | Robert Eden | 2003-03 | |||||
| 11752-11795 | Unassigned | ||||||||||
| db-lsp | 17500 | tcp | Dropbox LanSync Protocol | Paul Bohm | Paul Bohm | 2010-01-21 | |||||
| db-lsp-disc | 17500 | udp | Dropbox LanSync Discovery | Paul Bohm | Paul Bohm | 2010-01-21 | |||||
| 17501-17554 | Unassigned | ||||||||||
| ailith | 17555 | tcp | Ailith management of routers | Thomas Boje | Thomas Boje | 2014-03-27 | |||||
| 17555 | udp | Reserved | |||||||||
| 17556-17728 | Unassigned |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Bob Purvy | bpurvy&us.oracle.com | ||
| Bret O'Rourke | bretorµsoft.com | ||
| Christopher Tengi | tengi&princeton.edu | ||
| Chuck Neal | chuck&phase3.com | ||
| David Sechrest | david.sechrest&oracle.com | 2010-09-22 | |
| Dr. Charles E. Campbell Jr. | cec&gryphon.gsfc.nasa.gov | ||
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Mark Doyle | mark&engagecom.com | ||
| Norival Figueira | nfigueir&brocade.com | 2010-04-07 | |
| Paul Bohm | paul&dropbox.com | 2010-01-21 | |
| Rob Minerick | rob&vortimac.com | 2004-11 | |
| Robert Eden | reden&sieglertech.com | 2003-03 | |
| Ronnie De Giorgio | Silverstring Ltd. | rdegiorgio&silverstring.com | 2011-09-15 |
| Silverstring Ltd. | rdegiorgio&silverstring.com | 2011-09-15 | |
| Terry Lim | tkl&pentek.com | ||
| Tex Hull | tex&spss.com | ||
| Thomas Boje | thomas.boje&gmx.de | 2014-03-27 | |
| Tom Emberson | tom&lanworks.com | ||
| William Stoye | wstoye&atml.co.uk |