Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
genrad-mux 176 tcp GENRAD-MUX Ron Thornton Ron Thornton
genrad-mux 176 udp GENRAD-MUX Ron Thornton Ron Thornton
indigo-server 1176 tcp Indigo Home Server Matt Bendiksen Matt Bendiksen 2004-11
indigo-server 1176 udp Indigo Home Server Matt Bendiksen Matt Bendiksen 2004-11
www-ldap-gw 1760 tcp www-ldap-gw Nick Emery Nick Emery
www-ldap-gw 1760 udp www-ldap-gw Nick Emery Nick Emery
cft-0 1761 tcp cft-0 Martine Marchand Martine Marchand
cft-0 1761 udp cft-0 Martine Marchand Martine Marchand
cft-1 1762 tcp cft-1 Martine Marchand Martine Marchand
cft-1 1762 udp cft-1 Martine Marchand Martine Marchand
cft-2 1763 tcp cft-2 Martine Marchand Martine Marchand
cft-2 1763 udp cft-2 Martine Marchand Martine Marchand
cft-3 1764 tcp cft-3 Martine Marchand Martine Marchand
cft-3 1764 udp cft-3 Martine Marchand Martine Marchand
cft-4 1765 tcp cft-4 Martine Marchand Martine Marchand
cft-4 1765 udp cft-4 Martine Marchand Martine Marchand
cft-5 1766 tcp cft-5 Martine Marchand Martine Marchand
cft-5 1766 udp cft-5 Martine Marchand Martine Marchand
cft-6 1767 tcp cft-6 Martine Marchand Martine Marchand
cft-6 1767 udp cft-6 Martine Marchand Martine Marchand
cft-7 1768 tcp cft-7 Martine Marchand Martine Marchand
cft-7 1768 udp cft-7 Martine Marchand Martine Marchand
bmc-net-adm 1769 tcp bmc-net-adm Portnoy Boxman Portnoy Boxman
bmc-net-adm 1769 udp bmc-net-adm Portnoy Boxman Portnoy Boxman
rapi 2176 tcp Microsoft ActiveSync Remote API Jon Xu Jon Xu 2005-08
rapi 2176 udp Microsoft ActiveSync Remote API Jon Xu Jon Xu 2005-08
ars-master 3176 tcp ARS Master Portnoy Boxman Portnoy Boxman
ars-master 3176 udp ARS Master Portnoy Boxman Portnoy Boxman
tl-ipcproxy 4176 tcp Translattice Cluster IPC Proxy Michael Lyle Michael Lyle 2009-11-03
4176 udp Reserved
11176-11200 Unassigned
31686-31764 Unassigned
gamesmith-port 31765 tcp GameSmith Port Randy Thompson Randy Thompson 2002-08
gamesmith-port 31765 udp GameSmith Port Randy Thompson Randy Thompson 2002-08
31766-31947 Unassigned
core-rd tcp Resource Directory accessed using CoAP over TCP IESG IETF Chair 2021-03-16 RFC 9176 Defined TXT keys: None
core-rd udp Resource Directory accessed using CoAP IESG IETF Chair 2021-03-16 RFC 9176 Defined TXT keys: None
core-rd-tls tcp Resource Directory accessed using CoAP over TLS IESG IETF Chair 2021-03-16 2022-04-14 RFC 9176 Defined TXT keys: None
core-rd-dtls udp Resource Directory accessed using CoAP over DTLS IESG IETF Chair 2021-03-16 RFC 9176 Defined TXT keys: None

Contact Information

Name Organization Contact URI Last Updated
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jon Xu jonxu&microsoft.com 2005-08
Martine Marchand tel:+16-1-46-59-24-84
Matt Bendiksen matt&perceptiveautomation.com 2004-11
Michael Lyle protocols&translattice.com 2009-11-03
Nick Emery Nick.Emery&altavista.digital.com
Portnoy Boxman portnoy_boxman&bmc.com 2005-01
Randy Thompson thompr&earthlink.net 2002-08
Ron Thornton thornton&aerostation.org 2020-09-01