Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-22
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| unify | 181 | tcp | Unify | Daegis, Inc. | Chris Anderson | 2012-07-31 | |||||
| unify | 181 | udp | Unify | Daegis, Inc. | Chris Anderson | 2012-07-31 | |||||
| 3comnetman | 1181 | tcp | 3Com Net Management | Peter White | Peter White | 2004-11 | |||||
| 3comnetman | 1181 | udp | 3Com Net Management | Peter White | Peter White | 2004-11 | |||||
| jerand-lm | 1810 | tcp | Jerand License Manager | Robert Monat | Robert Monat | ||||||
| jerand-lm | 1810 | udp | Jerand License Manager | Robert Monat | Robert Monat | ||||||
| scientia-sdb | 1811 | tcp | Scientia-SDB | SYSTEMS MANAGER | SYSTEMS MANAGER | ||||||
| scientia-sdb | 1811 | udp | Scientia-SDB | SYSTEMS MANAGER | SYSTEMS MANAGER | ||||||
| radius | 1812 | tcp | RADIUS | RFC 2865 | |||||||
| radius | 1812 | udp | RADIUS | RFC 2865 | |||||||
| radius-acct | 1813 | tcp | RADIUS Accounting | RFC 2866 | |||||||
| radius-acct | 1813 | udp | RADIUS Accounting | RFC 2866 | |||||||
| tdp-suite | 1814 | tcp | TDP Suite | Rob Lockhart | Rob Lockhart | ||||||
| tdp-suite | 1814 | udp | TDP Suite | Rob Lockhart | Rob Lockhart | ||||||
| mmpft | 1815 | tcp | Manufacturing messaging protocol for factory transmission | Ralf Muckenhirn | Ralf Muckenhirn | 2024-06-12 | |||||
| mmpft | 1815 | udp | Manufacturing messaging protocol for factory transmission | Ralf Muckenhirn | Ralf Muckenhirn | 2024-06-12 | |||||
| harp | 1816 | tcp | HARP | Bjorn Chambless | Bjorn Chambless | ||||||
| harp | 1816 | udp | HARP | Bjorn Chambless | Bjorn Chambless | ||||||
| rkb-oscs | 1817 | tcp | RKB-OSCS | Robert Kevin Breton | Robert Kevin Breton | ||||||
| rkb-oscs | 1817 | udp | RKB-OSCS | Robert Kevin Breton | Robert Kevin Breton | ||||||
| etftp | 1818 | tcp | Enhanced Trivial File Transfer Protocol | William Polites | William Polites | ||||||
| etftp | 1818 | udp | Enhanced Trivial File Transfer Protocol | William Polites | William Polites | ||||||
| plato-lm | 1819 | tcp | Plato License Manager | Mark Morris | Mark Morris | ||||||
| plato-lm | 1819 | udp | Plato License Manager | Mark Morris | Mark Morris | ||||||
| eforward | 2181 | tcp | eforward | Greg Pringle | Greg Pringle | ||||||
| eforward | 2181 | udp | eforward | Greg Pringle | Greg Pringle | ||||||
| bmcpatrolagent | 3181 | tcp | BMC Patrol Agent | ||||||||
| bmcpatrolagent | 3181 | udp | BMC Patrol Agent | ||||||||
| macbak | 4181 | tcp | MacBak | Wes Peters | Wes Peters | 2007-04 | |||||
| macbak | 4181 | udp | MacBak | Wes Peters | Wes Peters | 2007-04 | |||||
| janus-disc | 7181 | udp | Janus Guidewire Enterprise Discovery Service Bus | Guidewire Software, Inc | Luca Debiasi | 2014-02-06 | |||||
| 7181 | tcp | Reserved | |||||||||
| intermapper | 8181 | tcp | Intermapper network management system | William Fisher | William Fisher | 2011-05-09 | |||||
| 8181 | udp | Reserved | |||||||||
| 18001-18103 | Unassigned | ||||||||||
| radpdf | 18104 | tcp | RAD PDF Service | Christopher Truxaw | Christopher Truxaw | 2010-10-15 | |||||
| 18104 | udp | Reserved | |||||||||
| 18105-18135 | Unassigned | ||||||||||
| racf | 18136 | tcp | z/OS Resource Access Control Facility | Bruce Wells | Bruce Wells | 2010-10-04 | |||||
| 18136 | udp | Reserved | |||||||||
| 18137-18180 | Unassigned | ||||||||||
| opsec-cvp | 18181 | tcp | OPSEC CVP | Alon Kantor | Alon Kantor | ||||||
| opsec-cvp | 18181 | udp | OPSEC CVP | Alon Kantor | Alon Kantor | ||||||
| opsec-ufp | 18182 | tcp | OPSEC UFP | Alon Kantor | Alon Kantor | ||||||
| opsec-ufp | 18182 | udp | OPSEC UFP | Alon Kantor | Alon Kantor | ||||||
| opsec-sam | 18183 | tcp | OPSEC SAM | Alon Kantor | Alon Kantor | ||||||
| opsec-sam | 18183 | udp | OPSEC SAM | Alon Kantor | Alon Kantor | ||||||
| opsec-lea | 18184 | tcp | OPSEC LEA | Alon Kantor | Alon Kantor | ||||||
| opsec-lea | 18184 | udp | OPSEC LEA | Alon Kantor | Alon Kantor | ||||||
| opsec-omi | 18185 | tcp | OPSEC OMI | Alon Kantor | Alon Kantor | ||||||
| opsec-omi | 18185 | udp | OPSEC OMI | Alon Kantor | Alon Kantor | ||||||
| ohsc | 18186 | tcp | Occupational Health SC | David Fudge | David Fudge | 2003-08 | |||||
| ohsc | 18186 | udp | Occupational Health Sc | David Fudge | David Fudge | 2003-08 | |||||
| opsec-ela | 18187 | tcp | OPSEC ELA | Alon Kantor | Alon Kantor | ||||||
| opsec-ela | 18187 | udp | OPSEC ELA | Alon Kantor | Alon Kantor | ||||||
| 18188-18240 | Unassigned |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Alon Kantor | alonk&checkpoint.com | ||
| Bjorn Chambless | bjorn&cs.pdx.edu | ||
| Bruce Wells | brwells&us.ibm.com | 2010-10-04 | |
| Chris Anderson | Daegis, Inc. | ianaportmaster&daegis.com | 2012-07-31 |
| Christopher Truxaw | ctruxaw&redsoftware.com | 2010-10-15 | |
| Daegis, Inc. | ianaportmaster&daegis.com | 2012-07-31 | |
| David Fudge | david.fudge&tssi.co.uk | 2003-08 | |
| Greg Pringle | gpringle&corvedia.com | 2019-01-25 | |
| Guidewire Software, Inc | info&guidewire.com | 2014-02-06 | |
| Luca Debiasi | Guidewire Software, Inc | ldebiasi&guidewire.com | 2014-02-06 |
| Mark Morris | mim&ermuk.com | ||
| Peter White | peter_white&3com.com | 2004-11 | |
| Ralf Muckenhirn | info&muckenhirn.net | 2024-06-11 | |
| Rob Lockhart | rob.lockhart&mot.com | ||
| Robert Kevin Breton | BOBBRETON&hotmail.com | ||
| Robert Monat | jerand&jerand.com | ||
| SYSTEMS MANAGER | systems-manager&scientia.com | ||
| Wes Peters | wes&softweyr.com | 2007-04 | |
| William Fisher | william.w.fisher&intermapper.com | 2011-05-09 | |
| William Polites | wpolites&mitre.org |