Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| direct | 242 | tcp | Direct | Herb Sutter | Paul Horton | ||||||
| direct | 242 | udp | Direct | Herb Sutter | Paul Horton | ||||||
| netconf-ssh | 830 | tcp | NETCONF over SSH | RFC 6242 | |||||||
| netconf-ssh | 830 | udp | NETCONF over SSH | RFC 6242 | |||||||
| nmasoverip | 1242 | tcp | NMAS over IP | Hal Henderson | Hal Henderson | ||||||
| nmasoverip | 1242 | udp | NMAS over IP | Hal Henderson | Hal Henderson | ||||||
| foliocorp | 2242 | tcp | Folio Remote Server | Pat Mcgowan | Pat Mcgowan | ||||||
| foliocorp | 2242 | udp | Folio Remote Server | Pat Mcgowan | Pat Mcgowan | ||||||
| dslremote-mgmt | 2420 | tcp | DSL Remote Management | Westell, Inc. | Westell, Inc. | ||||||
| dslremote-mgmt | 2420 | udp | DSL Remote Management | Westell, Inc. | Westell, Inc. | ||||||
| g-talk | 2421 | tcp | G-Talk | Matt Hammond | Matt Hammond | ||||||
| g-talk | 2421 | udp | G-Talk | Matt Hammond | Matt Hammond | ||||||
| crmsbits | 2422 | tcp | CRMSBITS | Rod Ward | Rod Ward | ||||||
| crmsbits | 2422 | udp | CRMSBITS | Rod Ward | Rod Ward | ||||||
| rnrp | 2423 | tcp | RNRP | Per Sahlqvist | Per Sahlqvist | ||||||
| rnrp | 2423 | udp | RNRP | Per Sahlqvist | Per Sahlqvist | ||||||
| kofax-svr | 2424 | tcp | KOFAX-SVR | Steven Kilby | Steven Kilby | 2011-04-25 | |||||
| kofax-svr | 2424 | udp | KOFAX-SVR | Steven Kilby | Steven Kilby | 2011-04-25 | |||||
| fjitsuappmgr | 2425 | tcp | Fujitsu App Manager | Hiroyuki Kawabuchi | Hiroyuki Kawabuchi | ||||||
| fjitsuappmgr | 2425 | udp | Fujitsu App Manager | Hiroyuki Kawabuchi | Hiroyuki Kawabuchi | ||||||
| vcmp | 2426 | tcp | VeloCloud MultiPath Protocol | VeloCloud Networks | Tim Van Herck | 2014-11-13 | This port was previously removed on 2002-04-29. | ||||
| vcmp | 2426 | udp | VeloCloud MultiPath Protocol | VeloCloud Networks | Tim Van Herck | 2014-11-13 | This port was previously removed on 2002-04-29. | ||||
| mgcp-gateway | 2427 | tcp | Media Gateway Control Protocol Gateway | Christian Huitema | Christian Huitema | ||||||
| mgcp-gateway | 2427 | udp | Media Gateway Control Protocol Gateway | Christian Huitema | Christian Huitema | ||||||
| ott | 2428 | tcp | One Way Trip Time | Greg Troxel | Greg Troxel | ||||||
| ott | 2428 | udp | One Way Trip Time | Greg Troxel | Greg Troxel | ||||||
| ft-role | 2429 | tcp | FT-ROLE | Doug Boone | Doug Boone | ||||||
| ft-role | 2429 | udp | FT-ROLE | Doug Boone | Doug Boone | ||||||
| sdp-id-port | 3242 | tcp | Session Description ID | Greg Rose | Greg Rose | 2002-02 | |||||
| sdp-id-port | 3242 | udp | Session Description ID | Greg Rose | Greg Rose | 2002-02 | |||||
| attune | 5242 | tcp | ATTUne API | Bellvedi Ltd. | Sean D. Sollé | 2022-06-01 | |||||
| 5242 | udp | Reserved | |||||||||
| jeol-nsdtp-2 | 6242 | tcp | JEOL Network Services Data Transport Protocol 2 | Kevin Wellwood | Kevin Wellwood | 2008-04-17 | |||||
| jeol-nsddp-2 | 6242 | udp | JEOL Network Services Dynamic Discovery Protocol 2 | Kevin Wellwood | Kevin Wellwood | 2008-04-17 | |||||
| 8233-8242 | Unassigned | ||||||||||
| iclid | 18242 | tcp | Checkpoint router monitoring | Check Point Software Technologies Ltd. | Rahul Bahadur | 2012-06-28 | |||||
| 18242 | udp | Reserved | |||||||||
| 24007-24241 | Unassigned | ||||||||||
| filesphere | 24242 | tcp | fileSphere | Carl Cedergren | Carl Cedergren | ||||||
| filesphere | 24242 | udp | fileSphere | Carl Cedergren | Carl Cedergren | ||||||
| 24243-24248 | Unassigned | ||||||||||
| vista-4gl | 24249 | tcp | Vista 4GL | Ingenta plc | Mark Itzcovitz | 2020-01-06 | |||||
| vista-4gl | 24249 | udp | Vista 4GL | Ingenta plc | Mark Itzcovitz | 2020-01-06 | |||||
| 24250-24320 | Unassigned |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Bellvedi Ltd. | iana&bellvedi.com | 2022-06-01 | |
| Carl Cedergren | asperon&home.se | ||
| Check Point Software Technologies Ltd. | rbahadur&checkpoint.com | 2012-06-28 | |
| Christian Huitema | huitema&research.telcordia.com | ||
| Doug Boone | dboone&atg.clr.com | ||
| Greg Rose | ggr&qualcomm.com | 2002-02 | |
| Greg Troxel | gdt&ir.bbn.com | ||
| Hal Henderson | hhenders&novell.com | ||
| Herb Sutter | HerbS&cntc.com | ||
| Hiroyuki Kawabuchi | buchi&ael.fujitsu.co.jp | ||
| Ingenta plc | mark.itzcovitz&ingenta.com | 2020-01-06 | |
| Kevin Wellwood | wellwood&jeol.com | 2008-04-17 | |
| Mark Itzcovitz | mark.itzcovitz&ingenta.com | 2020-01-06 | |
| Matt Hammond | matt_hammond&four-sight.co.uk | ||
| Pat Mcgowan | pmcgowan&folio.com | ||
| Paul Horton | paul.horton&dxstro.com | 2016-05-18 | |
| Per Sahlqvist | psahlqvi&sw.seisy.abb.se | ||
| Rahul Bahadur | Check Point Software Technologies Ltd. | rbahadur&checkpoint.com | 2012-06-28 |
| Rod Ward | RWard&vaccmel1.telstra.com.au | ||
| Sean D. Sollé | Bellvedi Ltd. | iana&bellvedi.com | 2022-06-01 |
| Steven Kilby | steven.kilby&kofax.com | 2011-04-25 | |
| Tim Van Herck | VeloCloud Networks | herckt&velocloud.net | 2014-11-13 |
| VeloCloud Networks | ops&velocloud.net | 2014-11-13 | |
| Westell, Inc. | jronk&westell.com |