Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-11-06

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
249-255 Reserved 2024-12-20 RFC 1060
de-cache-query 1255 tcp de-cache-query
de-cache-query 1255 udp de-cache-query
vrtp 2255 tcp VRTP - ViRtue Transfer Protocol Max Fudim Max Fudim
vrtp 2255 udp VRTP - ViRtue Transfer Protocol Max Fudim Max Fudim
ads 2550 tcp ADS Michael O'Connor Michael O'Connor
ads 2550 udp ADS Michael O'Connor Michael O'Connor
isg-uda-server 2551 tcp ISG UDA Server Dror Harari Dror Harari
isg-uda-server 2551 udp ISG UDA Server Dror Harari Dror Harari
call-logging 2552 tcp Call Logging Dean Webb Dean Webb
call-logging 2552 udp Call Logging Dean Webb Dean Webb
efidiningport 2553 tcp efidiningport Lynn Carter Lynn Carter
efidiningport 2553 udp efidiningport Lynn Carter Lynn Carter
vcnet-link-v10 2554 tcp VCnet-Link v10 Csaba Mate Csaba Mate
vcnet-link-v10 2554 udp VCnet-Link v10 Csaba Mate Csaba Mate
compaq-wcp 2555 tcp Compaq WCP Ferruccio Barletta Ferruccio Barletta
compaq-wcp 2555 udp Compaq WCP Ferruccio Barletta Ferruccio Barletta
nicetec-nmsvc 2556 tcp nicetec-nmsvc
nicetec-nmsvc 2556 udp nicetec-nmsvc
nicetec-mgmt 2557 tcp nicetec-mgmt Joerg Paulus Joerg Paulus
nicetec-mgmt 2557 udp nicetec-mgmt Joerg Paulus Joerg Paulus
pclemultimedia 2558 tcp PCLE Multi Media Jacob Gsoedl Jacob Gsoedl
pclemultimedia 2558 udp PCLE Multi Media Jacob Gsoedl Jacob Gsoedl
lstp 2559 tcp LSTP Waiki Wright Waiki Wright
lstp 2559 udp LSTP Waiki Wright Waiki Wright
semaphore 3255 tcp Semaphore Connection Port Jay Eckles Jay Eckles 2002-02
semaphore 3255 udp Semaphore Connection Port Jay Eckles Jay Eckles 2002-02
5255-5263 Unassigned
mon 9255 tcp Manager On Network David Rouchet David Rouchet 2007-05
mon 9255 udp Manager On Network David Rouchet David Rouchet 2007-05
22538-22554 Unassigned
vocaltec-wconf 22555 tcp Vocaltec Web Conference Scott Petrack Scott Petrack
vocaltec-phone 22555 udp Vocaltec Internet Phone Scott Petrack Scott Petrack
22556-22762 Unassigned
25472-25575 Unassigned
sauterdongle 25576 tcp Sauter Dongle Christian Brecht Christian Brecht 2010-12-15
25576 udp Reserved
25577-25603 Unassigned

Contact Information

Name Contact URI Last Updated
Christian Brecht Christian.Brecht&sauter-gmbh.de 2010-12-15
Csaba Mate mc36&freemail.c3.hu
David Rouchet david.rouchet&medialon.com 2007-05
Dean Webb dean.webb&ascend.com
Dror Harari Dror.Harari&isgsoft.com
Ferruccio Barletta ferruccio.barletta&compaq.com
Jacob Gsoedl jgsoedl&pinnaclesys.com
Jay Eckles ecklesweb&yahoo.com 2002-02
Joerg Paulus tech&nicetec.de
Lynn Carter carterl&execpc.com
Max Fudim fudim&virtue3d.com
Michael O'Connor moconnor&adobe.com
Scott Petrack Scott_Petrack&vocaltec.com
Waiki Wright waiki&us.ibm.com