Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
discard 9 sctp Discard Randall Stewart Randall Stewart 2022-02-07 RFC 9260
ftp-data 20 sctp FTP Randall Stewart Randall Stewart 2022-02-07 RFC 9260
ftp 21 sctp FTP Randall Stewart Randall Stewart 2022-02-07 RFC 9260 Defined TXT keys: u=<username> p=<password> path=<path>
ssh 22 sctp SSH Randall Stewart Randall Stewart 2022-02-07 RFC 9260 Defined TXT keys: u=<username> p=<password>
http 80 sctp HTTP Randall Stewart Randall Stewart 2022-02-07 RFC 9260 Defined TXT keys: u=<username> p=<password> path=<path to document>
bgp 179 sctp BGP Randall Stewart Randall Stewart 2022-02-07 RFC 9260
openport 260 tcp Openport John Marland John Marland
openport 260 udp Openport John Marland John Marland
https 443 sctp HTTPS Randall Stewart Randall Stewart 2022-02-07 RFC 9260
ibm-ssd 1260 tcp ibm-ssd Barry Whyte Barry Whyte
ibm-ssd 1260 udp ibm-ssd Barry Whyte Barry Whyte
apc-2260 2260 tcp APC 2260 American Power Conversion American Power Conversion 2002-02
apc-2260 2260 udp APC 2260 American Power Conversion American Power Conversion 2002-02
hpstgmgr 2600 tcp HPSTGMGR Kevin Collins Kevin Collins
hpstgmgr 2600 udp HPSTGMGR Kevin Collins Kevin Collins
discp-client 2601 tcp discp client
discp-client 2601 udp discp client
discp-server 2602 tcp discp server Peter White Peter White
discp-server 2602 udp discp server Peter White Peter White
servicemeter 2603 tcp Service Meter Duncan Hare Duncan Hare
servicemeter 2603 udp Service Meter Duncan Hare Duncan Hare
nsc-ccs 2604 tcp NSC CCS
nsc-ccs 2604 udp NSC CCS
nsc-posa 2605 tcp NSC POSA Tom Findley Tom Findley
nsc-posa 2605 udp NSC POSA Tom Findley Tom Findley
netmon 2606 tcp Dell Netmon
netmon 2606 udp Dell Netmon
connection 2607 tcp Dell Connection Sudhir Shetty Sudhir Shetty
connection 2607 udp Dell Connection Sudhir Shetty Sudhir Shetty
wag-service 2608 tcp Wag Service Gilles Bourquard Gilles Bourquard
wag-service 2608 udp Wag Service Gilles Bourquard Gilles Bourquard
system-monitor 2609 tcp System Monitor Greg Robson-Garth Greg Robson-Garth
system-monitor 2609 udp System Monitor Greg Robson-Garth Greg Robson-Garth
iscsi-target 3260 tcp iSCSI port IESG IETF Chair 2013-08-27 RFC 7143
iscsi-target 3260 udp iSCSI port IESG IETF Chair 2013-08-27 RFC 7143
axis-wimp-port 10260 tcp Axis WIMP Port Stefan Eriksson Stefan Eriksson
axis-wimp-port 10260 udp Axis WIMP Port Stefan Eriksson Stefan Eriksson
18260-18261 Unassigned
quake 26000 tcp quake Yasunari Gon Yamasita Yasunari Gon Yamasita
quake 26000 udp quake Yasunari Gon Yamasita Yasunari Gon Yamasita
26001-26132 Unassigned
ezproxy 26260 tcp eZproxy Albert C. Yang Albert C. Yang
ezproxy 26260 udp eZproxy Albert C. Yang Albert C. Yang
kingdomsonline 30260 tcp Kingdoms Online (CraigAvenue) Drake Bankston Drake Bankston 2009-08-18
kingdomsonline 30260 udp Kingdoms Online (CraigAvenue) Drake Bankston Drake Bankston 2009-08-18

Contact Information

Name Organization Contact URI Last Updated
Albert C. Yang albert.yang&ezmeeting.com 2002-03
American Power Conversion ports&apcc.com 2002-02
Barry Whyte barry_whyte&uk.ibm.com
Drake Bankston IANA.KingdomsOnline&gmail.com 2009-08-18
Duncan Hare Duncan.Hare&synoia.com
Gilles Bourquard gbo&wag.ch
Greg Robson-Garth gregr&alphalink.com.au
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
John Marland jmarland&dean.openport.com
Kevin Collins kevinc@.cnd.hp.com
Peter White peter_white&3com.com 2004-11
Randall Stewart IETF TSVWG rrs&lakerest.net
Stefan Eriksson contact-iana&axis.com
Sudhir Shetty Sudhir_Shetty&dell.com
Tom Findley tom.findley&networksciences.net
Yasunari Gon Yamasita yamasita&omronsoft.co.jp