Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-11-10

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
pt-tls 271 tcp IETF Network Endpoint Assessment (NEA) Posture Transport Protocol over TLS (PT-TLS) IESG IETF Chair 2012-07-31 RFC 6876
271 udp Reserved
excw 1271 tcp eXcW Norm Freedman Norm Freedman
excw 1271 udp eXcW Norm Freedman Norm Freedman
mmcals 2271 tcp Secure Meeting Maker Scheduling
mmcals 2271 udp Secure Meeting Maker Scheduling
sso-service 2710 tcp SSO Service
sso-service 2710 udp SSO Service
sso-control 2711 tcp SSO Control Axel Kern Axel Kern
sso-control 2711 udp SSO Control Axel Kern Axel Kern
aocp 2712 tcp Axapta Object Communication Protocol Jakob Steen Hansen Jakob Steen Hansen
aocp 2712 udp Axapta Object Communication Protocol Jakob Steen Hansen Jakob Steen Hansen
raventbs 2713 tcp Raven Trinity Broker Service
raventbs 2713 udp Raven Trinity Broker Service
raventdm 2714 tcp Raven Trinity Data Mover Daniel Sorlov Daniel Sorlov
raventdm 2714 udp Raven Trinity Data Mover Daniel Sorlov Daniel Sorlov
hpstgmgr2 2715 tcp HPSTGMGR2 Kevin Collins Kevin Collins
hpstgmgr2 2715 udp HPSTGMGR2 Kevin Collins Kevin Collins
inova-ip-disco 2716 tcp Inova IP Disco Chris Koeritz Chris Koeritz
inova-ip-disco 2716 udp Inova IP Disco Chris Koeritz Chris Koeritz
pn-requester 2717 tcp PN REQUESTER
pn-requester 2717 udp PN REQUESTER
pn-requester2 2718 tcp PN REQUESTER 2 Portnoy Boxman Portnoy Boxman
pn-requester2 2718 udp PN REQUESTER 2 Portnoy Boxman Portnoy Boxman
scan-change 2719 tcp Scan & Change Alexander Raji Alexander Raji
scan-change 2719 udp Scan & Change Alexander Raji Alexander Raji
csoft-prev 3271 tcp CSoft Prev Port Nedelcho Stanev Nedelcho Stanev
csoft-prev 3271 udp CSoft Prev Port Nedelcho Stanev Nedelcho Stanev
nut 3493 tcp Network UPS Tools Network UPS Tools Project Evgeny Klimov 2002-05 2022-05-18 RFC 9271
cuelink 5271 tcp StageSoft CueLink messaging Todd Pichler Todd Pichler 2010-03-26
cuelink-disc 5271 udp StageSoft CueLink discovery Todd Pichler Todd Pichler 2010-03-26
7263-7271 Unassigned
8271-8275 Unassigned
23054-23271 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Alexander Raji araji&lucent.com
Axel Kern axel.kern&betasystems.com
Chris Koeritz ckoeritz&inovacorp.com
Daniel Sorlov Daniel&sorlov.com
Evgeny Klimov jimklimov+nut&gmail.com 2020-12-16
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jakob Steen Hansen jsh&dk.damgaard.com
Kevin Collins kevinc&cnd.hp.com
Nedelcho Stanev decho&iname.com
Network UPS Tools Project iana&networkupstools.org 2020-12-16
Norm Freedman normfree&san.rr.com 2003-08
Portnoy Boxman portnoy_boxman&bmc.com 2005-01
Todd Pichler todd.pichler&stagesoft.com 2010-03-26