Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-11-06

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
301-307 Unassigned
1301 tcp Reserved 2019-10-30 De-Assigned on 2019-10-30
1301 udp Reserved 2019-10-30 De-Assigned on 2019-10-30
cpq-wbem 2301 tcp Compaq HTTP Scott Shaffer Scott Shaffer
cpq-wbem 2301 udp Compaq HTTP Scott Shaffer Scott Shaffer
gw 3010 tcp Telerate Workstation
ping-pong 3010 udp Telerate Workstation Timo Sivonen Timo Sivonen
trusted-web 3011 tcp Trusted Web
trusted-web 3011 udp Trusted Web
twsdss 3012 tcp Trusted Web Client Alex Duncan Alex Duncan
twsdss 3012 udp Trusted Web Client Alex Duncan Alex Duncan
gilatskysurfer 3013 tcp Gilat Sky Surfer Yossi Gal Yossi Gal
gilatskysurfer 3013 udp Gilat Sky Surfer Yossi Gal Yossi Gal
broker-service 3014 tcp Broker Service

IANA assigned this well-formed service name as a replacement for "broker_service".
Dale Bethers Dale Bethers
broker_service 3014 tcp Broker Service Dale Bethers Dale Bethers This entry is an alias to "broker-service". This entry is now historic, not usable for use with many common service discovery mechanisms.
broker-service 3014 udp Broker Service

IANA assigned this well-formed service name as a replacement for "broker_service".
Dale Bethers Dale Bethers
broker_service 3014 udp Broker Service Dale Bethers Dale Bethers This entry is an alias to "broker-service". This entry is now historic, not usable for use with many common service discovery mechanisms.
nati-dstp 3015 tcp NATI DSTP Paul Austin Paul Austin
nati-dstp 3015 udp NATI DSTP Paul Austin Paul Austin
notify-srvr 3016 tcp Notify Server

IANA assigned this well-formed service name as a replacement for "notify_srvr".
Hugo Parra Hugo Parra
notify_srvr 3016 tcp Notify Server Hugo Parra Hugo Parra This entry is an alias to "notify-srvr". This entry is now historic, not usable for use with many common service discovery mechanisms.
notify-srvr 3016 udp Notify Server

IANA assigned this well-formed service name as a replacement for "notify_srvr".
Hugo Parra Hugo Parra
notify_srvr 3016 udp Notify Server Hugo Parra Hugo Parra This entry is an alias to "notify-srvr". This entry is now historic, not usable for use with many common service discovery mechanisms.
event-listener 3017 tcp Event Listener

IANA assigned this well-formed service name as a replacement for "event_listener".
Ted Tronson Ted Tronson
event_listener 3017 tcp Event Listener Ted Tronson Ted Tronson This entry is an alias to "event-listener". This entry is now historic, not usable for use with many common service discovery mechanisms.
event-listener 3017 udp Event Listener

IANA assigned this well-formed service name as a replacement for "event_listener".
Ted Tronson Ted Tronson
event_listener 3017 udp Event Listener Ted Tronson Ted Tronson This entry is an alias to "event-listener". This entry is now historic, not usable for use with many common service discovery mechanisms.
srvc-registry 3018 tcp Service Registry

IANA assigned this well-formed service name as a replacement for "srvc_registry".
Mark Killgore Mark Killgore
srvc_registry 3018 tcp Service Registry Mark Killgore Mark Killgore This entry is an alias to "srvc-registry". This entry is now historic, not usable for use with many common service discovery mechanisms.
srvc-registry 3018 udp Service Registry

IANA assigned this well-formed service name as a replacement for "srvc_registry".
Mark Killgore Mark Killgore
srvc_registry 3018 udp Service Registry Mark Killgore Mark Killgore This entry is an alias to "srvc-registry". This entry is now historic, not usable for use with many common service discovery mechanisms.
resource-mgr 3019 tcp Resource Manager

IANA assigned this well-formed service name as a replacement for "resource_mgr".
Gary Glover Gary Glover
resource_mgr 3019 tcp Resource Manager Gary Glover Gary Glover This entry is an alias to "resource-mgr". This entry is now historic, not usable for use with many common service discovery mechanisms.
resource-mgr 3019 udp Resource Manager

IANA assigned this well-formed service name as a replacement for "resource_mgr".
Gary Glover Gary Glover
resource_mgr 3019 udp Resource Manager Gary Glover Gary Glover This entry is an alias to "resource-mgr". This entry is now historic, not usable for use with many common service discovery mechanisms.
tarantool 3301 tcp Tarantool in-memory computing platform Tarantool Alexander Turenko 2022-06-10 Known Unauthorized Use on port 3301
tarantool 3301 udp Tarantool in-memory computing platform Tarantool Alexander Turenko 2022-06-10 Known Unauthorized Use on port 3301
d-data 4301 tcp Diagnostic Data
d-data 4301 udp Diagnostic Data
lisp-control 4342 udp LISP Control Packets IETF IESG 2007-05 2021-02-25 RFC 9301
hacl-gs 5301 tcp HA cluster general services Eric Soderberg; Edward Yim Eric Soderberg; Edward Yim
hacl-gs 5301 udp HA cluster general services Eric Soderberg; Edward Yim Eric Soderberg; Edward Yim
coaps 5684 tcp Constrained Application Protocol (CoAP) IESG IETF Chair 2017-12-22 RFC 7301; RFC 8323
bmc-ctd-ldap 6301 tcp BMC CONTROL-D LDAP SERVER

IANA assigned this well-formed service name as a replacement for "bmc_ctd_ldap".
Portnoy Boxman Portnoy Boxman 2006-09
bmc_ctd_ldap 6301 tcp BMC CONTROL-D LDAP SERVER Portnoy Boxman Portnoy Boxman 2006-09 This entry is an alias to "bmc-ctd-ldap". This entry is now historic, not usable for use with many common service discovery mechanisms.
bmc-ctd-ldap 6301 udp BMC CONTROL-D LDAP SERVER

IANA assigned this well-formed service name as a replacement for "bmc_ctd_ldap".
Portnoy Boxman Portnoy Boxman 2006-09
bmc_ctd_ldap 6301 udp BMC CONTROL-D LDAP SERVER Portnoy Boxman Portnoy Boxman 2006-09 This entry is an alias to "bmc-ctd-ldap". This entry is now historic, not usable for use with many common service discovery mechanisms.
amberon 8301 tcp Amberon PPC/PPS Ronald Snyder Ronald Snyder 2006-03
amberon 8301 udp Amberon PPC/PPS Ronald Snyder Ronald Snyder 2006-03
9301-9305 Unassigned
12301 Unassigned
rwp 30100 tcp Remote Window Protocol Maxim Baklanovsky Maxim Baklanovsky 2015-05-20
30100 udp Reserved
rwp 30100 sctp Remote Window Protocol Maxim Baklanovsky Maxim Baklanovsky 2015-05-20
30101-30259 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Alex Duncan alex.duncan&sse.ie
Alexander Turenko Tarantool alexander.turenko&tarantool.org 2022-06-10
Dale Bethers dbethers&novell.com
Edward Yim eyim&hpmfas4.cup.hp.com
Eric Soderberg seric&hposl102.cup.hp
Gary Glover gglover&novell.com
Hugo Parra hparra&novell.com
IESG iesg&ietf.org
IETF iesg&ietf.org
IETF Chair IETF chair&ietf.org
Mark Killgore MKillgore&novell.com
Maxim Baklanovsky m.baklanovsky&spbu.ru 2015-05-20
Paul Austin paul.austin&natinst.com
Portnoy Boxman Portnoy_Boxman&bmc.com 2006-09
Ronald Snyder pugaroni&sssnet.com 2006-03
Scott Shaffer scott.shaffer&hp.com
Tarantool admin&tarantool.org 2022-06-10
Ted Tronson ttronson&novell.com
Timo Sivonen timo.sivonen&ccmail.dowjones.com
Yossi Gal yossi&gilat.com