Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-27

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
rpki-rtr-tls 324 tcp Resource PKI to Router Protocol over TLS IESG IETF Chair RFC 6810
324 udp Reserved
delta-mcp 1324 tcp delta-mcp Quinton Tormanen Quinton Tormanen
delta-mcp 1324 udp delta-mcp Quinton Tormanen Quinton Tormanen
cosmocall 2324 tcp Cosmocall Steve Dellutri Steve Dellutri
cosmocall 2324 udp Cosmocall Steve Dellutri Steve Dellutri
triomotion 3240 tcp Trio Motion Control Port Tony Matthews Tony Matthews 2002-02
triomotion 3240 udp Trio Motion Control Port Tony Matthews Tony Matthews 2002-02
sysorb 3241 tcp SysOrb Monitoring Server Jakob Oestergaard Jakob Oestergaard 2002-02
sysorb 3241 udp SysOrb Monitoring Server Jakob Oestergaard Jakob Oestergaard 2002-02
sdp-id-port 3242 tcp Session Description ID Greg Rose Greg Rose 2002-02
sdp-id-port 3242 udp Session Description ID Greg Rose Greg Rose 2002-02
timelot 3243 tcp Timelot Port David Ferguson David Ferguson 2002-02
timelot 3243 udp Timelot Port David Ferguson David Ferguson 2002-02
onesaf 3244 tcp OneSAF Gene McCulley Gene McCulley 2002-02
onesaf 3244 udp OneSAF Gene McCulley Gene McCulley 2002-02
vieo-fe 3245 tcp VIEO Fabric Executive James Cox James Cox 2002-02
vieo-fe 3245 udp VIEO Fabric Executive James Cox James Cox 2002-02
dvt-system 3246 tcp DVT SYSTEM PORT
dvt-system 3246 udp DVT SYSTEM PORT
dvt-data 3247 tcp DVT DATA LINK Phillip Heil Phillip Heil 2002-02
dvt-data 3247 udp DVT DATA LINK Phillip Heil Phillip Heil 2002-02
procos-lm 3248 tcp PROCOS LM Torsten Rendelmann Torsten Rendelmann
procos-lm 3248 udp PROCOS LM Torsten Rendelmann Torsten Rendelmann
ssp 3249 tcp State Sync Protocol Stephane Beaulieu Stephane Beaulieu 2002-02
ssp 3249 udp State Sync Protocol Stephane Beaulieu Stephane Beaulieu 2002-02
4324 Reserved 2015-05-12 This entry is being removed on 2015-05-12.
hrd-ncs 6324 tcp HR Device Network Configuration Service Hall Research Vishal Dharmadhikari 2011-11-29
hrd-ns-disc 6324 udp HR Device Network service Hall Research Vishal Dharmadhikari 2011-11-29
24324-24385 Unassigned
plex 32400 tcp Plex multimedia Plex Inc. Sasha Hilton 2016-06-02
32400 udp Reserved
32401-32482 Unassigned
apm-link 32483 tcp Access Point Manager Link Tony Diodato Tony Diodato 2005-08
apm-link 32483 udp Access Point Manager Link Tony Diodato Tony Diodato 2005-08
32484-32634 Unassigned
44324-44443 Unassigned

Contact Information

Name Organization Contact URI Last Updated
David Ferguson dferguson&xtralot.com 2002-02
Gene McCulley mcculley&cuspy.com 2002-02
Greg Rose ggr&qualcomm.com 2002-02
Hall Research vishal&hallresearch.com 2011-11-29
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jakob Oestergaard joe&sysorb.com 2002-02
James Cox jocox&view.com 2002-02
Phillip Heil phil.heil&dvtsensors.com 2002-02
Plex Inc. sashahilton00&gmail.com 2016-06-02
Quinton Tormanen quinton&deltacompsys.com
Sasha Hilton sashahilton00&gmail.com 2016-06-02
Stephane Beaulieu stephane&cisco.com 2002-02
Steve Dellutri
Tony Diodato tdiodato&cyprx.com 2005-08
Tony Matthews tmatthews&triomotion.com 2002-02
Torsten Rendelmann torsten.rendelmann&procos.com
Vishal Dharmadhikari Hall Research vishal&hallresearch.com 2011-11-29