Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
discard 9 dccp Discard Eddie Kohler Eddie Kohler RFC 4340 1145656131
34 tcp Unassigned
34 udp Unassigned
ingres-net 134 tcp INGRES-NET Service Mike Berrow Mike Berrow
ingres-net 134 udp INGRES-NET Service Mike Berrow Mike Berrow
334-343 Unassigned
pdap 344 tcp Prospero Data Access Protocol B. Clifford Neuman B. Clifford Neuman
pdap 344 udp Prospero Data Access Protocol B. Clifford Neuman B. Clifford Neuman
pawserv 345 tcp Perf Analysis Workbench
pawserv 345 udp Perf Analysis Workbench
zserv 346 tcp Zebra server
zserv 346 udp Zebra server
fatserv 347 tcp Fatmen Server
fatserv 347 udp Fatmen Server
csi-sgwp 348 tcp Cabletron Management Protocol
csi-sgwp 348 udp Cabletron Management Protocol
mftp 349 tcp mftp Dave Feinleib Dave Feinleib
mftp 349 udp mftp Dave Feinleib Dave Feinleib
mobileip-agent 434 tcp MobileIP-Agent
mobileip-agent 434 udp MobileIP-Agent
windream 534 tcp windream Admin Uwe Honermann Uwe Honermann
windream 534 udp windream Admin Uwe Honermann Uwe Honermann
ginad 634 tcp ginad Mark Crother Mark Crother
ginad 634 udp ginad Mark Crother Mark Crother
epp 700 tcp Extensible Provisioning Protocol RFC 5734
epp 700 udp EPP running over QUIC IESG IETF Chair 2026-07-23 RFC 5734; RFC-ietf-regext-epp-quic-12
834-846 Unassigned
apex-edge 913 tcp APEX endpoint-relay service RFC 3340
apex-edge 913 udp APEX endpoint-relay service RFC 3340
activesync 1034 tcp ActiveSync Notifications Sandra Vargas Sandra Vargas 2003-03
activesync 1034 udp ActiveSync Notifications Sandra Vargas Sandra Vargas 2003-03
aplx 1134 tcp MicroAPL APLX Richard Nabavi Richard Nabavi 2006-02
aplx 1134 udp MicroAPL APLX Richard Nabavi Richard Nabavi 2006-02
search-agent 1234 tcp Infoseek Search Agent Jackie Wu Jackie Wu
search-agent 1234 udp Infoseek Search Agent Jackie Wu Jackie Wu
writesrv 1334 tcp writesrv Marvin Toungate Marvin Toungate
writesrv 1334 udp writesrv Marvin Toungate Marvin Toungate
naap 1340 tcp NAAP Henry Haverinen Henry Haverinen
naap 1340 udp NAAP Henry Haverinen Henry Haverinen
qubes 1341 tcp QuBES Eric Grange Eric Grange
qubes 1341 udp QuBES Eric Grange Eric Grange
esbroker 1342 tcp ESBroker Alexander Medvinsky Alexander Medvinsky
esbroker 1342 udp ESBroker Alexander Medvinsky Alexander Medvinsky
re101 1343 tcp re101 Doriano Blengino Doriano Blengino
re101 1343 udp re101 Doriano Blengino Doriano Blengino
icap 1344 tcp ICAP Jeremy Elson Jeremy Elson
icap 1344 udp ICAP Jeremy Elson Jeremy Elson
vpjp 1345 tcp VPJP Michael Collins Michael Collins
vpjp 1345 udp VPJP Michael Collins Michael Collins
alta-ana-lm 1346 tcp Alta Analytics License Manager
alta-ana-lm 1346 udp Alta Analytics License Manager
bbn-mmc 1347 tcp multi media conferencing
bbn-mmc 1347 udp multi media conferencing
bbn-mmx 1348 tcp multi media conferencing
bbn-mmx 1348 udp multi media conferencing
sbook 1349 tcp Registration Network Protocol
sbook 1349 udp Registration Network Protocol
ms-sql-m 1434 tcp Microsoft-SQL-Monitor Peter Hussey Peter Hussey
ms-sql-m 1434 udp Microsoft-SQL-Monitor Peter Hussey Peter Hussey
micromuse-lm 1534 tcp micromuse-lm Adam Kerrison Adam Kerrison
micromuse-lm 1534 udp micromuse-lm Adam Kerrison Adam Kerrison
loaprobe 1634 tcp Log On America Probe James Tavares James Tavares
loaprobe 1634 udp Log On America Probe James Tavares James Tavares
cambertx-lm 1734 tcp Camber Corporation License Management Jeannie Burleson Jeannie Burleson
cambertx-lm 1734 udp Camber Corporation License Management Jeannie Burleson Jeannie Burleson
ardusuni 1834 tcp ARDUS Unicast
ardusuni 1834 udp ARDUS Unicast
xaapi 1934 tcp IBM LM Appl Agent Helga Wolin Helga Wolin
xaapi 1934 udp IBM LM Appl Agent Helga Wolin Helga Wolin
scoremgr 2034 tcp
scoremgr 2034 udp
avenue 2134 tcp AVENUE Jason Cater Jason Cater
avenue 2134 udp AVENUE Jason Cater Jason Cater
directplay 2234 tcp DirectPlay Ajay Jindal Ajay Jindal
directplay 2234 udp DirectPlay Ajay Jindal Ajay Jindal
ace-client 2334 tcp ACE Client Auth
ace-client 2334 udp ACE Client Auth
wrs-registry 2340 tcp WRS Registry

IANA assigned this well-formed service name as a replacement for "wrs_registry".
Christophe Cleraux Christophe Cleraux
wrs_registry 2340 tcp WRS Registry Christophe Cleraux Christophe Cleraux This entry is an alias to "wrs-registry". This entry is now historic, not usable for use with many common service discovery mechanisms.
wrs-registry 2340 udp WRS Registry

IANA assigned this well-formed service name as a replacement for "wrs_registry".
Christophe Cleraux Christophe Cleraux
wrs_registry 2340 udp WRS Registry Christophe Cleraux Christophe Cleraux This entry is an alias to "wrs-registry". This entry is now historic, not usable for use with many common service discovery mechanisms.
xiostatus 2341 tcp XIO Status Randy Maas Randy Maas
xiostatus 2341 udp XIO Status Randy Maas Randy Maas
manage-exec 2342 tcp Seagate Manage Exec Jim Flaherty Jim Flaherty
manage-exec 2342 udp Seagate Manage Exec Jim Flaherty Jim Flaherty
nati-logos 2343 tcp nati logos James Juhasz James Juhasz
nati-logos 2343 udp nati logos James Juhasz James Juhasz
fcmsys 2344 tcp fcmsys
fcmsys 2344 udp fcmsys
dbm 2345 tcp dbm Dean Robson Dean Robson
dbm 2345 udp dbm Dean Robson Dean Robson
redstorm-join 2346 tcp Game Connection Port

IANA assigned this well-formed service name as a replacement for "redstorm_join".
redstorm_join 2346 tcp Game Connection Port This entry is an alias to "redstorm-join". This entry is now historic, not usable for use with many common service discovery mechanisms.
redstorm-join 2346 udp Game Connection Port

IANA assigned this well-formed service name as a replacement for "redstorm_join".
redstorm_join 2346 udp Game Connection Port This entry is an alias to "redstorm-join". This entry is now historic, not usable for use with many common service discovery mechanisms.
redstorm-find 2347 tcp Game Announcement and Location

IANA assigned this well-formed service name as a replacement for "redstorm_find".
redstorm_find 2347 tcp Game Announcement and Location This entry is an alias to "redstorm-find". This entry is now historic, not usable for use with many common service discovery mechanisms.
redstorm-find 2347 udp Game Announcement and Location

IANA assigned this well-formed service name as a replacement for "redstorm_find".
redstorm_find 2347 udp Game Announcement and Location This entry is an alias to "redstorm-find". This entry is now historic, not usable for use with many common service discovery mechanisms.
redstorm-info 2348 tcp Information to query for game status

IANA assigned this well-formed service name as a replacement for "redstorm_info".

Contact Information

Name Organization Contact URI Last Updated
Adam Kerrison adam&micromuse.co.uk
Ajay Jindal ajayj&microsoft.com
Alexander Medvinsky smedvinsky&gi.com
B. Clifford Neuman bcn&isi.edu 2022-02-18
Christophe Cleraux chrisc&wrs.com
Dave Feinleib davefe&microsoft.com
Dean Robson dean.robson&fujitsu.com.au
Doriano Blengino tecnico_remove_&_remove_xonelectronics.it
Eddie Kohler IETF dccp WG kohler&cs.ucla.edu
Eric Grange egrange&creative-it.net 2002-08
Helga Wolin hwolin&us.ibm.com
Henry Haverinen henry.haverinen&nokia.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jackie Wu jackiew&infoseek.com
James Juhasz james.juhasz&ni.com
James Tavares Log On America krontor&loa.com
Jason Cater jason&ncsmags.com
Jeannie Burleson jeannie&cambertx.com
Jeremy Elson jelson&isi.edu
Jim Flaherty jim.flaherty&seagatesoftware.com
Mark Crother mark&eis.calstate.edu
Marvin Toungate toungate&austin.ibm.com
Michael Collins UBMCollins&aol.com
Mike Berrow
Peter Hussey peterhus&microsoft.com
Randy Maas randym&xiotech.com
Richard Nabavi nabavi&microapl.co.uk 2006-02
Sandra Vargas Sandrama&microsoft.com 2003-03
Uwe Honermann u.honermann&windream.com