Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
mftp 349 tcp mftp Dave Feinleib Dave Feinleib
mftp 349 udp mftp Dave Feinleib Dave Feinleib
sbook 1349 tcp Registration Network Protocol
sbook 1349 udp Registration Network Protocol
redstorm-diag 2349 tcp Diagnostics Port

IANA assigned this well-formed service name as a replacement for "redstorm_diag".
David Weinstein David Weinstein
redstorm_diag 2349 tcp Diagnostics Port David Weinstein David Weinstein This entry is an alias to "redstorm-diag". This entry is now historic, not usable for use with many common service discovery mechanisms.
redstorm-diag 2349 udp Diagnostics Port

IANA assigned this well-formed service name as a replacement for "redstorm_diag".
David Weinstein David Weinstein
redstorm_diag 2349 udp Diagnostics Port David Weinstein David Weinstein This entry is an alias to "redstorm-diag". This entry is now historic, not usable for use with many common service discovery mechanisms.
chevinservices 3349 tcp Chevin Services Gus McNaughton Gus McNaughton
chevinservices 3349 udp Chevin Services Gus McNaughton Gus McNaughton
colubris 3490 tcp Colubris Management Port Gilbert Moineau Gilbert Moineau 2002-05
colubris 3490 udp Colubris Management Port Gilbert Moineau Gilbert Moineau 2002-05
swr-port 3491 tcp SWR Port Ian Manning Ian Manning 2002-05
swr-port 3491 udp SWR Port Ian Manning Ian Manning 2002-05
tvdumtray-port 3492 tcp TVDUM Tray Port Peter Boers Peter Boers 2002-05
tvdumtray-port 3492 udp TVDUM Tray Port Peter Boers Peter Boers 2002-05
nut 3493 tcp Network UPS Tools Network UPS Tools Project Evgeny Klimov 2002-05 2022-05-18 RFC 9271
nut 3493 udp Network UPS Tools Network UPS Tools Project Evgeny Klimov 2002-05 2020-12-16
ibm3494 3494 tcp IBM 3494 Jeffrey Pilch Jeffrey Pilch
ibm3494 3494 udp IBM 3494 Jeffrey Pilch Jeffrey Pilch
seclayer-tcp 3495 tcp securitylayer over tcp
seclayer-tcp 3495 udp securitylayer over tcp
seclayer-tls 3496 tcp securitylayer over tls Arno Hollosi Arno Hollosi 2002-03
seclayer-tls 3496 udp securitylayer over tls Arno Hollosi Arno Hollosi 2002-03
ipether232port 3497 tcp ipEther232Port Marcus Leufgen Marcus Leufgen 2002-05
ipether232port 3497 udp ipEther232Port Marcus Leufgen Marcus Leufgen 2002-05
dashpas-port 3498 tcp DASHPAS user port Albrecht Mayer Albrecht Mayer 2002-05
dashpas-port 3498 udp DASHPAS user port Albrecht Mayer Albrecht Mayer 2002-05
sccip-media 3499 tcp SccIP Media David Yon David Yon 2002-05
sccip-media 3499 udp SccIP Media David Yon David Yon 2002-05
fsportmap 4349 tcp File System Port Map Ron Minnich Ron Minnich
fsportmap 4349 udp File System Port Map Ron Minnich Ron Minnich
stuns 5349 tcp Session Traversal Utilities for NAT (STUN) port IESG IETF Chair 2019-03-28 RFC 8489
stuns 5349 udp STUN over DTLS IESG IETF Chair 2014-07-03 RFC 7350 This service name was initially created by RFC 5389.
turns 5349 tcp TURN over TLS 2019-08-02 RFC 8656
turns 5349 udp TURN over DTLS IESG IETF Chair 2019-08-02 RFC 7350 This service name was initially created by RFC 8656.
stun-behaviors 5349 tcp STUN Behavior Discovery over TLS RFC 5780
stun-behaviors 5349 udp Reserved for a future enhancement of STUN-BEHAVIOR RFC 5780
6348-6349 Unassigned
22348-22349 Unassigned
34568-34961 Unassigned
profinet-rt 34962 tcp PROFInet RT Unicast PNO – PROFIBUS Nutzerorganisation e.V. Dietmar Bohn 2004-11 2026-03-16
profinet-rt 34962 udp PROFInet RT Unicast PNO – PROFIBUS Nutzerorganisation e.V. Dietmar Bohn 2004-11 2026-03-16
profinet-rtm 34963 tcp PROFInet RT Multicast PNO – PROFIBUS Nutzerorganisation e.V. Dietmar Bohn 2004-11 2026-03-16
profinet-rtm 34963 udp PROFInet RT Multicast PNO – PROFIBUS Nutzerorganisation e.V. Dietmar Bohn 2004-11 2026-03-16
profinet-cm 34964 tcp PROFInet Context Manager PNO – PROFIBUS Nutzerorganisation e.V. Dietmar Bohn 2004-11 2026-03-16
profinet-cm 34964 udp PROFInet Context Manager PNO – PROFIBUS Nutzerorganisation e.V. Dietmar Bohn 2004-11 2026-03-16
profinet-cm-sec 34965 tcp PROFINET secure connection management and key provisioning PNO – PROFIBUS Nutzerorganisation e.V. Dietmar Bohn 2026-03-10
profinet-cm-sec 34965 udp PROFINET secure connection management and key provisioning PNO – PROFIBUS Nutzerorganisation e.V. Dietmar Bohn 2026-03-10
34966 tcp Reserved
profinet-rt-sec 34966 udp PROFINET secure real-time data transfer over UDP (unicast and multicast) PNO – PROFIBUS Nutzerorganisation e.V. Dietmar Bohn 2026-03-10
34967-34979 Unassigned
ethercat 34980 tcp EtherCAT Port Martin Rostan Martin Rostan 2003-11
ethercat 34980 udp EtherCAT Port Martin Rostan Martin Rostan 2003-11
34981-34999 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Albrecht Mayer albrecht.mayer&infineon.com 2002-05
Arno Hollosi arno.hollosi&cio.gv.at 2002-03
Dave Feinleib davefe&microsoft.com
David Weinstein david.weinstein&redstorm.com
David Yon dyon&dialout.net 2002-05
Dietmar Bohn standards.central-office&profibus.com 2026-03-10
Evgeny Klimov jimklimov+nut&gmail.com 2020-12-16
Gilbert Moineau gilbert.moineau&colubris.com 2002-05
Gus McNaughton gus&chevin.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Ian Manning imanning&dtsuk.com 2002-05
Jeffrey Pilch jpilch&us.ibm.com
Marcus Leufgen leufgen&ipcas.de 2002-05
Martin Rostan m.rostan&beckhoff.com 2003-11
Network UPS Tools Project iana&networkupstools.org 2020-12-16
Peter Boers boers&isisglobal.nl 2002-05
PNO – PROFIBUS Nutzerorganisation e.V. standards.central-office&profibus.com 2026-03-10
Ron Minnich rminnich&sarnoff.com