Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
imap 143 tcp Internet Message Access Protocol IESG IETF Chair 2021-02-22 RFC 3501; RFC 9051
matip-type-a 350 tcp MATIP Type A Alain Robert Alain Robert RFC 2351
matip-type-a 350 udp MATIP Type A Alain Robert Alain Robert RFC 2351
imaps 993 tcp IMAP over TLS protocol IESG IETF Chair 2021-02-22 RFC 3501; RFC 8314; RFC 9051
editbench 1350 tcp Registration Network Protocol Simson L. Garfinkel Simson L. Garfinkel
editbench 1350 udp Registration Network Protocol Simson L. Garfinkel Simson L. Garfinkel
psbserver 2350 tcp Pharos Booking Server
psbserver 2350 udp Pharos Booking Server
findviatv 3350 tcp FINDVIATV Oran Davis Oran Davis
findviatv 3350 udp FINDVIATV Oran Davis Oran Davis
rtmp-port 3500 tcp RTMP Port Miriam Wohlgelernter Miriam Wohlgelernter
rtmp-port 3500 udp RTMP Port Miriam Wohlgelernter Miriam Wohlgelernter
isoft-p2p 3501 tcp iSoft-P2P David Walling David Walling
isoft-p2p 3501 udp iSoft-P2P David Walling David Walling
avinstalldisc 3502 tcp Avocent Install Discovery Brian S. Stewart Brian S. Stewart
avinstalldisc 3502 udp Avocent Install Discovery Brian S. Stewart Brian S. Stewart
lsp-ping 3503 tcp MPLS LSP-echo Port RFC 8029
lsp-ping 3503 udp MPLS LSP-echo Port RFC 8029
ironstorm 3504 tcp IronStorm game server Arnaud Clermonte Arnaud Clermonte
ironstorm 3504 udp IronStorm game server Arnaud Clermonte Arnaud Clermonte
ccmcomm 3505 tcp CCM communications port Tom Bougan Tom Bougan
ccmcomm 3505 udp CCM communications port Tom Bougan Tom Bougan
apc-3506 3506 tcp APC 3506 American Power Conversion American Power Conversion
apc-3506 3506 udp APC 3506 American Power Conversion American Power Conversion
nesh-broker 3507 tcp Nesh Broker Port Jeremy Maiden Jeremy Maiden
nesh-broker 3507 udp Nesh Broker Port Jeremy Maiden Jeremy Maiden
interactionweb 3508 tcp Interaction Web Mike Gagle Mike Gagle
interactionweb 3508 udp Interaction Web Mike Gagle Mike Gagle
vt-ssl 3509 tcp Virtual Token SSL Port Libor Sykora Libor Sykora 2002-05
vt-ssl 3509 udp Virtual Token SSL Port Libor Sykora Libor Sykora 2002-05
net-device 4350 tcp Net Device Glenn Peterson Glenn Peterson
net-device 4350 udp Net Device Glenn Peterson Glenn Peterson
stuns 5349 udp STUN over DTLS IESG IETF Chair 2014-07-03 RFC 7350 This service name was initially created by RFC 5389.
turns 5349 udp TURN over DTLS IESG IETF Chair 2019-08-02 RFC 7350 This service name was initially created by RFC 8656.
5350 tcp Reserved
pcp-multicast 5350 udp Port Control Protocol Multicast IESG IETF Chair RFC 6887
adap 6350 tcp App Discovery and Access Protocol Thomas Kjoernes Thomas Kjoernes 2010-06-22
adap 6350 udp App Discovery and Access Protocol Thomas Kjoernes Thomas Kjoernes 2010-06-22
8323-8350 Unassigned
codemeter 22350 tcp CodeMeter Standard Wolfgang Voelker Wolfgang Voelker 2007-06
codemeter 22350 udp CodeMeter Standard Wolfgang Voelker Wolfgang Voelker 2007-06
heathview 35000 tcp HeathView Heathwest Systems Limited Andrew Porrer 2013-03-21
35000 udp Reserved
rt-viewer 35001 tcp ReadyTech Viewer ReadyTech Corporation Kevin Woodward 2013-09-13
rt-viewer 35001 udp ReadyTech Viewer ReadyTech Corporation Kevin Woodward 2013-09-13
rt-sound 35002 tcp ReadyTech Sound Server ReadyTech Corporation Kevin Woodward 2013-09-13
35002 udp Reserved
rt-devicemapper 35003 tcp ReadyTech DeviceMapper Server ReadyTech Corporation Kevin Woodward 2013-09-13
35003 udp Reserved
rt-classmanager 35004 tcp ReadyTech ClassManager ReadyTech Corporation Kevin Woodward 2013-09-13
rt-classmanager 35004 udp ReadyTech ClassManager ReadyTech Corporation Kevin Woodward 2013-09-13
rt-labtracker 35005 tcp ReadyTech LabTracker ReadyTech Corporation Kevin Woodward 2013-09-13
35005 udp Reserved
rt-helper 35006 tcp ReadyTech Helper Service ReadyTech Corporation Kevin Woodward 2013-09-13
35006 udp Reserved
35007-35099 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Alain Robert arobert&par.sita.int
American Power Conversion ports&apcc.com 2002-02
Andrew Porrer Heathwest Systems Limited Andrew.Porrer&heathwest.com 2013-03-21
Arnaud Clermonte clermonte&4xtechnologies.com
Brian S. Stewart Brian.Stewart&avovent.com
David Walling dwalling&isoft.com
Glenn Peterson glennp&microsoft.com
Heathwest Systems Limited info&heathwest.com 2013-03-21
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jeremy Maiden jeremy&3507.uk 2020-05-01
Kevin Woodward ReadyTech Corporation kwoodward&readytech.com 2013-09-13
Libor Sykora libor.sykora&st.com 2002-05
Mike Gagle mikeg&inin.com 2006-05
Miriam Wohlgelernter miriamw&adirtech.com
Oran Davis oran&8x8.com
ReadyTech Corporation kwoodward&readytech.com 2013-09-13
Simson L. Garfinkel simsong&next.cambridge.ma.us
Thomas Kjoernes thomas&ipv.no 2010-06-22
Tom Bougan tomb&apptechsys.com
Wolfgang Voelker wolfgang.voelker&wibu.com 2007-06