Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
ndsauth 353 tcp NDSAUTH Jayakumar Ramalingam Jayakumar Ramalingam
ndsauth 353 udp NDSAUTH Jayakumar Ramalingam Jayakumar Ramalingam
relief 1353 tcp Relief Consulting John Feiler John Feiler
relief 1353 udp Relief Consulting John Feiler John Feiler
pspserver 2353 tcp pspserver
pspserver 2353 udp pspserver
fatpipe 3353 tcp FATPIPE Sanchaita Datta Sanchaita Datta
fatpipe 3353 udp FATPIPE Sanchaita Datta Sanchaita Datta
gf 3530 tcp Grid Friendly Daivd P. Chassin Daivd P. Chassin 2002-06
gf 3530 udp Grid Friendly Daivd P. Chassin Daivd P. Chassin 2002-06
joltid 3531 tcp Joltid Ahti Heinla Ahti Heinla 2002-06
joltid 3531 udp Joltid Ahti Heinla Ahti Heinla 2002-06
raven-rmp 3532 tcp Raven Remote Management Control
raven-rmp 3532 udp Raven Remote Management Control
raven-rdp 3533 tcp Raven Remote Management Data Daniel Sorlov Daniel Sorlov 2002-06
raven-rdp 3533 udp Raven Remote Management Data Daniel Sorlov Daniel Sorlov 2002-06
urld-port 3534 tcp URL Daemon Port Jim Binkley Jim Binkley 2002-06
urld-port 3534 udp URL Daemon Port Jim Binkley Jim Binkley 2002-06
ms-la 3535 tcp MS-LA Eric Ledoux Eric Ledoux
ms-la 3535 udp MS-LA Eric Ledoux Eric Ledoux
snac 3536 tcp SNAC Tatsuya Igarashi Tatsuya Igarashi 2002-07
snac 3536 udp SNAC Tatsuya Igarashi Tatsuya Igarashi 2002-07
ni-visa-remote 3537 tcp Remote NI-VISA port Sinnadurai Dharshan Sinnadurai Dharshan 2002-07
ni-visa-remote 3537 udp Remote NI-VISA port Sinnadurai Dharshan Sinnadurai Dharshan 2002-07
ibm-diradm 3538 tcp IBM Directory Server
ibm-diradm 3538 udp IBM Directory Server
ibm-diradm-ssl 3539 tcp IBM Directory Server SSL Mark Cavage Mark Cavage 2002-07
ibm-diradm-ssl 3539 udp IBM Directory Server SSL Mark Cavage Mark Cavage 2002-07
f5-iquery 4353 tcp F5 iQuery Tom Kee Tom Kee
f5-iquery 4353 udp F5 iQuery Tom Kee Tom Kee
mdns 5353 tcp Multicast DNS IESG IETF Chair RFC 6762
mdns 5353 udp Multicast DNS IESG IETF Chair RFC 6762
enrp-sctp 9901 sctp enrp server channel RFC 5353
enrp-sctp-tls 9902 sctp enrp/tls server channel RFC 5353
snmptls 10161 tcp SNMP-TLS RFC 6353
snmpdtls 10161 udp SNMP-DTLS RFC 6353
snmptls-trap 10162 tcp SNMP-Trap-TLS RFC 6353
snmpdtls-trap 10162 udp SNMP-Trap-DTLS RFC 6353
33436-33655 Unassigned Known Unauthorized Use on ports 33436-33534
35101-35353 Unassigned
kitim 35354 tcp KIT Messenger Rudi Visser Rudi Visser 2011-07-07
35354 udp Reserved
altova-lm 35355 tcp Altova License Management Alexander Falk Alexander Falk 2011-07-07
altova-lm-disc 35355 udp Altova License Management Discovery Alexander Falk Alexander Falk 2011-07-07
guttersnex 35356 tcp Gutters Note Exchange Squee! Application Development Tristan Seifert 2011-07-19
35356 udp Reserved
openstack-id 35357 tcp OpenStack ID Service Rackspace Hosting Ziad Sawalha 2011-08-15
35357 udp Reserved
35358-36000 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Ahti Heinla ahti&ahti.bluemoon.ee 2002-06
Alexander Falk Altova, Inc. al&altova.com 2011-07-07
Daivd P. Chassin david.chassin&pnl.gov 2002-06
Daniel Sorlov daniel&sorlov.com 2002-06
Eric Ledoux ericle&microsoft.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jayakumar Ramalingam jayakumar&novell.com
Jim Binkley jrb&cs.pdx.edu 2002-06
John Feiler relief!jjfeiler&uu2.psi.com
Mark Cavage mcavage&us.ibm.com 2002-07
Rackspace Hosting ziad.sawalha&rackspace.com 2011-08-15
Rudi Visser rudi.visser&ljund.eu 2011-07-07
Sanchaita Datta sdatta&ragula.com
Sinnadurai Dharshan sinnadurai.dharshan&ni.com 2002-07
Squee! Application Development tristan&squee.co 2011-07-19
Tatsuya Igarashi Tatsuya.Igarashi&jp.sony.com 2002-07
Tom Kee t.kee&f5.com
Tristan Seifert Squee! Application Development tristan&squee.co 2011-07-19
Ziad Sawalha Rackspace Hosting ziad.sawalha&rackspace.com 2011-08-15