Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
hp-managed-node 382 tcp hp performance data managed node
hp-managed-node 382 udp hp performance data managed node
udt-os 1382 tcp udt_os

IANA assigned this well-formed service name as a replacement for "udt_os".
udt_os 1382 tcp udt_os This entry is an alias to "udt-os". This entry is now historic, not usable for use with many common service discovery mechanisms.
udt-os 1382 udp udt_os

IANA assigned this well-formed service name as a replacement for "udt_os".
udt_os 1382 udp udt_os This entry is an alias to "udt-os". This entry is now historic, not usable for use with many common service discovery mechanisms.
ms-olap3 2382 tcp Microsoft OLAP
ms-olap3 2382 udp Microsoft OLAP
fcip-port 3225 tcp FCIP RFC 3821
fcip-port 3225 udp FCIP RFC 3821
fujitsu-neat 3382 tcp Fujitsu Network Enhanced Antitheft function Markku Viima Markku Viima
fujitsu-neat 3382 udp Fujitsu Network Enhanced Antitheft function Markku Viima Markku Viima
scp 3820 tcp Siemens AuD SCP Johann Arnold Johann Arnold 2004-10
scp 3820 udp Siemens AuD SCP Johann Arnold Johann Arnold 2004-10
pmcp 3821 tcp ATSC PMCP Standard Graham Jones Graham Jones 2004-11
pmcp 3821 udp ATSC PMCP Standard Graham Jones Graham Jones 2004-11
acp-discovery 3822 tcp Compute Pool Discovery
acp-discovery 3822 udp Compute Pool Discovery
acp-conduit 3823 tcp Compute Pool Conduit
acp-conduit 3823 udp Compute Pool Conduit
acp-policy 3824 tcp Compute Pool Policy Andy Belk Andy Belk 2005-02
acp-policy 3824 udp Compute Pool Policy Andy Belk Andy Belk 2005-02
ffserver 3825 tcp Antera FlowFusion Process Simulation Armin Liebchen Armin Liebchen 2007-06
ffserver 3825 udp Antera FlowFusion Process Simulation Armin Liebchen Armin Liebchen 2007-06
warmux 3826 tcp WarMUX game server Christophe Gisquet Christophe Gisquet 2011-05-26
warmux 3826 udp WarMUX game server Christophe Gisquet Christophe Gisquet 2011-05-26
netmpi 3827 tcp Netadmin Systems MPI service Göran Runfeldt Göran Runfeldt 2007-07-10
netmpi 3827 udp Netadmin Systems MPI service Göran Runfeldt Göran Runfeldt 2007-07-10
neteh 3828 tcp Netadmin Systems Event Handler
neteh 3828 udp Netadmin Systems Event Handler
neteh-ext 3829 tcp Netadmin Systems Event Handler External Jonas Krogell Jonas Krogell 2007-07-10
neteh-ext 3829 udp Netadmin Systems Event Handler External Jonas Krogell Jonas Krogell 2007-07-10
metatude-mds 6382 tcp Metatude Dialogue Server Menno Zweistra Menno Zweistra
metatude-mds 6382 udp Metatude Dialogue Server Menno Zweistra Menno Zweistra
8381-8382 Unassigned
dsmcc-passthru 13820 tcp DSMCC Pass-Thru Messages Tim Addington Tim Addington ISO/IEC 13818-6 MPEG-2 DSM-CC
dsmcc-passthru 13820 udp DSMCC Pass-Thru Messages Tim Addington Tim Addington ISO/IEC 13818-6 MPEG-2 DSM-CC
dsmcc-download 13821 tcp DSMCC Download Protocol Tim Addington Tim Addington ISO/IEC 13818-6 MPEG-2 DSM-CC
dsmcc-download 13821 udp DSMCC Download Protocol Tim Addington Tim Addington ISO/IEC 13818-6 MPEG-2 DSM-CC
dsmcc-ccp 13822 tcp DSMCC Channel Change Protocol Tim Addington Tim Addington ISO/IEC 13818-6 MPEG-2 DSM-CC
dsmcc-ccp 13822 udp DSMCC Channel Change Protocol Tim Addington Tim Addington ISO/IEC 13818-6 MPEG-2 DSM-CC
bmdss 13823 tcp Blackmagic Design Streaming Server Sam Vaughan Sam Vaughan 2011-03-01
13823 udp Reserved
13824-13831 Unassigned
38003-38200 Unassigned
galaxy7-data 38201 tcp Galaxy7 Data Tunnel Tatham Oddie Tatham Oddie 2002-09
galaxy7-data 38201 udp Galaxy7 Data Tunnel Tatham Oddie Tatham Oddie 2002-09
fairview 38202 tcp Fairview Message Service Jim Lyle Jim Lyle 2005-11 Defined TXT keys: DevID=<device id>, DevType=<device type>, DevStat=<device status>
fairview 38202 udp Fairview Message Service Jim Lyle Jim Lyle 2005-11 Defined TXT keys: DevID=<device id>, DevType=<device type>, DevStat=<device status>
agpolicy 38203 tcp AppGate Policy Server Martin Forssen Martin Forssen 2004-11
agpolicy 38203 udp AppGate Policy Server Martin Forssen Martin Forssen 2004-11
38204-38411 Unassigned

Contact Information

Name Contact URI Last Updated
Andy Belk register1&azulsystems.com 2005-02
Armin Liebchen armin&anteradesign.com 2007-06
Christophe Gisquet christophe.gisquet&gmail.com 2011-05-26
Göran Runfeldt goran&netadmin.se 2007-07-10
Graham Jones gjones&nab.org 2004-11
Jim Lyle jim.lyle&siliconimage.com 2005-11
Johann Arnold johann.arnold&siemens.com 2004-10
Jonas Krogell jonas.krogell&netadmin.se 2007-07-10
Markku Viima markku.viima&team.icl.se
Martin Forssen maf&appgate.com 2004-11
Menno Zweistra m.zweistra&metatude.com
Sam Vaughan samv&blackmagic-design.com 2011-03-01
Tatham Oddie tatham&e-oddie.com 2002-09
Tim Addington Tim.Addington&sciatl.com