Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-22
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| unidata-ldm | 388 | tcp | Unidata LDM | The University Corporation for Atmospheric Research | Steven Emmerson | 2012-05-18 | |||||
| unidata-ldm | 388 | udp | Unidata LDM | The University Corporation for Atmospheric Research | Steven Emmerson | 2012-05-18 | |||||
| mtqp | 1038 | tcp | Message Tracking Query Protocol | RFC 3887 | |||||||
| mtqp | 1038 | udp | Message Tracking Query Protocol | RFC 3887 | |||||||
| objective-dbc | 1388 | tcp | Objective Solutions DataBase Cache | Donald Cornwell | Donald Cornwell | ||||||
| objective-dbc | 1388 | udp | Objective Solutions DataBase Cache | Donald Cornwell | Donald Cornwell | ||||||
| mynahautostart | 2388 | tcp | MYNAH AutoStart | Thomas J. Klehr | Thomas J. Klehr | ||||||
| mynahautostart | 2388 | udp | MYNAH AutoStart | Thomas J. Klehr | Thomas J. Klehr | ||||||
| cbserver | 3388 | tcp | CB Server | Allen Wei | Allen Wei | ||||||
| cbserver | 3388 | udp | CB Server | Allen Wei | Allen Wei | ||||||
| igrs | 3880 | tcp | IGRS | Huang Jingnan | Huang Jingnan | 2003-10 | |||||
| igrs | 3880 | udp | IGRS | Huang Jingnan | Huang Jingnan | 2003-10 | |||||
| idac | 3881 | tcp | Data Acquisition and Control | Chatziandreoglou Christos | Chatziandreoglou Christos | 2003-10 | |||||
| idac | 3881 | udp | Data Acquisition and Control | Chatziandreoglou Christos | Chatziandreoglou Christos | 2003-10 | |||||
| msdts1 | 3882 | tcp | DTS Service Port | Sergei Ivanov | Sergei Ivanov | 2003-10 | |||||
| msdts1 | 3882 | udp | DTS Service Port | Sergei Ivanov | Sergei Ivanov | 2003-10 | |||||
| vrpn | 3883 | tcp | VR Peripheral Network | Sensics | Yuval Boger | 2003-10 | 2015-05-04 | ||||
| vrpn | 3883 | udp | VR Peripheral Network | Sensics | Yuval Boger | 2003-10 | 2015-05-04 | ||||
| softrack-meter | 3884 | tcp | SofTrack Metering | John T. McCann | John T. McCann | 2003-10 | |||||
| softrack-meter | 3884 | udp | SofTrack Metering | John T. McCann | John T. McCann | 2003-10 | |||||
| topflow-ssl | 3885 | tcp | TopFlow SSL | Ken Nelson | Ken Nelson | ||||||
| topflow-ssl | 3885 | udp | TopFlow SSL | Ken Nelson | Ken Nelson | ||||||
| nei-management | 3886 | tcp | NEI management port | Kevin Murphy | Kevin Murphy | 2003-10 | |||||
| nei-management | 3886 | udp | NEI management port | Kevin Murphy | Kevin Murphy | 2003-10 | |||||
| ciphire-data | 3887 | tcp | Ciphire Data Transport | Lars Eilebrecht | Lars Eilebrecht | 2003-10 | |||||
| ciphire-data | 3887 | udp | Ciphire Data Transport | Lars Eilebrecht | Lars Eilebrecht | 2003-10 | |||||
| ciphire-serv | 3888 | tcp | Ciphire Services | Lars Eilebrecht | Lars Eilebrecht | 2003-10 | |||||
| ciphire-serv | 3888 | udp | Ciphire Services | Lars Eilebrecht | Lars Eilebrecht | 2003-10 | |||||
| dandv-tester | 3889 | tcp | D and V Tester Control Port | Voiko Loukanov | Voiko Loukanov | 2003-10 | |||||
| dandv-tester | 3889 | udp | D and V Tester Control Port | Voiko Loukanov | Voiko Loukanov | 2003-10 | |||||
| 4380-4388 | Unassigned | ||||||||||
| 6383-6388 | Unassigned | ||||||||||
| d2ddatatrans | 9388 | tcp | D2D Data Transfer Service | Pete Camble | Pete Camble | 2008-12-24 | |||||
| 9388 | udp | Reserved | |||||||||
| 33657-33889 | Unassigned | ||||||||||
| sruth | 38800 | tcp | Sruth is a service for the distribution of routinely- generated but arbitrary files based on a publish/subscribe distribution model and implemented using a peer-to-peer transport mechanism | The University Corporation for Atmospheric Research | Steven Emmerson | 2012-05-07 | |||||
| 38800 | udp | Reserved | |||||||||
| 38801-38864 | Unassigned | ||||||||||
| secrmmsafecopya | 38865 | tcp | Security approval process for use of the secRMM SafeCopy program | Squadra Technologies | Anthony LaMark | 2012-03-14 | |||||
| 38865 | udp | Reserved | |||||||||
| 38866-39062 | Unassigned |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Allen Wei | Allen_Wei&arborsoft.com | ||
| Anthony LaMark | Squadra Technologies | anthony&squadratechnologies.com | 2012-03-14 |
| Chatziandreoglou Christos | chatzi&xan.forthnet.gr | 2003-10 | |
| Donald Cornwell | |||
| Huang Jingnan | huangjnb&lenovo.com | 2003-10 | |
| John T. McCann | jmccann&softwaremetering.com | 2003-10 | |
| Ken Nelson | nelson&toplayer.com | ||
| Kevin Murphy | kevin.murphy&networkengines.com | 2003-10 | |
| Lars Eilebrecht | le+iana&leogic.com | 2003-10 | |
| Pete Camble | pete.camble&hpe.com | 2023-04-05 | |
| Sensics | vrpn&sensics.com | 2015-05-04 | |
| Sergei Ivanov | sergeiµsoft.com | 2003-10 | |
| Squadra Technologies | anthony&squadratechnologies.com | 2012-03-14 | |
| Steven Emmerson | The University Corporation for Atmospheric Research | emmerson&ucar.edu | 2012-05-07 |
| Steven Emmerson | The University Corporation for Atmospheric Research | support-ldm&unidata.ucar.edu | 2012-05-18 |
| Thomas J. Klehr | tklehr&telcordia.com | ||
| The University Corporation for Atmospheric Research | support&unidata.ucar.edu | 2012-05-07 | |
| The University Corporation for Atmospheric Research | support-ldm&unidata.ucar.edu | 2012-05-18 | |
| Voiko Loukanov | v.loukanov&dvelectronics.com | 2003-10 | |
| Yuval Boger | Sensics | vrpn&sensics.com | 2015-05-04 |