Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| rlp | 39 | tcp | Resource Location Protocol | Mike Accetta | Mike Accetta | ||||||
| rlp | 39 | udp | Resource Location Protocol | Mike Accetta | Mike Accetta | ||||||
| nntp | 119 | tcp | Network News Transfer Protocol | IESG | IETF Chair | 2018-07-06 | RFC 3977 | ||||
| nntp | 119 | udp | Network News Transfer Protocol | IESG | IETF Chair | 2018-07-06 | RFC 3977 | ||||
| netbios-ssn | 139 | tcp | NETBIOS Session Service | Jon Postel | Jon Postel | ||||||
| netbios-ssn | 139 | udp | NETBIOS Session Service | Jon Postel | Jon Postel | ||||||
| z39-50 | 210 | tcp | ANSI Z39.50 IANA assigned this well-formed service name as a replacement for "z39.50". |
Mark H. Needleman | Mark H. Needleman | ||||||
| z39.50 | 210 | tcp | ANSI Z39.50 | Mark H. Needleman | Mark H. Needleman | This entry is an alias to "z39-50". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| z39-50 | 210 | udp | ANSI Z39.50 IANA assigned this well-formed service name as a replacement for "z39.50". |
Mark H. Needleman | Mark H. Needleman | ||||||
| z39.50 | 210 | udp | ANSI Z39.50 | Mark H. Needleman | Mark H. Needleman | This entry is an alias to "z39-50". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| uis | 390 | tcp | UIS | Ed Barron | Ed Barron | ||||||
| uis | 390 | udp | UIS | Ed Barron | Ed Barron | ||||||
| synotics-relay | 391 | tcp | SynOptics SNMP Relay Port | ||||||||
| synotics-relay | 391 | udp | SynOptics SNMP Relay Port | ||||||||
| synotics-broker | 392 | tcp | SynOptics Port Broker Port | Illan Raab | Illan Raab | ||||||
| synotics-broker | 392 | udp | SynOptics Port Broker Port | Illan Raab | Illan Raab | ||||||
| meta5 | 393 | tcp | Meta5 | Jim Kanzler | Jim Kanzler | ||||||
| meta5 | 393 | udp | Meta5 | Jim Kanzler | Jim Kanzler | ||||||
| embl-ndt | 394 | tcp | EMBL Nucleic Data Transfer | Peter Gad | Peter Gad | ||||||
| embl-ndt | 394 | udp | EMBL Nucleic Data Transfer | Peter Gad | Peter Gad | ||||||
| netcp | 395 | tcp | NetScout Control Protocol | Ashwani Singhal | Ashwani Singhal | 2010-04-07 | |||||
| netcp | 395 | udp | NetScout Control Protocol | Ashwani Singhal | Ashwani Singhal | 2010-04-07 | |||||
| netware-ip | 396 | tcp | Novell Netware over IP | ||||||||
| netware-ip | 396 | udp | Novell Netware over IP | ||||||||
| mptn | 397 | tcp | Multi Protocol Trans. Net. | Soumitra Sarkar | Soumitra Sarkar | ||||||
| mptn | 397 | udp | Multi Protocol Trans. Net. | Soumitra Sarkar | Soumitra Sarkar | ||||||
| kryptolan | 398 | tcp | Kryptolan | Peter de Laval | Peter de Laval | ||||||
| kryptolan | 398 | udp | Kryptolan | Peter de Laval | Peter de Laval | ||||||
| iso-tsap-c2 | 399 | tcp | ISO Transport Class 2 Non-Control over TCP | Yanick Pouffary | Yanick Pouffary | ||||||
| iso-tsap-c2 | 399 | udp | ISO Transport Class 2 Non-Control over UDP | Yanick Pouffary | Yanick Pouffary | ||||||
| nnsp | 433 | tcp | NNTP for transit servers (NNSP) | IESG | IETF Chair | 2018-07-06 | RFC 3977 | ||||
| nnsp | 433 | udp | NNTP for transit servers (NNSP) | IESG | IETF Chair | 2018-07-06 | RFC 3977 | ||||
| dasp | 439 | tcp | dasp | Thomas Obermair | Thomas Obermair | ||||||
| dasp | 439 | udp | dasp | Thomas Obermair | Thomas Obermair | ||||||
| apertus-ldp | 539 | tcp | Apertus Technologies Load Determination | ||||||||
| apertus-ldp | 539 | udp | Apertus Technologies Load Determination | ||||||||
| msdp | 639 | tcp | MSDP | Dino Farinacci | Dino Farinacci | ||||||
| msdp | 639 | udp | MSDP | Dino Farinacci | Dino Farinacci | ||||||
| iris-beep | 702 | tcp | IRIS over BEEP | RFC 3983 | |||||||
| iris-beep | 702 | udp | IRIS over BEEP | RFC 3983 | |||||||
| sbl | 1039 | tcp | Streamlined Blackhole | Jonathan A. Zdziaraski | Jonathan A. Zdziaraski | 2004-11 | |||||
| sbl | 1039 | udp | Streamlined Blackhole | Jonathan A. Zdziaraski | Jonathan A. Zdziaraski | 2004-11 | |||||
| evm | 1139 | tcp | Enterprise Virtual Manager | Thomas Hennessy | Thomas Hennessy | 2007-10-04 | |||||
| evm | 1139 | udp | Enterprise Virtual Manager | Thomas Hennessy | Thomas Hennessy | 2007-10-04 | |||||
| tsdos390 | 1237 | tcp | tsdos390 | Ben Pracht | Ben Pracht | ||||||
| tsdos390 | 1237 | udp | tsdos390 | Ben Pracht | Ben Pracht | ||||||
| nmsd | 1239 | tcp | NMSD | Yuri Machkasov | Yuri Machkasov | ||||||
| nmsd | 1239 | udp | NMSD | Yuri Machkasov | Yuri Machkasov | ||||||
| kjtsiteserver | 1339 | tcp | kjtsiteserver | Jason Aubain | Jason Aubain | ||||||
| kjtsiteserver | 1339 | udp | kjtsiteserver | Jason Aubain | Jason Aubain | ||||||
| iclpv-sc | 1390 | tcp | Storage Controller | ||||||||
| iclpv-sc | 1390 | udp | Storage Controller | ||||||||
| iclpv-sas | 1391 | tcp | Storage Access Server | ||||||||
| iclpv-sas | 1391 | udp | Storage Access Server | ||||||||
| iclpv-pm | 1392 | tcp | Print Manager | ||||||||
| iclpv-pm | 1392 | udp | Print Manager | ||||||||
| iclpv-nls | 1393 | tcp | Network Log Server | ||||||||
| iclpv-nls | 1393 | udp | Network Log Server | ||||||||
| iclpv-nlc | 1394 | tcp | Network Log Client | ||||||||
| iclpv-nlc | 1394 | udp | Network Log Client | ||||||||
| iclpv-wsm | 1395 | tcp | PC Workstation Manager software | A.P. Hobson | A.P. Hobson | ||||||
| iclpv-wsm | 1395 | udp | PC Workstation Manager software | A.P. Hobson | A.P. Hobson | ||||||
| dvl-activemail | 1396 | tcp | DVL Active Mail | ||||||||
| dvl-activemail | 1396 | udp | DVL Active Mail | ||||||||
| audio-activmail | 1397 | tcp | Audio Active Mail | ||||||||
| audio-activmail | 1397 | udp | Audio Active Mail | ||||||||
| video-activmail | 1398 | tcp | Video Active Mail | Avshalom Houri | Avshalom Houri | ||||||
| video-activmail | 1398 | udp | Video Active Mail | Avshalom Houri | Avshalom Houri | ||||||
| cadkey-licman | 1399 | tcp | Cadkey License Manager | ||||||||
| cadkey-licman | 1399 | udp | Cadkey License Manager | ||||||||
| eicon-x25 | 1439 | tcp | Eicon X25/SNA Gateway | ||||||||
| eicon-x25 | 1439 | udp | Eicon X25/SNA Gateway | ||||||||
| intellistor-lm | 1539 | tcp | Intellistor License Manager | Ron Vaughn | Ron Vaughn | ||||||
| intellistor-lm | 1539 | udp | Intellistor License Manager | Ron Vaughn | Ron Vaughn | ||||||
| cert-initiator | 1639 | tcp | cert-initiator | ||||||||
| cert-initiator | 1639 | udp | cert-initiator | ||||||||
| webaccess | 1739 | tcp | webaccess | Christian Saether | Christian Saether | ||||||
| webaccess | 1739 | udp | webaccess | Christian Saether | Christian Saether | ||||||
| netopia-vo1 | 1839 | tcp | netopia-vo1 | ||||||||
| netopia-vo1 | 1839 | udp | netopia-vo1 | ||||||||
| jvserver | 1939 | tcp | JetVision Server Port | ||||||||
| jvserver | 1939 | udp | JetVision Server Port | ||||||||
| prizma | 2039 | tcp | Prizma Monitoring Service | Dotan Ofek | Dotan Ofek | 2005-12 | |||||
| prizma | 2039 | udp | Prizma Monitoring Service | Dotan Ofek | Dotan Ofek | 2005-12 | |||||
| ias-auth | 2139 | tcp | IAS-AUTH | ||||||||
| ias-auth | 2139 | udp | IAS-AUTH | ||||||||
| imagequery | 2239 | tcp | Image Query | Charles Jacobs | Charles Jacobs | ||||||
| imagequery | 2239 | udp | Image Query | Charles Jacobs | Charles Jacobs | ||||||
| 3com-webview | 2339 | tcp | 3Com WebView | Jennifer Grace | Jennifer Grace | ||||||
| 3com-webview | 2339 | udp | 3Com WebView | Jennifer Grace | Jennifer Grace | ||||||
| rsmtp | 2390 | tcp | RSMTP | Geoff Collyer | Geoff Collyer | ||||||
| rsmtp | 2390 | udp | RSMTP | Geoff Collyer | Geoff Collyer | ||||||
| 3com-net-mgmt | 2391 | tcp | 3COM Net Management | Prathibha Nagvar | Prathibha Nagvar | ||||||
| 3com-net-mgmt | 2391 | udp | 3COM Net Management | Prathibha Nagvar | Prathibha Nagvar | ||||||
| tacticalauth | 2392 | tcp | Tactical Auth | David Yon | David Yon | ||||||
| tacticalauth | 2392 | udp | Tactical Auth | David Yon | David Yon | ||||||
| ms-olap1 | 2393 | tcp | MS OLAP 1 | ||||||||
| ms-olap1 | 2393 | udp | MS OLAP 1 | ||||||||
| ms-olap2 | 2394 | tcp | MS OLAP 2 | Mosha Pasumansky | Mosha Pasumansky | ||||||
| ms-olap2 | 2394 | udp | MS OLAP 2 | Mosha Pasumansky | Mosha Pasumansky |