Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
ariel3 422 tcp Ariel 3 Joel Karafin Joel Karafin
ariel3 422 udp Ariel 3 Joel Karafin Joel Karafin
soap-beep 605 tcp SOAP over BEEP RFC 4227
soap-beep 605 udp SOAP over BEEP RFC 4227
autodesk-lm 1422 tcp Autodesk License Manager David Ko David Ko
autodesk-lm 1422 udp Autodesk License Manager David Ko David Ko
crmsbits 2422 tcp CRMSBITS Rod Ward Rod Ward
crmsbits 2422 udp CRMSBITS Rod Ward Rod Ward
rusb-sys-port 3422 tcp Remote USB System Port Steven Klein Steven Klein 2002-02
rusb-sys-port 3422 udp Remote USB System Port Steven Klein Steven Klein 2002-02
tsepisp 4422 tcp TSEP Installation Service Protocol Technical Software Engineering Plazotta Peter Plazotta 2016-06-22
4422 udp Reserved
salient-mux 5422 tcp Salient MUX Richard Farnham Richard Farnham
salient-mux 5422 udp Salient MUX Richard Farnham Richard Farnham
6422-6431 Unassigned
7422-7425 Unassigned
8418-8422 Unassigned
36422 tcp Reserved
36422 udp Reserved
x2-control 36422 sctp X2-Control Plane (3GPP) Kimmo Kymalainen Kimmo Kymalainen 2009-09-01
38422 tcp Reserved
38422 udp Reserved
xn-control 38422 sctp Xn Control Plane (3GPP) Luis Lopes Luis Lopes 2017-05-18 2017-05-19

Contact Information

Name Contact URI Last Updated
David Ko dko&autodesk.com
Joel Karafin jkarafin&infotrieve.com
Kimmo Kymalainen kimmo.kymalainen&etsi.org 2017-05-08
Luis Lopes llopes&qti.qualcomm.com 2017-06-23
Peter Plazotta peter.plazotta&tsep.de 2016-06-22
Richard Farnham rfarnham&salient.com
Rod Ward RWard&vaccmel1.telstra.com.au
Steven Klein stevek&ionetworks.com 2002-02
Technical Software Engineering Plazotta peter.plazotta&tsep.de 2016-06-22