Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| utmpsd | 430 | tcp | UTMPSD | ||||||||
| utmpsd | 430 | udp | UTMPSD | ||||||||
| kink | 910 | tcp | Kerberized Internet Negotiation of Keys (KINK) | RFC 4430 | |||||||
| kink | 910 | udp | Kerberized Internet Negotiation of Keys (KINK) | RFC 4430 | |||||||
| tpdu | 1430 | tcp | Hypercom TPDU | Noor Chowdhury | Noor Chowdhury | ||||||
| tpdu | 1430 | udp | Hypercom TPDU | Noor Chowdhury | Noor Chowdhury | ||||||
| venus | 2430 | tcp | venus | ||||||||
| venus | 2430 | udp | venus | ||||||||
| ssdispatch | 3430 | tcp | Scott Studios Dispatch | Michael Settles | Michael Settles | 2002-03 | |||||
| ssdispatch | 3430 | udp | Scott Studios Dispatch | Michael Settles | Michael Settles | 2002-03 | |||||
| corelccam | 4300 | tcp | Corel CCam | Jason Aiken | Jason Aiken | ||||||
| corelccam | 4300 | udp | Corel CCam | Jason Aiken | Jason Aiken | ||||||
| d-data | 4301 | tcp | Diagnostic Data | ||||||||
| d-data | 4301 | udp | Diagnostic Data | ||||||||
| d-data-control | 4302 | tcp | Diagnostic Data Control | Jon March | Jon March | 2006-09 | |||||
| d-data-control | 4302 | udp | Diagnostic Data Control | Jon March | Jon March | 2006-09 | |||||
| srcp | 4303 | tcp | Simple Railroad Command Protocol | Matthias Trute | Matthias Trute | 2007-01 | |||||
| srcp | 4303 | udp | Simple Railroad Command Protocol | Matthias Trute | Matthias Trute | 2007-01 | |||||
| owserver | 4304 | tcp | One-Wire Filesystem Server | Paul Alfille | Paul Alfille | 2007-01 | Defined TXT keys: txtvers | ||||
| owserver | 4304 | udp | One-Wire Filesystem Server | Paul Alfille | Paul Alfille | 2007-01 | Defined TXT keys: txtvers | ||||
| batman | 4305 | tcp | better approach to mobile ad-hoc networking | Simon Wunderlich | Simon Wunderlich | 2007-08-30 | |||||
| batman | 4305 | udp | better approach to mobile ad-hoc networking | Simon Wunderlich | Simon Wunderlich | 2007-08-30 | |||||
| pinghgl | 4306 | tcp | Hellgate London | David Berk | David Berk | 2007-08-30 | |||||
| pinghgl | 4306 | udp | Hellgate London | David Berk | David Berk | 2007-08-30 | |||||
| trueconf | 4307 | tcp | TrueConf Videoconference Service | Dmitry Odintsov | Lev Yakupov | 2007-10-22 | 2017-05-12 | ||||
| trueconf | 4307 | udp | TrueConf Videoconference Service | Dmitry Odintsov | Lev Yakupov | 2007-10-22 | 2017-05-12 | ||||
| compx-lockview | 4308 | tcp | CompX-LockView | John Payson | John Payson | 2007-10-22 | |||||
| compx-lockview | 4308 | udp | CompX-LockView | John Payson | John Payson | 2007-10-22 | |||||
| dserver | 4309 | tcp | Exsequi Appliance Discovery | Angelo Masci | Angelo Masci | 2007-01 | |||||
| dserver | 4309 | udp | Exsequi Appliance Discovery | Angelo Masci | Angelo Masci | 2007-01 | |||||
| rsqlserver | 4430 | tcp | REAL SQL Server | Marco Bambini | Marco Bambini | 2008-08-28 | |||||
| rsqlserver | 4430 | udp | REAL SQL Server | Marco Bambini | Marco Bambini | 2008-08-28 | |||||
| radec-corp | 5430 | tcp | RADEC CORP | David Chell | David Chell | ||||||
| radec-corp | 5430 | udp | RADEC CORP | David Chell | David Chell | ||||||
| xmpv7 | 7430 | tcp | OpenView DM xmpv7 api pipe | Dave Lamb | Dave Lamb | ||||||
| xmpv7 | 7430 | udp | OpenView DM xmpv7 api pipe | Dave Lamb | Dave Lamb | ||||||
| lsdp | 11430 | udp | Lenbrook Service Discovery Protocol | Lenbrook Industries Limited | Kevin Groeneveld | 2014-03-27 | |||||
| 11430 | tcp | Reserved | |||||||||
| recvr-rc | 43000 | tcp | Receiver Remote Control | Research Electronics International | Ross Binkley | 2012-12-20 | |||||
| recvr-rc-disc | 43000 | udp | Receiver Remote Control Discovery | Research Electronics International | Ross Binkley | 2012-12-20 | |||||
| 43001-43187 | Unassigned |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Angelo Masci | angelomasci&yahoo.co.uk | 2007-01 | |
| Dave Lamb | rdl&rdl.cnd.hp.com | ||
| David Berk | dberk&ping-0.com | 2007-08-30 | |
| David Chell | david&softlife.co.nz | ||
| Dmitry Odintsov | dimodin&trueconf.com | 2017-05-12 | |
| Jason Aiken | jasona&corelcomputer.com | ||
| John Payson | john&circad.com | 2007-10-22 | |
| Jon March | jon.march&paget-analyst-services.co.uk | 2006-09 | |
| Kevin Groeneveld | Lenbrook Industries Limited | kgroeneveld&lenbrook.com | 2014-03-27 |
| Lenbrook Industries Limited | tsonderskov&lenbrook.com | 2014-03-27 | |
| Lev Yakupov | lyakupov&trueconf.com | 2017-05-12 | |
| Marco Bambini | marco&realsoftware.com | 2008-08-28 | |
| Matthias Trute | mtrute&web.de | 2007-01 | |
| Michael Settles | michael.settles&verizon.net | 2002-03 | |
| Noor Chowdhury | noor&hypercom.com | ||
| Paul Alfille | paul.alfille&gmail.com | 2007-01 | |
| Research Electronics International | software&reiusa.net | 2012-12-20 | |
| Ross Binkley | Research Electronics International | software&reiusa.net | 2012-12-20 |
| Simon Wunderlich | siwu&hrz.tu-chemnitz.de | 2007-08-30 |