Service Name and Transport Protocol Port Number Registry
- Last Updated
- 2026-09-30
- Expert(s)
-
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf SCTP: Michael Tuexen DCCP: Eddie Kohler and Yoshifumi Nishida
- Reference
- [RFC 6335]
- Note
-
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP. Service names are assigned on a first-come, first-served process, as documented in [RFC 6335]. Port numbers are assigned in various ways, based on three ranges: System Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private Ports (49152-65535); the different uses of these ranges are described in [RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are assigned by the "IETF Review" or "IESG Approval" procedures described in [RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, the "IESG Approval" process, or the "Expert Review" process, as per [RFC 6335]. Dynamic Ports are not assigned. The registration procedures for service names and port numbers are described in [RFC 6335]. Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration. ************************************************************************ * PLEASE NOTE THE FOLLOWING: * * * * ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN * * ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK * * TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT * * IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE * * ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD * * CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF * * THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER * * REGISTERED OR NOT. * ************************************************************************
- Request an Assignment
-
[https://www.iana.org/protocols/apply]
- Available Formats
-

CSV
XML
HTML
TXT
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| l-acoustics | 4432 | tcp | L-ACOUSTICS management | [L-ACOUSTICS] | [Christophe_Pignon] | 2012-08-13 | |||||
| l-acoustics | 4432 | udp | L-ACOUSTICS management | [L-ACOUSTICS] | [Christophe_Pignon] | 2012-08-13 | |||||
| 44124-44320 | Unassigned | ||||||||||
| pmcd | 44321 | tcp | PCP server (pmcd) | [Performance_Co-Pilot_PCP_Project] | [Ken_McDonell] | 2010-12-20 | 2025-09-29 | ||||
| pmcd | 44321 | udp | PCP server (pmcd) | [Performance_Co-Pilot_PCP_Project] | [Ken_McDonell] | 2010-12-20 | 2025-09-29 | ||||
| pmproxy | 44322 | tcp | PCP proxy (pmproxy) | [Performance_Co-Pilot_PCP_Project] | [Ken_McDonell] | 2003-07 | 2025-09-26 | ||||
| pmproxy | 44322 | udp | PCP proxy (pmproxy) | [Performance_Co-Pilot_PCP_Project] | [Ken_McDonell] | 2003-07 | 2025-09-26 | ||||
| pmwebapi | 44323 | tcp | HTTP binding for Performance Co-Pilot client API | [Performance_Co-Pilot_PCP_Project] | [Ken_McDonell] | 2013-10-09 | |||||
| 44323 | udp | Unassigned | "pcp" assignment withdrawn, moved to port 5351 per RFC6887 | ||||||||
| 44324-44443 | Unassigned |
Contact Information
| ID | Name | Organization | Contact URI | Last Updated |
|---|---|---|---|---|
| [Christophe_Pignon] | Christophe Pignon | L-ACOUSTICS | mailto:christophe.pignon&l-acoustics.com | 2012-08-13 |
| [Ken_McDonell] | Ken McDonell | mailto:kenj&kenj.id.au | 2025-09-26 | |
| [L-ACOUSTICS] | L-ACOUSTICS | mailto:christophe.pignon&l-acoustics.com | 2012-08-13 | |
| [Performance_Co-Pilot_PCP_Project] | Performance Co-Pilot (PCP) Project | mailto:pcp-maintainers&groups.io | 2025-09-26 |