Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
ampr-rcmd 459 tcp ampr-rcmd Rob Janssen Rob Janssen
ampr-rcmd 459 udp ampr-rcmd Rob Janssen Rob Janssen
proshare1 1459 tcp Proshare Notebook Application
proshare1 1459 udp Proshare Notebook Application
xrpl 2459 tcp Community David Schwartz David Schwartz 2019-08-09
xrpl 2459 udp Community David Schwartz David Schwartz 2019-08-09
integral 3459 tcp TIP Integral Integral Software Olivier Mascia 2023-11-07
integral 3459 udp TIP Integral Integral Software Olivier Mascia 2023-11-07
4459 Unassigned
rid 4590 tcp RID over HTTP/TLS IESG IETF Chair RFC 6546
4590 udp Reserved
l3t-at-an 4591 tcp HRPD L3T (AT-AN) Avi Lior Avi Lior 2009-02-27
l3t-at-an 4591 udp HRPD L3T (AT-AN) Avi Lior Avi Lior 2009-02-27
4592 tcp Reserved
hrpd-ith-at-an 4592 udp HRPD-ITH (AT-AN) David Ott David Ott 2008-06-05
ipt-anri-anri 4593 tcp IPT (ANRI-ANRI)
ipt-anri-anri 4593 udp IPT (ANRI-ANRI)
ias-session 4594 tcp IAS-Session (ANRI-ANRI)
ias-session 4594 udp IAS-Session (ANRI-ANRI)
ias-paging 4595 tcp IAS-Paging (ANRI-ANRI)
ias-paging 4595 udp IAS-Paging (ANRI-ANRI)
ias-neighbor 4596 tcp IAS-Neighbor (ANRI-ANRI) David Ott David Ott 2007-07-31
ias-neighbor 4596 udp IAS-Neighbor (ANRI-ANRI) David Ott David Ott 2007-07-31
a21-an-1xbs 4597 tcp A21 (AN-1xBS) David Ott David Ott 2006-02
a21-an-1xbs 4597 udp A21 (AN-1xBS) David Ott David Ott 2006-02
a16-an-an 4598 tcp A16 (AN-AN) David Ott David Ott 2005-12
a16-an-an 4598 udp A16 (AN-AN) David Ott David Ott 2005-12
a17-an-an 4599 tcp A17 (AN-AN) David Ott David Ott 2006-02
a17-an-an 4599 udp A17 (AN-AN) David Ott David Ott 2006-02
44554-44599 Unassigned
45826-45965 Unassigned
ssr-servermgr 45966 tcp SSRServerMgr Jeremy Gilliat Jeremy Gilliat
ssr-servermgr 45966 udp SSRServerMgr Jeremy Gilliat Jeremy Gilliat
45967-46335 Unassigned
robustirc tcp Like ircu (RFC 1459), but failure tolerant due to strong consistency among n>=3 servers Michael Stapelberg Michael Stapelberg 2015-01-07 Defined TXT keys: None

Contact Information

Name Organization Contact URI Last Updated
Avi Lior avi&bridgewatersystems.com 2009-02-27
David Ott dott&qualcomm.com 2010-10-15
David Schwartz davidjoelschwartz&gmail.com 2019-08-09
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Integral Software om&integral.software 2023-11-07
Jeremy Gilliat jeremy.gilliat&geac.com
Michael Stapelberg michael+iana&stapelberg.ch 2015-01-07
Olivier Mascia om&integral.software 2023-11-07
Rob Janssen rob&sys3.pe1chl.ampr.org