Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-11-05

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
kpasswd 464 tcp kpasswd Greg Hudson Greg Hudson 2023-11-17
kpasswd 464 udp kpasswd Greg Hudson Greg Hudson 2023-11-17
nntps 563 tcp nntp protocol over TLS/SSL (was snntp) IESG IETF Chair 2018-07-06 RFC 4642
nntps 563 udp nntp protocol over TLS/SSL (was snntp) IESG IETF Chair 2018-07-06 RFC 4642
msl-lmd 1464 tcp MSL License Manager

IANA assigned this well-formed service name as a replacement for "msl_lmd".
Matt Timmermans Matt Timmermans
msl_lmd 1464 tcp MSL License Manager Matt Timmermans Matt Timmermans This entry is an alias to "msl-lmd". This entry is now historic, not usable for use with many common service discovery mechanisms.
msl-lmd 1464 udp MSL License Manager

IANA assigned this well-formed service name as a replacement for "msl_lmd".
Matt Timmermans Matt Timmermans
msl_lmd 1464 udp MSL License Manager Matt Timmermans Matt Timmermans This entry is an alias to "msl-lmd". This entry is now historic, not usable for use with many common service discovery mechanisms.
direcpc-si 2464 tcp DirecPC SI Doug Dillon Doug Dillon
direcpc-si 2464 udp DirecPC SI Doug Dillon Doug Dillon
edm-mgr-sync 3464 tcp EDM MGR Sync
edm-mgr-sync 3464 udp EDM MGR Sync
4622-4645 Unassigned
dots-signal 4646 tcp Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel Protocol. The service name is used to construct the SRV service names "_dots-signal._udp" and "_dots-signal._tcp" for discovering DOTS servers used to establish DOTS signal channel. IESG IETF Chair 2020-01-16 2021-06-14 RFC 8973; RFC 9132
dots-signal 4646 udp Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel Protocol. The service name is used to construct the SRV service names "_dots-signal._udp" and "_dots-signal._tcp" for discovering DOTS servers used to establish DOTS signal channel. IESG IETF Chair 2020-01-16 2021-06-14 RFC 8973; RFC 9132
4647-4657 Unassigned
quailnet 5464 tcp Quail Networks Object Broker Craig N. Bissell Craig N. Bissell 2006-04
quailnet 5464 udp Quail Networks Object Broker Craig N. Bissell Craig N. Bissell 2006-04
ieee11073-20701 6464 tcp Port assignment for medical device communication in accordance to IEEE 11073-20701 David Gregorczyk David Gregorczyk 2017-03-02
ieee11073-20701 6464 udp Port assignment for medical device communication in accordance to IEEE 11073-20701 David Gregorczyk David Gregorczyk 2017-03-02
18464-18515 Unassigned
24387-24464 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Craig N. Bissell craig&quailnetworks.com 2006-04
David Gregorczyk david.gregorczyk&draeger.com 2017-03-02
Doug Dillon dillon&hns.com
Greg Hudson ghudson&mit.edu 2023-11-17
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Matt Timmermans