Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-22
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| tn-tl-w1 | 474 | tcp | tn-tl-w1 | ||||||||
| tn-tl-w2 | 474 | udp | tn-tl-w2 | Ed Kress | Ed Kress | ||||||
| telefinder | 1474 | tcp | Telefinder | Jim White | Jim White | ||||||
| telefinder | 1474 | udp | Telefinder | Jim White | Jim White | ||||||
| vitalanalysis | 2474 | tcp | Vital Analysis | Srinivas Reddy | Srinivas Reddy | ||||||
| vitalanalysis | 2474 | udp | Vital Analysis | Srinivas Reddy | Srinivas Reddy | ||||||
| ttntspauto | 3474 | tcp | TSP Automation | Arnie Koster | Arnie Koster | 2002-04 | |||||
| ttntspauto | 3474 | udp | TSP Automation | Arnie Koster | Arnie Koster | 2002-04 | |||||
| ipfixs | 4740 | tcp | ipfix protocol over TLS | Nevil Brownlee | Nevil Brownlee | 2006-10 | |||||
| ipfixs | 4740 | sctp | ipfix protocol over DTLS | Nevil Brownlee | Nevil Brownlee | 2006-10 | |||||
| ipfixs | 4740 | udp | ipfix protocol over DTLS | Nevil Brownlee | Nevil Brownlee | 2006-10 | |||||
| lumimgrd | 4741 | tcp | Luminizer Manager | George Hwa | George Hwa | 2007-03 | |||||
| lumimgrd | 4741 | udp | Luminizer Manager | George Hwa | George Hwa | 2007-03 | |||||
| sicct | 4742 | tcp | SICCT | ||||||||
| sicct-sdp | 4742 | udp | SICCT Service Discovery Protocol | TeleTrusT Deutschland e.V. | TeleTrusT Deutschland e.V. | 2006-04 | |||||
| openhpid | 4743 | tcp | openhpi HPI service | Thomas Kanngieser | Thomas Kanngieser | 2006-01 | |||||
| openhpid | 4743 | udp | openhpi HPI service | Thomas Kanngieser | Thomas Kanngieser | 2006-01 | |||||
| ifsp | 4744 | tcp | Internet File Synchronization Protocol | Alex White | Alex White | 2007-09-12 | |||||
| ifsp | 4744 | udp | Internet File Synchronization Protocol | Alex White | Alex White | 2007-09-12 | |||||
| fmp | 4745 | tcp | Funambol Mobile Push | Andrea Gazzaniga | Andrea Gazzaniga | 2007-01 | |||||
| fmp | 4745 | udp | Funambol Mobile Push | Andrea Gazzaniga | Andrea Gazzaniga | 2007-01 | |||||
| 4746 | tcp | Reserved | |||||||||
| intelliadm-disc | 4746 | udp | IntelliAdmin Discovery | IntelliAdmin, LLC | Steve Wiseman | 2016-11-18 | |||||
| buschtrommel | 4747 | udp | peer-to-peer file exchange protocol | Tobias Sturm | Tobias Sturm | 2013-01-14 | |||||
| 4747 | tcp | Reserved | |||||||||
| 4748-4748 | Unassigned | ||||||||||
| profilemac | 4749 | tcp | Profile for Mac | David Sinclair | David Sinclair | 2006-05 | |||||
| profilemac | 4749 | udp | Profile for Mac | David Sinclair | David Sinclair | 2006-05 | |||||
| apsolab-rpc | 5474 | udp | The Apsolab company's status query protocol | Apsolab Inc. | Jean-Francois Gauthier | 2014-11-10 | |||||
| 5474 | tcp | Reserved | |||||||||
| neo4j | 7474 | tcp | Neo4j Graph Database | Neo Technology, Inc | Julian Simpson | 2013-02-08 | |||||
| 7474 | udp | Reserved | |||||||||
| noteshare | 8474 | tcp | AquaMinds NoteShare | Michael McNabb | Michael McNabb | 2005-10 | |||||
| noteshare | 8474 | udp | AquaMinds NoteShare | Michael McNabb | Michael McNabb | 2005-10 | |||||
| 37473-37474 | Unassigned | ||||||||||
| netconf-beep | NETCONF over BEEP | RFC 4744; RFC 9900 | |||||||||
| netconfsoapbeep | NETCONF for SOAP over BEEP | RFC 4743; RFC 9900 | |||||||||
| netconfsoaphttp | NETCONF for SOAP over HTTPS | RFC 4743; RFC 9900 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Alex White | alex&intralan.co.uk | 2007-09-12 | |
| Andrea Gazzaniga | gazzaniga&funambol.com | 2007-01 | |
| Apsolab Inc. | admin&apsolab.com | 2014-11-10 | |
| Arnie Koster | akoster&teltone.com | 2002-04 | |
| David Sinclair | dev&profilemac.com | 2006-05 | |
| Ed Kress | eskress&thinknet.com | ||
| George Hwa | george.hwa&kla-tencor.com | 2016-10-17 | |
| IntelliAdmin, LLC | support&intelliadmin.com | 2016-11-18 | |
| Jean-Francois Gauthier | Apsolab Inc. | jfgauthier&apsolab.com | 2014-11-10 |
| Jim White | Jim_White&spiderisland.com | ||
| Julian Simpson | Neo Technology, Inc | julian.simpson&neotechnology.com | 2016-09-29 |
| Michael McNabb | michael&aquaminds.com | 2005-10 | |
| Neo Technology, Inc | admins&neotechnology.com | 2016-09-29 | |
| Nevil Brownlee | n.brownlee&auckland.ac.nz | 2006-10 | |
| Srinivas Reddy | sreddy&vitalsigns.com | ||
| Steve Wiseman | steve.wiseman&intelliadmin.com | 2016-11-18 | |
| TeleTrusT Deutschland e.V. | info&teletrust.de | 2006-04 | |
| Thomas Kanngieser | thomas.kanngieser&arcor.de | 2006-01 | |
| Tobias Sturm | tobias.sturm&student.kit.edu | 2013-01-14 |