Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
re-mail-ck 50 tcp Remote Mail Checking Protocol Steve Dorner Steve Dorner
re-mail-ck 50 udp Remote Mail Checking Protocol Steve Dorner Steve Dorner
imap 143 tcp Internet Message Access Protocol IESG IETF Chair 2021-02-22 RFC 3501; RFC 9051
sql-net 150 tcp SQL-NET Martin Picard Martin Picard
sql-net 150 udp SQL-NET Martin Picard Martin Picard
z39-50 210 tcp ANSI Z39.50

IANA assigned this well-formed service name as a replacement for "z39.50".
Mark H. Needleman Mark H. Needleman
z39.50 210 tcp ANSI Z39.50 Mark H. Needleman Mark H. Needleman This entry is an alias to "z39-50". This entry is now historic, not usable for use with many common service discovery mechanisms.
z39-50 210 udp ANSI Z39.50

IANA assigned this well-formed service name as a replacement for "z39.50".
Mark H. Needleman Mark H. Needleman
z39.50 210 udp ANSI Z39.50 Mark H. Needleman Mark H. Needleman This entry is an alias to "z39-50". This entry is now historic, not usable for use with many common service discovery mechanisms.
matip-type-a 350 tcp MATIP Type A Alain Robert Alain Robert RFC 2351
matip-type-a 350 udp MATIP Type A Alain Robert Alain Robert RFC 2351
tserver 450 tcp Computer Supported Telecomunication Applications Harvey S. Schultz Harvey S. Schultz
tserver 450 udp Computer Supported Telecomunication Applications Harvey S. Schultz Harvey S. Schultz
isakmp 500 tcp isakmp Mark Schertler Mark Schertler
isakmp 500 udp isakmp Mark Schertler Mark Schertler
stmf 501 tcp STMF Alan Ungar Alan Ungar
stmf 501 udp STMF Alan Ungar Alan Ungar
mbap 502 tcp Modbus Application Protocol modbus.org Dennis Dube 2014-06-10
mbap 502 udp Modbus Application Protocol modbus.org Dennis Dube 2014-06-10
intrinsa 503 tcp Intrinsa Robert Ford Robert Ford
intrinsa 503 udp Intrinsa Robert Ford Robert Ford
citadel 504 tcp citadel Art Cancro Art Cancro
citadel 504 udp citadel Art Cancro Art Cancro
mailbox-lm 505 tcp mailbox-lm Beverly Moody Beverly Moody
mailbox-lm 505 udp mailbox-lm Beverly Moody Beverly Moody
ohimsrv 506 tcp ohimsrv Scott Powell Scott Powell
ohimsrv 506 udp ohimsrv Scott Powell Scott Powell
crs 507 tcp crs Brad Wright Brad Wright
crs 507 udp crs Brad Wright Brad Wright
xvttp 508 tcp xvttp Keith J. Alphonso Keith J. Alphonso
xvttp 508 udp xvttp Keith J. Alphonso Keith J. Alphonso
snare 509 tcp snare Dennis Batchelder Dennis Batchelder
snare 509 udp snare Dennis Batchelder Dennis Batchelder
new-rwho 550 tcp new-who n/a
new-rwho 550 udp new-who n/a
obex 650 tcp OBEX Jeff Garbers Jeff Garbers
obex 650 udp OBEX Jeff Garbers Jeff Garbers
rfile 750 tcp
loadav 750 udp
kerberos-iv 750 udp kerberos version iv Martin Hamilton Martin Hamilton
domain-s 853 udp DNS query-response protocol run over DTLS or QUIC IESG IETF Chair 2015-10-08 2022-04-01 RFC 7858; RFC 8094; RFC 9250
imaps 993 tcp IMAP over TLS protocol IESG IETF Chair 2021-02-22 RFC 3501; RFC 8314; RFC 9051
cma 1050 tcp CORBA Management Agent Ramy Zaarour Ramy Zaarour
cma 1050 udp CORBA Management Agent Ramy Zaarour Ramy Zaarour
blaze 1150 tcp Blaze File Server Curt Schimmel Curt Schimmel 2005-11
blaze 1150 udp Blaze File Server Curt Schimmel Curt Schimmel 2005-11
swldy-sias 1250 tcp swldy-sias Peter E Williams Peter E Williams
swldy-sias 1250 udp swldy-sias Peter E Williams Peter E Williams
editbench 1350 tcp Registration Network Protocol Simson L. Garfinkel Simson L. Garfinkel
editbench 1350 udp Registration Network Protocol Simson L. Garfinkel Simson L. Garfinkel
dwf 1450 tcp Tandem Distributed Workbench Facility Mike Bert Mike Bert
dwf 1450 udp Tandem Distributed Workbench Facility Mike Bert Mike Bert
vlsi-lm 1500 tcp VLSI License Manager Shue-Lin Kuo Shue-Lin Kuo
vlsi-lm 1500 udp VLSI License Manager Shue-Lin Kuo Shue-Lin Kuo
saiscm 1501 tcp Satellite-data Acquisition System 3 Bill Taylor Bill Taylor
saiscm 1501 udp Satellite-data Acquisition System 3 Bill Taylor Bill Taylor
shivadiscovery 1502 tcp Shiva Jonathan Wenocur Jonathan Wenocur
shivadiscovery 1502 udp Shiva Jonathan Wenocur Jonathan Wenocur
imtc-mcs 1503 tcp Databeam Jim Johnston Jim Johnston
imtc-mcs 1503 udp Databeam Jim Johnston Jim Johnston
evb-elm 1504 tcp EVB Software Engineering License Manager B.G. Mahesh B.G. Mahesh
evb-elm 1504 udp EVB Software Engineering License Manager B.G. Mahesh B.G. Mahesh
funkproxy 1505 tcp Funk Software, Inc. Robert D. Vincent Robert D. Vincent
funkproxy 1505 udp Funk Software, Inc. Robert D. Vincent Robert D. Vincent
utcd 1506 tcp Universal Time daemon (utcd) Walter Poxon Walter Poxon
utcd 1506 udp Universal Time daemon (utcd) Walter Poxon Walter Poxon
symplex 1507 tcp symplex Mike Turley Mike Turley
symplex 1507 udp symplex Mike Turley Mike Turley
diagmond 1508 tcp diagmond Pete Moscatelli Pete Moscatelli
diagmond 1508 udp diagmond Pete Moscatelli Pete Moscatelli
robcad-lm 1509 tcp Robcad, Ltd. License Manager Hindin Joseph Hindin Joseph
robcad-lm 1509 udp Robcad, Ltd. License Manager Hindin Joseph Hindin Joseph
3m-image-lm 1550 tcp Image Storage license manager 3M Company J. C. Canessa J. C. Canessa
3m-image-lm 1550 udp Image Storage license manager 3M Company J. C. Canessa J. C. Canessa
nkd 1650 tcp nkdn
nkd 1650 udp nkd
sslp 1750 tcp Simple Socket Library's PortMaster Dr. Charles E. Campbell Jr. Dr. Charles E. Campbell Jr.
sslp 1750 udp Simple Socket Library's PortMaster Dr. Charles E. Campbell Jr. Dr. Charles E. Campbell Jr.
gsi 1850 tcp GSI William Mullaney William Mullaney
gsi 1850 udp GSI William Mullaney William Mullaney
ismaeasdaqtest 1950 tcp ISMA Easdaq Test Stephen Dunne Stephen Dunne
ismaeasdaqtest 1950 udp ISMA Easdaq Test Stephen Dunne Stephen Dunne
av-emb-config 2050 tcp Avaya EMB Config Port John Yeager John Yeager
av-emb-config 2050 udp Avaya EMB Config Port John Yeager John Yeager
h2250-annex-g 2099 tcp H.225.0 Annex G Signalling ITU-T ITU-T TSB 2013-01-31
h2250-annex-g 2099 udp H.225.0 Annex G Signalling ITU-T ITU-T TSB 2013-01-31
tdmoip 2142 tcp TDM OVER IP Yaakov Stein Yaakov Stein 2016-09-21 RFC 5087
tdmoip 2142 udp TDM OVER IP Yaakov Stein Yaakov Stein 2016-09-21 RFC 5087
dynamic3d 2150 tcp DYNAMIC3D Tobias Wegner Tobias Wegner
dynamic3d 2150 udp DYNAMIC3D Tobias Wegner Tobias Wegner
remote-collab 2250 tcp remote-collab Richard Walters Richard Walters
remote-collab 2250 udp remote-collab Richard Walters Richard Walters
apx500api-1 2264 tcp Audio Precision Apx500 API Port 1
apx500api-1 2264 udp Audio Precision Apx500 API Port 1
apx500api-2 2265 tcp Audio Precision Apx500 API Port 2 Robert Wright, Founder and Principal Engineer Robert Wright, Founder and Principal Engineer
apx500api-2 2265 udp Audio Precision Apx500 API Port 2 Robert Wright, Founder and Principal Engineer Robert Wright, Founder and Principal Engineer
amt 2268 tcp AMT IESG IETF Chair 2004-12 2014-12-17 RFC 7450
amt 2268 udp AMT IESG IETF Chair 2004-12 2014-12-17 RFC 7450
psbserver 2350 tcp Pharos Booking Server
psbserver 2350 udp Pharos Booking Server

Contact Information

Name Organization Contact URI Last Updated
Alain Robert arobert&par.sita.int
Alan Ungar aungar&farradyne.com
Art Cancro ajc&citadel.org 2015-02-18
B.G. Mahesh mahesh&sett.com
Beverly Moody Beverly_Moody&stercomm.com
Bill Taylor sais&ssec.wisc.edu
Brad Wright bradwr&microsoft.com
Curt Schimmel curt&small-tree.com 2005-11
Dennis Batchelder dennis&capres.com
Dennis Dube dennis.dube&schneider-electric.com 2014-06-10
Dr. Charles E. Campbell Jr. cec&gryphon.gsfc.nasa.gov
Harvey S. Schultz harvey&acm.org
Hindin Joseph hindin%25robcad@uunet.uu.net
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
ITU-T tsbsg16&itu.int 2013-01-31
ITU-T TSB ITU-T tsbsg16&itu.int 2013-01-31
J. C. Canessa jccanessa&mmm.com
Jeff Garbers FJG030&email.mot.com
Jim Johnston jjohnston&databeam.com
John Yeager johnyeager&avaya.com
Jonathan Wenocur jhw&shiva.com
Keith J. Alphonso alphonso&ncs-ssc.com
Mark H. Needleman markn&sirsi.com
Mark Schertler mjs&tycho.ncsc.mil
Martin Hamilton martin&mrrl.lut.as.uk
Martin Picard
Mike Bert BERG_MIKE&tandem.com
Mike Turley turley&symplex.com
modbus.org rbelliardi&modbus.org 2014-06-10
Pete Moscatelli moscat&hprdstl0.rose.hp.com
Peter E Williams peter.williams&smallworld-us.com
Ramy Zaarour ramy&lumos.com
Richard Walters walters&cs.ucdavis.edu
Robert D. Vincent bert&willowpond.com
Robert Ford robert&intrinsa.com
Robert Wright, Founder and Principal Engineer Audio Precision Inc. ianaports&ap.com 2006-05
Scott Powell spowell&openhorizon.com
Shue-Lin Kuo shuelin&mdk.sanjose.vlsi.com
Simson L. Garfinkel simsong&next.cambridge.ma.us
Stephen Dunne sdun&isma.co.uk
Steve Dorner s-dorner&uiuc.edu
Tobias Wegner wegner&novagate.de
Walter Poxon wdp&ironwood.cray.com
William Mullaney mullanwi&usa.net
Yaakov Stein yaakovjstein&gmail.com 2022-02-04