Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-11-10

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
windream 534 tcp windream Admin Uwe Honermann Uwe Honermann
windream 534 udp windream Admin Uwe Honermann Uwe Honermann
micromuse-lm 1534 tcp micromuse-lm Adam Kerrison Adam Kerrison
micromuse-lm 1534 udp micromuse-lm Adam Kerrison Adam Kerrison
combox-web-acc 2534 tcp Combox Web Access Yochai Cohen Yochai Cohen
combox-web-acc 2534 udp Combox Web Access Yochai Cohen Yochai Cohen
urld-port 3534 tcp URL Daemon Port Jim Binkley Jim Binkley 2002-06
urld-port 3534 udp URL Daemon Port Jim Binkley Jim Binkley 2002-06
4534 tcp Reserved
armagetronad 4534 udp Armagetron Advanced Game Server Manuel Moos Yann Kaiser 2012-11-02
5322-5342 Unassigned
kfserver 5343 tcp Sculptor Database Server Keith Ashman Keith Ashman 2005-12
kfserver 5343 udp Sculptor Database Server Keith Ashman Keith Ashman 2005-12
xkotodrcp 5344 tcp xkoto DRCP Jeff Heisz Jeff Heisz 2006-02
xkotodrcp 5344 udp xkoto DRCP Jeff Heisz Jeff Heisz 2006-02
5345-5348 Unassigned
stuns 5349 tcp Session Traversal Utilities for NAT (STUN) port IESG IETF Chair 2019-03-28 RFC 8489
stuns 5349 udp STUN over DTLS IESG IETF Chair 2014-07-03 RFC 7350 This service name was initially created by RFC 5389.
turns 5349 tcp TURN over TLS 2019-08-02 RFC 8656
turns 5349 udp TURN over DTLS IESG IETF Chair 2019-08-02 RFC 7350 This service name was initially created by RFC 8656.
stun-behaviors 5349 tcp STUN Behavior Discovery over TLS RFC 5780
stun-behaviors 5349 udp Reserved for a future enhancement of STUN-BEHAVIOR RFC 5780
9523-9534 Unassigned
15119-15344 Unassigned
xpilot 15345 tcp XPilot Contact Port Bert Gijsbers Bert Gijsbers
xpilot 15345 udp XPilot Contact Port Bert Gijsbers Bert Gijsbers
15346-15362 Unassigned
33436-33655 Unassigned Known Unauthorized Use on ports 33436-33534

Contact Information

Name Organization Contact URI Last Updated
Adam Kerrison adam&micromuse.co.uk
Bert Gijsbers bert&xpilot.org
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jeff Heisz jeff.heisz&xkoto.com 2006-02
Jim Binkley jrb&cs.pdx.edu 2002-06
Keith Ashman sciana&sculptor.co.uk 2005-12
Manuel Moos z-man&users.sf.net 2012-11-02
Uwe Honermann u.honermann&windream.com
Yann Kaiser kaiser.yann&gmail.com 2012-11-02
Yochai Cohen yochai&combox.co.il