Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
klogin 543 tcp
klogin 543 udp
simba-cs 1543 tcp simba-cs Betsy Alexander Betsy Alexander
simba-cs 1543 udp simba-cs Betsy Alexander Betsy Alexander
reftek 2543 tcp REFTEK Phil Davidson Phil Davidson
reftek 2543 udp REFTEK Phil Davidson Phil Davidson
qftest-lookup 3543 tcp qftest Lookup Port Gregor Schmid Gregor Schmid 2002-07
qftest-lookup 3543 udp qftest Lookup Port Gregor Schmid Gregor Schmid 2002-07
radec-corp 5430 tcp RADEC CORP David Chell David Chell
radec-corp 5430 udp RADEC CORP David Chell David Chell
park-agent 5431 tcp PARK AGENT John Clifford John Clifford
park-agent 5431 udp PARK AGENT John Clifford John Clifford
postgresql 5432 tcp PostgreSQL Database Tom Lane Tom Lane
postgresql 5432 udp PostgreSQL Database Tom Lane Tom Lane
pyrrho 5433 tcp Pyrrho DBMS Malcolm Crowe Malcolm Crowe 2005-11
pyrrho 5433 udp Pyrrho DBMS Malcolm Crowe Malcolm Crowe 2005-11
sgi-arrayd 5434 tcp SGI Array Services Daemon Karl Feind Karl Feind 2005-10
sgi-arrayd 5434 udp SGI Array Services Daemon Karl Feind Karl Feind 2005-10
sceanics 5435 tcp SCEANICS situation and action notification Richard Olsen Richard Olsen
sceanics 5435 udp SCEANICS situation and action notification Richard Olsen Richard Olsen
5436 tcp Reserved
pmip6-cntl 5436 udp pmip6-cntl RFC 5844
5437 tcp Reserved
pmip6-data 5437 udp pmip6-data RFC 5844
5438-5442 Unassigned
qftest-lic-mcp 5543 tcp QF-Test License Server / QF-Test MCP Server Quality First Software GmbH Gregor Schmid 2024-01-05 2026-09-04
5543 udp Reserved
lds-distrib 6543 tcp lds_distrib Jack Baker Jack Baker 2003-06
lds-distrib 6543 udp lds_distrib Jack Baker Jack Baker 2003-06
atul 7543 tcp atul server Mark Stapp Mark Stapp 2006-01
atul 7543 udp atul server Mark Stapp Mark Stapp 2006-01
MOS-soap 10543 tcp MOS SOAP Default Port Eric Thorniley Eric Thorniley 2007-09-17
MOS-soap 10543 udp MOS SOAP Default Port Eric Thorniley Eric Thorniley 2007-09-17
44446-44543 Unassigned Known UNAUTHORIZED USE: Ports 44515 & 44516

Contact Information

Name Organization Contact URI Last Updated
Betsy Alexander tel:+1-604-681-4549
David Chell david&softlife.co.nz
Eric Thorniley eric&etcomms.co.uk 2007-09-17
Gregor Schmid gregor.schmid&qfs.de 2024-01-05
Jack Baker Jack.Baker&l-3com.com 2006-02
John Clifford John.Clifford&veritas.com
Karl Feind kaf&sgi.com 2005-10
Malcolm Crowe malcolm.crowe&paisley.ac.uk 2005-11
Mark Stapp mjs&cisco.com 2006-01
Phil Davidson p.davidson&reftek.com
Quality First Software GmbH qfs&qfs.de 2024-01-05
Richard Olsen olsen.richard&yahoo.com
Tom Lane tgl&sss.pgh.pa.us