Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
dhcpv6-client 546 tcp DHCPv6 Client
dhcpv6-client 546 udp DHCPv6 Client IESG IETF Chair 2018-05-21 RFC 9915
dhcpv6-server 547 tcp DHCPv6 Server IESG IETF Chair 2018-05-21 RFC 5460
abbaccuray 1546 tcp abbaccuray John Wendt John Wendt
abbaccuray 1546 udp abbaccuray John Wendt John Wendt
vytalvaultbrtp 2546 tcp vytalvaultbrtp
vytalvaultbrtp 2546 udp vytalvaultbrtp
3546 Unassigned 2002-09
sf-lm 4546 tcp SF License Manager (Sentinel) Thomas Koell Thomas Koell
sf-lm 4546 udp SF License Manager (Sentinel) Thomas Koell Thomas Koell
rid 4590 tcp RID over HTTP/TLS IESG IETF Chair RFC 6546
5457-5460 Unassigned
silkmeter 5461 tcp SILKMETER Klaus Fellner Klaus Fellner
silkmeter 5461 udp SILKMETER Klaus Fellner Klaus Fellner
ttl-publisher 5462 tcp TTL Publisher Peter Jacobs Peter Jacobs
ttl-publisher 5462 udp TTL Publisher Peter Jacobs Peter Jacobs
ttlpriceproxy 5463 tcp TTL Price Proxy Peter Jacobs Peter Jacobs
ttlpriceproxy 5463 udp TTL Price Proxy Peter Jacobs Peter Jacobs
quailnet 5464 tcp Quail Networks Object Broker Craig N. Bissell Craig N. Bissell 2006-04
quailnet 5464 udp Quail Networks Object Broker Craig N. Bissell Craig N. Bissell 2006-04
netops-broker 5465 tcp NETOPS-BROKER John R. Deuel John R. Deuel
netops-broker 5465 udp NETOPS-BROKER John R. Deuel John R. Deuel
5466-5469 Unassigned
6545-6546 Unassigned
cfs 7546 tcp Cisco Fabric service Rituparna Agrawal Rituparna Agrawal 2005-09
cfs 7546 udp Cisco Fabric service Rituparna Agrawal Rituparna Agrawal 2005-09
carb-repl-ctrl 12546 tcp Carbonite Server Replication Control Open Text Corporation Tony Ponzo 2022-10-07
12546 udp Reserved
areaguard-neo 23546 tcp AreaGuard Neo - WebServer SODATSW spol. s r.o. Roman Štěpánek 2012-05-31
23546 udp Reserved

Contact Information

Name Organization Contact URI Last Updated
Craig N. Bissell craig&quailnetworks.com 2006-04
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
John R. Deuel kink&netops.com
John Wendt tel:+1-614-261-2000
Klaus Fellner webmaster&segue.com
kfellner&segue.com
Open Text Corporation tponzo&opentext.com 2022-10-07
Peter Jacobs pjacobs&tullib.com
Rituparna Agrawal riagrawa&cisco.com 2005-09
Roman Štěpánek SODATSW spol. s r.o. roman.stepanek&sodatsw.cz 2012-05-31
SODATSW spol. s r.o. info&sodatsw.cz 2012-05-31
Thomas Koell info&sf.com
Tony Ponzo Open Text Corporation tponzo&opentext.com 2022-10-07