Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-11-06
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| dsf | 555 | tcp | |||||||||
| dsf | 555 | udp | |||||||||
| livelan | 1555 | tcp | livelan | Kaynam Hedayat | Kaynam Hedayat | ||||||
| livelan | 1555 | udp | livelan | Kaynam Hedayat | Kaynam Hedayat | ||||||
| compaq-wcp | 2555 | tcp | Compaq WCP | Ferruccio Barletta | Ferruccio Barletta | ||||||
| compaq-wcp | 2555 | udp | Compaq WCP | Ferruccio Barletta | Ferruccio Barletta | ||||||
| razor | 3555 | tcp | Vipul's Razor | Vipul Ved Prakash | Vipul Ved Prakash | 2002-07 | |||||
| razor | 3555 | udp | Vipul's Razor | Vipul Ved Prakash | Vipul Ved Prakash | 2002-07 | |||||
| dsmipv6 | 4191 | udp | Dual Stack MIPv6 NAT Traversal | RFC 5555 | |||||||
| rsip | 4555 | tcp | RSIP Port | RFC 3103 | |||||||
| rsip | 4555 | udp | RSIP Port | RFC 3103 | |||||||
| cbus | 5550 | tcp | Model Railway control using the CBUS message protocol | MERG | Pete Brownlow | 2017-01-03 | |||||
| 5550 | udp | Reserved | |||||||||
| 5551-5552 | Unassigned | ||||||||||
| sgi-eventmond | 5553 | tcp | SGI Eventmond Port | Andrei Vilkotski | Andrei Vilkotski | 2003-06 | |||||
| sgi-eventmond | 5553 | udp | SGI Eventmond Port | Andrei Vilkotski | Andrei Vilkotski | 2003-06 | |||||
| sgi-esphttp | 5554 | tcp | SGI ESP HTTP | Vladimir Legalov | Vladimir Legalov | ||||||
| sgi-esphttp | 5554 | udp | SGI ESP HTTP | Vladimir Legalov | Vladimir Legalov | ||||||
| personal-agent | 5555 | tcp | Personal Agent | Jackie Wu | Jackie Wu | Known UNAUTHORIZED USEs on port 5555 | |||||
| personal-agent | 5555 | udp | Personal Agent | Jackie Wu | Jackie Wu | Known UNAUTHORIZED USEs on port 5555 | |||||
| freeciv | 5556 | tcp | Freeciv gameplay | Reinier Post and Paul Zastoupil | Reinier Post and Paul Zastoupil | 2006-01 | Known Unauthorized Use on port 5556 | ||||
| freeciv | 5556 | udp | Freeciv gameplay | Reinier Post and Paul Zastoupil | Reinier Post and Paul Zastoupil | 2006-01 | Known Unauthorized Use on port 5556 | ||||
| farenet | 5557 | tcp | Sandlab FARENET | Kay T. Labinsky | Kay T. Labinsky | 2010-05-03 | |||||
| 5557 | udp | Reserved | |||||||||
| 5558-5564 | Unassigned | ||||||||||
| 6552-6555 | Unassigned | ||||||||||
| d-fence | 8555 | tcp | SYMAX D-FENCE | Thomas Geisel | Thomas Geisel | 2003-01 | |||||
| d-fence | 8555 | udp | SYMAX D-FENCE | Thomas Geisel | Thomas Geisel | 2003-01 | |||||
| trispen-sra | 9555 | tcp | Trispen Secure Remote Access | Jaco Botha | Jaco Botha | 2004-11 | |||||
| trispen-sra | 9555 | udp | Trispen Secure Remote Access | Jaco Botha | Jaco Botha | 2004-11 | |||||
| 15364-15554 | Unassigned | ||||||||||
| cisco-snat | 15555 | tcp | Cisco Stateful NAT | Kaushik Biswas | Kaushik Biswas | 2006-03 | |||||
| cisco-snat | 15555 | udp | Cisco Stateful NAT | Kaushik Biswas | Kaushik Biswas | 2006-03 | |||||
| 15556-15659 | Unassigned | ||||||||||
| ailith | 17555 | tcp | Ailith management of routers | Thomas Boje | Thomas Boje | 2014-03-27 | |||||
| 17555 | udp | Reserved | |||||||||
| 21555-21589 | Unassigned | ||||||||||
| vocaltec-wconf | 22555 | tcp | Vocaltec Web Conference | Scott Petrack | Scott Petrack | ||||||
| vocaltec-phone | 22555 | udp | Vocaltec Internet Phone | Scott Petrack | Scott Petrack | ||||||
| 24555-24576 | Unassigned | ||||||||||
| 48130-48555 | Unassigned |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Andrei Vilkotski | andreiv&sgi.com | 2003-06 | |
| Ferruccio Barletta | ferruccio.barletta&compaq.com | ||
| Jackie Wu | jackiew&infoseek.com | ||
| Jaco Botha | jaco.botha&trispen.com | 2004-11 | |
| Kaushik Biswas | kbiswas&cisco.com | 2006-03 | |
| Kay T. Labinsky | Kay.Labinsky&sandlab.de | 2010-05-03 | |
| Kaynam Hedayat | khedayat&roadrunner.pictel.com | ||
| MERG | merg&upsys.co.uk | 2017-01-03 | |
| Pete Brownlow | merg&upsys.co.uk | 2017-01-03 | |
| Reinier Post and Paul Zastoupil | freeciv&freeciv.org | 2006-01 | |
| Scott Petrack | Scott_Petrack&vocaltec.com | ||
| Thomas Boje | thomas.boje&gmx.de | 2014-03-27 | |
| Thomas Geisel | tgeisel&symax.de | 2003-01 | |
| Vipul Ved Prakash | mail&vipul.net | 2002-07 | |
| Vladimir Legalov | legalov&sgi.com |