Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-27
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 57 | tcp | any private terminal access | Jon Postel | Jon Postel | |||||||
| 57 | udp | any private terminal access | Jon Postel | Jon Postel | |||||||
| knet-cmp | 157 | tcp | KNET/VM Command/Message Protocol | Gary S. Malkin | Gary S. Malkin | ||||||
| knet-cmp | 157 | udp | KNET/VM Command/Message Protocol | Gary S. Malkin | Gary S. Malkin | ||||||
| set | 257 | tcp | Secure Electronic Transaction | Donald Eastlake | Donald Eastlake | ||||||
| set | 257 | udp | Secure Electronic Transaction | Donald Eastlake | Donald Eastlake | ||||||
| bhevent | 357 | tcp | bhevent | John Kelly | John Kelly | ||||||
| bhevent | 357 | udp | bhevent | John Kelly | John Kelly | ||||||
| scohelp | 457 | tcp | scohelp | Faith Zack | Faith Zack | ||||||
| scohelp | 457 | udp | scohelp | Faith Zack | Faith Zack | ||||||
| openvms-sysipc | 557 | tcp | openvms-sysipc | Alan Potter | Alan Potter | ||||||
| openvms-sysipc | 557 | udp | openvms-sysipc | Alan Potter | Alan Potter | ||||||
| meter | 570 | tcp | demon | ||||||||
| meter | 570 | udp | demon | ||||||||
| meter | 571 | tcp | udemon | ||||||||
| meter | 571 | udp | udemon | ||||||||
| sonar | 572 | tcp | sonar | Keith Moore | Keith Moore | ||||||
| sonar | 572 | udp | sonar | Keith Moore | Keith Moore | ||||||
| banyan-vip | 573 | tcp | banyan-vip | Denis Leclerc | Denis Leclerc | ||||||
| banyan-vip | 573 | udp | banyan-vip | Denis Leclerc | Denis Leclerc | ||||||
| ftp-agent | 574 | tcp | FTP Software Agent System | Michael S. Greenberg | Michael S. Greenberg | ||||||
| ftp-agent | 574 | udp | FTP Software Agent System | Michael S. Greenberg | Michael S. Greenberg | ||||||
| vemmi | 575 | tcp | VEMMI | Daniel Mavrakis | Daniel Mavrakis | ||||||
| vemmi | 575 | udp | VEMMI | Daniel Mavrakis | Daniel Mavrakis | ||||||
| ipcd | 576 | tcp | ipcd | ||||||||
| ipcd | 576 | udp | ipcd | ||||||||
| vnas | 577 | tcp | vnas | ||||||||
| vnas | 577 | udp | vnas | ||||||||
| ipdd | 578 | tcp | ipdd | Jay Farhat | Jay Farhat | ||||||
| ipdd | 578 | udp | ipdd | Jay Farhat | Jay Farhat | ||||||
| decbsrv | 579 | tcp | decbsrv | Rudi Martin | Rudi Martin | ||||||
| decbsrv | 579 | udp | decbsrv | Rudi Martin | Rudi Martin | ||||||
| rmc | 657 | tcp | RMC | Michael Schmidt | Michael Schmidt | ||||||
| rmc | 657 | udp | RMC | Michael Schmidt | Michael Schmidt | ||||||
| epp | 700 | tcp | Extensible Provisioning Protocol | RFC 5734 | |||||||
| epp | 700 | udp | EPP running over QUIC | IESG | IETF Chair | 2026-07-23 | RFC 5734; RFC-ietf-regext-epp-quic-12 | ||||
| 755-757 | Unassigned | ||||||||||
| twamp-control | 862 | tcp | TWAMP-Control | IESG | IETF Chair | RFC 5357 | |||||
| startron | 1057 | tcp | STARTRON | Markus Sabadello | Markus Sabadello | ||||||
| startron | 1057 | udp | STARTRON | Markus Sabadello | Markus Sabadello | ||||||
| iascontrol | 1157 | tcp | Oracle iASControl | Todd Guay | Todd Guay | 2004-11 | |||||
| iascontrol | 1157 | udp | Oracle iASControl | Todd Guay | Todd Guay | 2004-11 | |||||
| shockwave2 | 1257 | tcp | Shockwave 2 | Dave Simmons | Dave Simmons | ||||||
| shockwave2 | 1257 | udp | Shockwave 2 | Dave Simmons | Dave Simmons | ||||||
| pegboard | 1357 | tcp | Electronic PegBoard | Chris Cuilla | Chris Cuilla | ||||||
| pegboard | 1357 | udp | Electronic PegBoard | Chris Cuilla | Chris Cuilla | ||||||
| valisys-lm | 1457 | tcp | Valisys License Manager | Leslie Lincoln | Leslie Lincoln | ||||||
| valisys-lm | 1457 | udp | Valisys License Manager | Leslie Lincoln | Leslie Lincoln | ||||||
| arbortext-lm | 1557 | tcp | ArborText License Manager | David J. Wilson | David J. Wilson | ||||||
| arbortext-lm | 1557 | udp | ArborText License Manager | David J. Wilson | David J. Wilson | ||||||
| orbixd | 1570 | tcp | orbixd | Bridget Walsh | Bridget Walsh | ||||||
| orbixd | 1570 | udp | orbixd | Bridget Walsh | Bridget Walsh | ||||||
| rdb-dbs-disp | 1571 | tcp | Oracle Remote Data Base | mackin | mackin | ||||||
| rdb-dbs-disp | 1571 | udp | Oracle Remote Data Base | mackin | mackin | ||||||
| chip-lm | 1572 | tcp | Chipcom License Manager | ||||||||
| chip-lm | 1572 | udp | Chipcom License Manager | ||||||||
| itscomm-ns | 1573 | tcp | itscomm-ns | Rich Thompson | Rich Thompson | ||||||
| itscomm-ns | 1573 | udp | itscomm-ns | Rich Thompson | Rich Thompson | ||||||
| mvel-lm | 1574 | tcp | mvel-lm | David Bisset | David Bisset | ||||||
| mvel-lm | 1574 | udp | mvel-lm | David Bisset | David Bisset | ||||||
| oraclenames | 1575 | tcp | oraclenames | P.V.Shivkumar | P.V.Shivkumar | ||||||
| oraclenames | 1575 | udp | oraclenames | P.V.Shivkumar | P.V.Shivkumar | ||||||
| moldflow-lm | 1576 | tcp | Moldflow License Manager | Lech Laskowski | Lech Laskowski | ||||||
| moldflow-lm | 1576 | udp | Moldflow License Manager | Lech Laskowski | Lech Laskowski | ||||||
| hypercube-lm | 1577 | tcp | hypercube-lm | Christopher McLendon | Christopher McLendon | ||||||
| hypercube-lm | 1577 | udp | hypercube-lm | Christopher McLendon | Christopher McLendon | ||||||
| jacobus-lm | 1578 | tcp | Jacobus License Manager | Tony Cleveland | Tony Cleveland | ||||||
| jacobus-lm | 1578 | udp | Jacobus License Manager | Tony Cleveland | Tony Cleveland | ||||||
| ioc-sea-lm | 1579 | tcp | ioc-sea-lm | Paul Nelson | Paul Nelson | ||||||
| ioc-sea-lm | 1579 | udp | ioc-sea-lm | Paul Nelson | Paul Nelson | ||||||
| fujitsu-mmpdc | 1657 | tcp | fujitsu-mmpdc | Katsumi Oomuro | Katsumi Oomuro | ||||||
| fujitsu-mmpdc | 1657 | udp | fujitsu-mmpdc | Katsumi Oomuro | Katsumi Oomuro | ||||||
| cnhrp | 1757 | tcp | cnhrp | William Stoye | William Stoye | ||||||
| cnhrp | 1757 | udp | cnhrp | William Stoye | William Stoye | ||||||
| datacaptor | 1857 | tcp | DataCaptor | Steven M. Forrester | Steven M. Forrester | ||||||
| datacaptor | 1857 | udp | DataCaptor | Steven M. Forrester | Steven M. Forrester | ||||||
| unix-status | 1957 | tcp | unix-status | Thomas Erskine | Thomas Erskine | ||||||
| unix-status | 1957 | udp | unix-status | Thomas Erskine | Thomas Erskine | ||||||
| rich-cp | 2057 | tcp | Rich Content Protocol | Ronen Vainish | Ronen Vainish | ||||||
| rich-cp | 2057 | udp | Rich Content Protocol | Ronen Vainish | Ronen Vainish | ||||||
| xnds | 2157 | tcp | Xerox Network Document Scan Protocol | William R. Lear | William R. Lear | 2008-03-06 | |||||
| xnds | 2157 | udp | Xerox Network Document Scan Protocol | William R. Lear | William R. Lear | 2008-03-06 | |||||
| simple-tx-rx | 2257 | tcp | simple text/file transfer | Daniel Kilsdonk | Daniel Kilsdonk | 2006-08 | |||||
| simple-tx-rx | 2257 | udp | simple text/file transfer | Daniel Kilsdonk | Daniel Kilsdonk | 2006-08 | |||||
| unihub-server | 2357 | tcp | UniHub Server | Tim Kenyon | Tim Kenyon | ||||||
| unihub-server | 2357 | udp | UniHub Server | Tim Kenyon | Tim Kenyon | ||||||
| rapido-ip | 2457 | tcp | Rapido_IP | Man Shuen Cheung | Man Shuen Cheung | ||||||
| rapido-ip | 2457 | udp | Rapido_IP | Man Shuen Cheung | Man Shuen Cheung | ||||||
| nicetec-mgmt | 2557 | tcp | nicetec-mgmt | Joerg Paulus | Joerg Paulus | ||||||
| nicetec-mgmt | 2557 | udp | nicetec-mgmt | Joerg Paulus | Joerg Paulus | ||||||
| hs-port | 2570 | tcp | HS Port | Uri Doron | Uri Doron | ||||||
| hs-port | 2570 | udp | HS Port | Uri Doron | Uri Doron | ||||||
| cecsvc | 2571 | tcp | CECSVC | Roger Pao | Roger Pao | ||||||
| cecsvc | 2571 | udp | CECSVC | Roger Pao | Roger Pao | ||||||
| ibp | 2572 | tcp | IBP | Jonathan Downes | Jonathan Downes | ||||||
| ibp | 2572 | udp | IBP | Jonathan Downes | Jonathan Downes | ||||||
| trustestablish | 2573 | tcp | Trust Establish | Yosi Mass | Yosi Mass | ||||||
| trustestablish | 2573 | udp | Trust Establish | Yosi Mass | Yosi Mass | ||||||
| blockade-bpsp | 2574 | tcp | Blockade BPSP | VP - Research & Development | VP - Research & Development | ||||||
| blockade-bpsp | 2574 | udp | Blockade BPSP | VP - Research & Development | VP - Research & Development |