Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
ipcd 576 tcp ipcd
ipcd 576 udp ipcd
moldflow-lm 1576 tcp Moldflow License Manager Lech Laskowski Lech Laskowski
moldflow-lm 1576 udp Moldflow License Manager Lech Laskowski Lech Laskowski
tclprodebugger 2576 tcp TCL Pro Debugger
tclprodebugger 2576 udp TCL Pro Debugger
cmc-port 3576 tcp Coalsere CMC Port Chris Hawkinson Chris Hawkinson 2002-08
cmc-port 3576 udp Coalsere CMC Port Chris Hawkinson Chris Hawkinson 2002-08
radius-dynauth 3799 tcp RADIUS Dynamic Authorization RFC 3576
radius-dynauth 3799 udp RADIUS Dynamic Authorization RFC 3576
avt-profile-1 5004 dccp RTP media data RFC 3551; RFC 5762
avt-profile-2 5005 dccp RTP control protocol RFC 3551; RFC 5762
5576-5578 Unassigned
5758-5765 Unassigned
openmailns 5766 tcp OpenMail NewMail Server OpenMail Encyclopedia; Don Loughry OpenMail Encyclopedia; Don Loughry
openmailns 5766 udp OpenMail NewMail Server OpenMail Encyclopedia; Don Loughry OpenMail Encyclopedia; Don Loughry
s-openmail 5767 tcp OpenMail Suer Agent Layer (Secure) OpenMail Encyclopedia; Don Loughry OpenMail Encyclopedia; Don Loughry
s-openmail 5767 udp OpenMail Suer Agent Layer (Secure) OpenMail Encyclopedia; Don Loughry OpenMail Encyclopedia; Don Loughry
openmailpxy 5768 tcp OpenMail CMTS Server OpenMail Encyclopedia; Don Loughry OpenMail Encyclopedia; Don Loughry
openmailpxy 5768 udp OpenMail CMTS Server OpenMail Encyclopedia; Don Loughry OpenMail Encyclopedia; Don Loughry
spramsca 5769 tcp x509solutions Internal CA Brendan Fay Brendan Fay 2006-02
spramsca 5769 udp x509solutions Internal CA Brendan Fay Brendan Fay 2006-02
7576-7587 Unassigned
24555-24576 Unassigned
sauterdongle 25576 tcp Sauter Dongle Christian Brecht Christian Brecht 2010-12-15
25576 udp Reserved

Contact Information

Name Organization Contact URI Last Updated
Brendan Fay brendan.fay&x509solutions.com 2006-02
Chris Hawkinson chawkinson&coalsere.com 2002-08
Christian Brecht Christian.Brecht&sauter-gmbh.de 2010-12-15
Don Loughry DON_LOUGHRY&hp-cupertino-om4.om.hp.com
Lech Laskowski lech_laskowski&moldflow.com
OpenMail Encyclopedia opencyc&hpopd.pwd.hp.com