Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
gist 270 udp Q-mode encapsulation for GIST messages RFC 5971
ptcnameservice 597 tcp PTC Name Service Yuri Machkasov Yuri Machkasov
ptcnameservice 597 udp PTC Name Service Yuri Machkasov Yuri Machkasov
orbplus-iiop 1597 tcp orbplus-iiop Robert A. Kukura Robert A. Kukura
orbplus-iiop 1597 udp orbplus-iiop Robert A. Kukura Robert A. Kukura
homesteadglory 2597 tcp Homestead Glory John Tokash John Tokash
homesteadglory 2597 udp Homestead Glory John Tokash John Tokash
a14 3597 tcp A14 (AN-to-SC/MM)
a14 3597 udp A14 (AN-to-SC/MM)
a21-an-1xbs 4597 tcp A21 (AN-1xBS) David Ott David Ott 2006-02
a21-an-1xbs 4597 udp A21 (AN-1xBS) David Ott David Ott 2006-02
ininmessaging 5597 tcp inin secure messaging Mike Gagle Mike Gagle 2006-05
ininmessaging 5597 udp inin secure messaging Mike Gagle Mike Gagle 2006-05
5970-5983 Unassigned
pd-admin 9597 tcp PD Administration Duk Loi Duk Loi 2005-11
pd-admin 9597 udp PD Administration Duk Loi Duk Loi 2005-11

Contact Information

Name Contact URI Last Updated
David Ott dott&qualcomm.com 2010-10-15
Duk Loi dloi&peerdirect.com 2005-11
John Tokash jtokash&homestead.com
Mike Gagle mikeg&inin.com 2006-05
Robert A. Kukura kukura&apollo.hp.com
Yuri Machkasov yuri&ptc.com