Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
sshell 614 tcp SSLshell Simon J. Gerraty Simon J. Gerraty
sshell 614 udp SSLshell Simon J. Gerraty Simon J. Gerraty
c1222-acse 1153 tcp ANSI C12.22 Port RFC 6142
c1222-acse 1153 udp ANSI C12.22 Port RFC 6142
netbill-cred 1614 tcp NetBill Credential Server
netbill-cred 1614 udp NetBill Credential Server
radsec 2083 tcp Secure Radius Service IESG IETF Chair 2005-05 RFC 6614 The TCP port 2083 was already previously assigned by IANA for "RadSec", an early implementation of RADIUS/TLS, prior to issuance of this RFC. This early implementation can be configured to be compatible to RADIUS/TLS as specified by the IETF. See RFC 6614, Appendix A for details.
neveroffline 2614 tcp Never Offline Dustin Brand Dustin Brand
neveroffline 2614 udp Never Offline Dustin Brand Dustin Brand
sigma-port 3614 tcp Satchwell Sigma Dave Chapman Dave Chapman 2011-06-06
sigma-port 3614 udp Satchwell Sigma Dave Chapman Dave Chapman 2011-06-06
rfb 5900 tcp Remote Framebuffer Tristan Richardson Tristan Richardson 2006-03 RFC 6143
rfb 5900 udp Remote Framebuffer Tristan Richardson Tristan Richardson 2006-03 RFC 6143
pulsonixnls 6140 tcp Pulsonix Network License Service David Manns David Manns 2008-02-28
pulsonixnls 6140 udp Pulsonix Network License Service David Manns David Manns 2008-02-28
meta-corp 6141 tcp Meta Corporation License Manager Osamu Masuda Osamu Masuda
meta-corp 6141 udp Meta Corporation License Manager Osamu Masuda Osamu Masuda
aspentec-lm 6142 tcp Aspen Technology License Manager Kevin Massey Kevin Massey
aspentec-lm 6142 udp Aspen Technology License Manager Kevin Massey Kevin Massey
watershed-lm 6143 tcp Watershed License Manager David Ferrero David Ferrero
watershed-lm 6143 udp Watershed License Manager David Ferrero David Ferrero
statsci1-lm 6144 tcp StatSci License Manager - 1 Scott Blachowicz Scott Blachowicz
statsci1-lm 6144 udp StatSci License Manager - 1 Scott Blachowicz Scott Blachowicz
statsci2-lm 6145 tcp StatSci License Manager - 2 Scott Blachowicz Scott Blachowicz
statsci2-lm 6145 udp StatSci License Manager - 2 Scott Blachowicz Scott Blachowicz
lonewolf-lm 6146 tcp Lone Wolf Systems License Manager Dan Klein Dan Klein
lonewolf-lm 6146 udp Lone Wolf Systems License Manager Dan Klein Dan Klein
montage-lm 6147 tcp Montage License Manager Michael Ubell Michael Ubell
montage-lm 6147 udp Montage License Manager Michael Ubell Michael Ubell
ricardo-lm 6148 tcp Ricardo North America License Manager M Flemming M Flemming
ricardo-lm 6148 udp Ricardo North America License Manager M Flemming M Flemming
tal-pod 6149 tcp tal-pod Steven Loomis Steven Loomis
tal-pod 6149 udp tal-pod Steven Loomis Steven Loomis
canon-bjnp4 8614 tcp Canon BJNP Port 4 Atsushi Nakamura Atsushi Nakamura 2003-11
canon-bjnp4 8614 udp Canon BJNP Port 4 Atsushi Nakamura Atsushi Nakamura 2003-11
iadt-tls 9614 tcp iADT Protocol over TLS Paul A. Suhler Paul A. Suhler 2009-02-05
9614 udp Reserved

Contact Information

Name Organization Contact URI Last Updated
Atsushi Nakamura nakamura.atsushi318&canon.co.jp 2003-11
Dan Klein daniel.v.klein&gmail.com 2018-08-21
Dave Chapman dave.chapman&buildings.schneider-electric.com 2011-06-06
David Ferrero david&zion.com
David Manns davidm&pulsonix.com 2008-02-28
Dustin Brand amo&amo.net
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Kevin Massey massey&aspentec.com
M Flemming mflemming&aol.com
Michael Ubell michael&montage.com
Osamu Masuda
Paul A. Suhler paul.suhler&quantum.com 2009-02-06
Scott Blachowicz scott&statsci.com
Simon J. Gerraty sjg&quick.com.au
Steven Loomis srl&taligent.com
Tristan Richardson iana&realvnc.com 2006-03