Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
oob-ws-http 623 tcp DMTF out-of-band web services management protocol Jim Davis Jim Davis 2007-06
asf-rmcp 623 udp ASF Remote Management and Control Protocol Carl First Carl First
jaleosnd 1623 tcp jaleosnd Christian Schormann Christian Schormann
jaleosnd 1623 udp jaleosnd Christian Schormann Christian Schormann
lmdp 2623 tcp LMDP Ken Bailey Ken Bailey
lmdp 2623 udp LMDP Ken Bailey Ken Bailey
haipe-discover 3623 tcp HAIPIS Dynamic Discovery Mike Irani Mike Irani 2002-10
haipe-discover 3623 udp HAIPIS Dynamic Discovery Mike Irani Mike Irani 2002-10
ktelnet 6623 tcp Kerberos V5 Telnet Robert J. Scott Robert J. Scott 2005-08
ktelnet 6623 udp Kerberos V5 Telnet Robert J. Scott Robert J. Scott 2005-08
cfw 7563 tcp Control Framework RFC 6230
7607-7623 Unassigned
emc-xsw-dconfig 11623 tcp EMC XtremSW distributed config EMC David Erel 2013-09-18
11623 udp Reserved
47558-47623 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Carl First Carl.L.First&intel.com
Christian Schormann 100410.3063&compuserve.com
David Erel EMC david.erel&emc.com 2013-09-18
EMC david.erel&emc.com 2013-09-18
Jim Davis jim.davis&wbemsolutions.com 2007-06
Ken Bailey kbailey&rockettalk.com
Mike Irani irani_mike&bah.com 2002-10
Robert J. Scott rob&hpcmo.hpc.mil 2005-08