Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-11-10

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
cryptoadmin 624 tcp Crypto Admin Tony Walker Tony Walker
cryptoadmin 624 udp Crypto Admin Tony Walker Tony Walker
netconf-ssh 830 tcp NETCONF over SSH RFC 6242
netconf-ssh 830 udp NETCONF over SSH RFC 6242
udp-sr-port 1624 tcp udp-sr-port Herb Jensen Herb Jensen
udp-sr-port 1624 udp udp-sr-port Herb Jensen Herb Jensen
aria 2624 tcp Aria Logan Bruns Logan Bruns
aria 2624 udp Aria Logan Bruns Logan Bruns
dist-upgrade 3624 tcp Distributed Upgrade Port Jason Schoon Jason Schoon 2002-10
dist-upgrade 3624 udp Distributed Upgrade Port Jason Schoon Jason Schoon 2002-10
6223-6240 Unassigned
jeol-nsdtp-1 6241 tcp JEOL Network Services Data Transport Protocol 1 Kevin Wellwood Kevin Wellwood 2008-04-17
jeol-nsddp-1 6241 udp JEOL Network Services Dynamic Discovery Protocol 1 Kevin Wellwood Kevin Wellwood 2008-04-17
jeol-nsdtp-2 6242 tcp JEOL Network Services Data Transport Protocol 2 Kevin Wellwood Kevin Wellwood 2008-04-17
jeol-nsddp-2 6242 udp JEOL Network Services Dynamic Discovery Protocol 2 Kevin Wellwood Kevin Wellwood 2008-04-17
jeol-nsdtp-3 6243 tcp JEOL Network Services Data Transport Protocol 3 Kevin Wellwood Kevin Wellwood 2008-04-17
jeol-nsddp-3 6243 udp JEOL Network Services Dynamic Discovery Protocol 3 Kevin Wellwood Kevin Wellwood 2008-04-17
jeol-nsdtp-4 6244 tcp JEOL Network Services Data Transport Protocol 4 Kevin Wellwood Kevin Wellwood 2008-04-17
jeol-nsddp-4 6244 udp JEOL Network Services Dynamic Discovery Protocol 4 Kevin Wellwood Kevin Wellwood 2008-04-17
6245-6250 Unassigned
datascaler-db 6624 tcp DataScaler database Vasu Murthy Vasu Murthy 2010-02-08
6624 udp Reserved
indi 7624 tcp Instrument Neutral Distributed Interface Elwood Downey Elwood Downey 2002-04
indi 7624 udp Instrument Neutral Distributed Interface Elwood Downey Elwood Downey 2002-04
11624-11719 Unassigned Unauthorized Use Known on port 11711
directplaysrvr 47624 tcp Direct Play Server Ajay Jindal Ajay Jindal
directplaysrvr 47624 udp Direct Play Server Ajay Jindal Ajay Jindal

Contact Information

Name Contact URI Last Updated
Ajay Jindal ajayj&microsoft.com
Elwood Downey ecdowney&clearskyinstitute.com 2002-04
Herb Jensen HWJensen&nfsrv.avionics.itt.com
Jason Schoon jason.schoon&intermec.com 2002-10
Kevin Wellwood wellwood&jeol.com 2008-04-17
Logan Bruns logan&andromedia.com
Tony Walker tony&cryptocard.com
Vasu Murthy vmurthy&datascaler.com 2010-02-08