Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-11-10

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
0 tcp Reserved 2024-12-20 RFC 6335
0 udp Reserved 2024-12-20 RFC 6335
whoispp 63 tcp whois++

IANA assigned this well-formed service name as a replacement for "whois++".
Rickard Schoultz Rickard Schoultz
whois++ 63 tcp whois++ Rickard Schoultz Rickard Schoultz This entry is an alias to "whoispp". This entry is now historic, not usable for use with many common service discovery mechanisms.
whoispp 63 udp whois++

IANA assigned this well-formed service name as a replacement for "whois++".
Rickard Schoultz Rickard Schoultz
whois++ 63 udp whois++ Rickard Schoultz Rickard Schoultz This entry is an alias to "whoispp". This entry is now historic, not usable for use with many common service discovery mechanisms.
cmip-man 163 tcp CMIP/TCP Manager
cmip-man 163 udp CMIP/TCP Manager
hdap 263 tcp HDAP Troy Gau Troy Gau
hdap 263 udp HDAP Troy Gau Troy Gau
rsvp-tunnel 363 tcp RSVP Tunnel

IANA assigned this well-formed service name as a replacement for "rsvp_tunnel".
Andreas Terzis Andreas Terzis
rsvp_tunnel 363 tcp RSVP Tunnel Andreas Terzis Andreas Terzis This entry is an alias to "rsvp-tunnel". This entry is now historic, not usable for use with many common service discovery mechanisms.
rsvp-tunnel 363 udp RSVP Tunnel

IANA assigned this well-formed service name as a replacement for "rsvp_tunnel".
Andreas Terzis Andreas Terzis
rsvp_tunnel 363 udp RSVP Tunnel Andreas Terzis Andreas Terzis This entry is an alias to "rsvp-tunnel". This entry is now historic, not usable for use with many common service discovery mechanisms.
alpes 463 tcp alpes Alain Durand Alain Durand
alpes 463 udp alpes Alain Durand Alain Durand
nntps 563 tcp nntp protocol over TLS/SSL (was snntp) IESG IETF Chair 2018-07-06 RFC 4642
nntps 563 udp nntp protocol over TLS/SSL (was snntp) IESG IETF Chair 2018-07-06 RFC 4642
rda 630 tcp RDA John Hadjioannou John Hadjioannou
rda 630 udp RDA John Hadjioannou John Hadjioannou
ipp 631 tcp IPP (Internet Printing Protocol) IESG IETF Chair 2018-07-06 RFC 8011 Defined TXT keys: See BonjourPrinting.pdf.
ipp 631 udp IPP (Internet Printing Protocol) IESG IETF Chair 2018-07-06 RFC 8011 Defined TXT keys: See BonjourPrinting.pdf.
ipps 631 tcp Internet Printing Protocol over HTTPS IESG IETF Chair 2018-07-06 RFC 8011
bmpp 632 tcp bmpp Troy Rollo Troy Rollo
bmpp 632 udp bmpp Troy Rollo Troy Rollo
servstat 633 tcp Service Status update (Sterling Software) Greg Rose Greg Rose
servstat 633 udp Service Status update (Sterling Software) Greg Rose Greg Rose
ginad 634 tcp ginad Mark Crother Mark Crother
ginad 634 udp ginad Mark Crother Mark Crother
rlzdbase 635 tcp RLZ DBase Michael Ginn Michael Ginn
rlzdbase 635 udp RLZ DBase Michael Ginn Michael Ginn
ldaps 636 tcp ldap protocol over TLS/SSL (was sldap) Pat Richard Pat Richard
ldaps 636 udp ldap protocol over TLS/SSL (was sldap) Pat Richard Pat Richard
lanserver 637 tcp lanserver Chris Larsson Chris Larsson
lanserver 637 udp lanserver Chris Larsson Chris Larsson
mcns-sec 638 tcp mcns-sec Kaz Ozawa Kaz Ozawa
mcns-sec 638 udp mcns-sec Kaz Ozawa Kaz Ozawa
msdp 639 tcp MSDP Dino Farinacci Dino Farinacci
msdp 639 udp MSDP Dino Farinacci Dino Farinacci
purenoise 663 tcp PureNoise Sam Osa Sam Osa
purenoise 663 udp PureNoise Sam Osa Sam Osa
cycleserv 763 tcp
cycleserv 763 udp
863-872 Unassigned
exp1 1021 tcp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp1 1021 udp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp1 1021 sctp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp1 1021 dccp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 tcp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 udp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 sctp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 dccp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
1023 tcp Reserved 2024-12-20 RFC 6335
1023 udp Reserved 2024-12-20 RFC 6335
1024 tcp Reserved 2024-12-20 RFC 6335
1024 udp Reserved 2024-12-20 RFC 6335
kyoceranetdev 1063 tcp KyoceraNetDev Shigenaka Kanemitsu Shigenaka Kanemitsu
kyoceranetdev 1063 udp KyoceraNetDev Shigenaka Kanemitsu Shigenaka Kanemitsu
sddp 1163 tcp SmartDialer Data Protocol Lee Griffiths Lee Griffiths 2004-11
sddp 1163 udp SmartDialer Data Protocol Lee Griffiths Lee Griffiths 2004-11
dka 1263 tcp dka Chris Griffin Chris Griffin
dka 1263 udp dka Chris Griffin Chris Griffin
ndm-requester 1363 tcp Network DataMover Requester
ndm-requester 1363 udp Network DataMover Requester
nucleus 1463 tcp Nucleus Venky Nagar Venky Nagar
nucleus 1463 udp Nucleus Venky Nagar Venky Nagar
cadabra-lm 1563 tcp Cadabra License Manager Arthur Castonguay Arthur Castonguay
cadabra-lm 1563 udp Cadabra License Manager Arthur Castonguay Arthur Castonguay
oraclenet8cman 1630 tcp Oracle Net8 Cman Tong-Ming Lee Tong-Ming Lee
oraclenet8cman 1630 udp Oracle Net8 Cman Tong-Ming Lee Tong-Ming Lee
visitview 1631 tcp Visit view Tom Whittaker Tom Whittaker
visitview 1631 udp Visit view Tom Whittaker Tom Whittaker
pammratc 1632 tcp PAMMRATC
pammratc 1632 udp PAMMRATC
pammrpc 1633 tcp PAMMRPC John Britton John Britton
pammrpc 1633 udp PAMMRPC John Britton John Britton
loaprobe 1634 tcp Log On America Probe James Tavares James Tavares
loaprobe 1634 udp Log On America Probe James Tavares James Tavares
edb-server1 1635 tcp EDB Server 1 Carlos Portela Carlos Portela
edb-server1 1635 udp EDB Server 1 Carlos Portela Carlos Portela
isdc 1636 tcp ISP shared public data control
isdc 1636 udp ISP shared public data control
islc 1637 tcp ISP shared local data control
islc 1637 udp ISP shared local data control
ismc 1638 tcp ISP shared management control Nick Austin Nick Austin
ismc 1638 udp ISP shared management control Nick Austin Nick Austin
cert-initiator 1639 tcp cert-initiator
cert-initiator 1639 udp cert-initiator
netview-aix-3 1663 tcp netview-aix-3
netview-aix-3 1663 udp netview-aix-3
pptp 1723 tcp pptp Ken Crocker Ken Crocker 2021-09-21 RFC 2637
pptp 1723 udp pptp Ken Crocker Ken Crocker 2021-09-21 RFC 2637
cft-2 1763 tcp cft-2 Martine Marchand Martine Marchand
cft-2 1763 udp cft-2 Martine Marchand Martine Marchand
msnp 1863 tcp MSNP William Lai William Lai
msnp 1863 udp MSNP William Lai William Lai
webmachine 1963 tcp WebMachine Tim Jowers Tim Jowers
webmachine 1963 udp WebMachine Tim Jowers Tim Jowers
icg-bridge 2063 tcp ICG Bridge Port
icg-bridge 2063 udp ICG Bridge Port

Contact Information

Name Organization Contact URI Last Updated
Alain Durand Alain.Durand&imag.fr
Andreas Terzis terzis&cs.ucla.edu
Arthur Castonguay arthurc&doe.carleton.ca
Carlos Portela cportela&simple-sw.com 2003-02
Chris Griffin cgriffin&dka.com
Chris Larsson clarsson&vnet.ibm.com
Dino Farinacci dino&cisco.com 2008-08-21
Greg Rose Greg_Rose&sydney.sterling.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
James Tavares Log On America krontor&loa.com
John Britton johnb&peakaudio.com
John Hadjioannou john&minster.co.uk
Kaz Ozawa k.ozawa&cablelabs.com
Ken Crocker kcrocker&microsoft.com
Lee Griffiths lg&dataconnection.com 2004-11
Mark Crother mark&eis.calstate.edu
Martine Marchand tel:+16-1-46-59-24-84
Michael Ginn ginn&tyxar.com
Nick Austin ogmion&ogmium.com
Pat Richard patr&xcert.com
Rickard Schoultz schoultz&sunet.se
Sam Osa pristine&mailcity.com
Shigenaka Kanemitsu Shigenaka_Kanemitsu&ypd.kyocera.co.jp
Tim Jowers Tim.Jowers&columbiasc.ncr.com
Tom Whittaker tomw&ssec.wisc.edu
Tong-Ming Lee tmlee&us.oracle.com
Troy Gau troy&zyxel.com
Troy Rollo troy&kroll.corvu.com.au
Venky Nagar venky&fafner.stanford.edu
William Lai wlai&microsoft.com