Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-11-10

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
0 tcp Reserved 2024-12-20 RFC 6335
0 udp Reserved 2024-12-20 RFC 6335
servstat 633 tcp Service Status update (Sterling Software) Greg Rose Greg Rose
servstat 633 udp Service Status update (Sterling Software) Greg Rose Greg Rose
exp1 1021 tcp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp1 1021 udp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp1 1021 sctp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp1 1021 dccp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 tcp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 udp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 sctp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 dccp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
1023 tcp Reserved 2024-12-20 RFC 6335
1023 udp Reserved 2024-12-20 RFC 6335
1024 tcp Reserved 2024-12-20 RFC 6335
1024 udp Reserved 2024-12-20 RFC 6335
pammrpc 1633 tcp PAMMRPC John Britton John Britton
pammrpc 1633 udp PAMMRPC John Britton John Britton
interintelli 2633 tcp InterIntelli Mike Gagle Mike Gagle
interintelli 2633 udp InterIntelli Mike Gagle Mike Gagle
wacp 3633 tcp Wyrnix AIS port Harry T. Vennik Harry T. Vennik 2002-11
wacp 3633 udp Wyrnix AIS port Harry T. Vennik Harry T. Vennik 2002-11
beorl 5633 tcp BE Operations Request Listener Chirag Desai Chirag Desai 2006-02
beorl 5633 udp BE Operations Request Listener Chirag Desai Chirag Desai 2006-02
6633 tcp Reserved
cisco-vpath-tun 6633 udp Cisco vPath Services Overlay Cisco Surendra Kumar 2012-06-11
pmdfmgt 7633 tcp PMDF Management Hunter Goatley Hunter Goatley
pmdfmgt 7633 udp PMDF Management Hunter Goatley Hunter Goatley
9633-9639 Unassigned
18517-18633 Unassigned
45967-46335 Unassigned
inedo 46336 tcp Listen port used for Inedo agent communication Inedo Steve Dennis 2016-01-12
46336 udp Reserved
46337-46997 Unassigned
49151 Reserved 2024-12-20 RFC 6335

Contact Information

Name Organization Contact URI Last Updated
Chirag Desai Chirag_Desai&symantec.com 2006-02
Cisco smkumar&cisco.com 2012-06-11
Greg Rose Greg_Rose&sydney.sterling.com
Harry T. Vennik htvennik&zonnet.nl 2002-11
Hunter Goatley goathunter&goatley.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Inedo support&inedo.com 2016-01-12
John Britton johnb&peakaudio.com
Mike Gagle MikeG&inter-intelli.com
Steve Dennis sdennis&inedo.com 2016-01-12
Surendra Kumar Cisco smkumar&cisco.com 2012-06-11